Page 1 of 1

kan ikke logge ind som admin, hjælp

Posted: Sat Oct 16, 2010 8:00 pm
by Martin_Nielsen
Hej Alle
Håber meget nogen kan hjælpe mig. Skal siges jeg er temmelig ny med Joomla og har indtil videre været ret tilfreds. Jeg har læst og forsøgt rigtig meget, men stadig ingen løsning. Mit problem er jeg ikke logge ind som admin mere, men selve sitet virker fint. Det er kun via backend da jeg ikke har aktiveret det på frontend. Den går bare i loop og selv om jeg bevidst skriver forkert kommer der intet med forkert bruger navn eller password. Her er nogle af de ting jeg har forsøgt:

- Jeg har flere gange ændret password via mysql, men uden held.
- Har kigget på jos_plugin, men id5 står allerede som 1 under published
- min session_path skulle gerne stå som writeable
- jeg har forsøgt at overføre til localhost, men kan heller ikke logge ind som admin her
- min $tmp_path i configuration_php ser fin ud og gør de andre også

Kan snart ikke finde på mere og vil nødigt begynde forfra. Håber nogen kan hjælpe.

mvh
Martin

Re: kan ikke logge ind som admin, hjælp

Posted: Sat Oct 16, 2010 8:43 pm
by b-ronnow

Re: kan ikke logge ind som admin, hjælp

Posted: Sat Oct 16, 2010 9:33 pm
by Martin_Nielsen
Desværre. Men tak alligevel

Re: kan ikke logge ind som admin, hjælp

Posted: Sun Oct 31, 2010 10:03 pm
by Hyy
Jer er også newbie,så det jeg kommer med er kun forslag, men det er også sket for mig et par gange.
Den ene gang tømte jeg cachen på browseren, altså bare slette alt, og så opdatere siden.
Den anden gang var det fordi jeg kun havde skiftet navn og kode i databasen og ikke i joomla(håber ikke jeg husker forkert). Prøv at skifte tilbage til det gamle kodeord.

Re: kan ikke logge ind som admin, hjælp

Posted: Mon Nov 01, 2010 7:34 am
by Martin_Nielsen
Hej Hyy
Jeg prøvede alle tænkelige metoder, men ingenting hjalp. Det endte med en total geninstallering af joomla, databaser og alt andet på localhost og så en overførsel fra serveren. Dette hjalp, så jeg kunne logge ind fra localhost, men overflytningen til serveren lavede det samme nummer igen.

Men... Nu ser det ud til jeg har fundet løsningen. Faldt tilfældigt over en tråd, hvor det var nævnt. Det viser sig at notepad, indsætter en skjult kode i configuration-filen, når den er på dansk, efter man har åbnet den, rettet og så gemmer den igen. Denne kode kan joomla så ikke helt finde ud af, når man overflytter filen til webserveren.
Løsningen er slet ikke at bruge notepad til ændringer. I stedet er jeg gået over til at bruge crimson editor. Her kan den tidligere notepad configuration-fil åbnes. Under document - encoding type, ændres der fra UTF-8 (with BOM) til UTF-8 (w/o BOM). Notepad har gemt det som UTF-8 (with BOM) og det er det, der kan skabe problemer. Det løste problemet for mig. Tænk noget så banalt, skal skabe så mange problemer og jeg har virkelig brugt lang tid på det.

Så håber andre hurtigere kan få løst det eventuelle problem.

Re: kan ikke logge ind som admin, hjælp

Posted: Mon Nov 01, 2010 7:39 am
by solsikkehaven
for windows brugere: Man kan også hente det gratis værktøj notepad++ som er notepad på steroider. Inkluderer support af UTF-8 uden BOM osv.

Re: kan ikke logge ind som admin, hjælp

Posted: Mon Nov 01, 2010 7:42 am
by Martin_Nielsen
ahh... super. vidste jeg ikke. Jeg ved heller ikke helt, hvordan jeg får sat et grønt flueben på tråden :)

Re: kan ikke logge ind som admin, hjælp

Posted: Mon Nov 01, 2010 7:49 am
by solsikkehaven
grønt flueben = sættes i det første, oprindelige indlæg i denne tråd.

Re: kan ikke logge ind som admin, hjælp

Posted: Mon Nov 01, 2010 8:07 am
by Martin_Nielsen
ok. Jeg kan bare ikke rigtigt ændre det. Muligheden for edit er der ikke. Men det er i hvert fald blevet løst.

Re: kan ikke logge ind som admin, hjælp

Posted: Mon Nov 01, 2010 9:04 am
by solsikkehaven
det er noget med at hvis der går for lang tid, så kan man ikke ændre indlægget. Så alt er OK.

Re: kan ikke logge ind som admin, hjælp

Posted: Thu Oct 11, 2012 5:05 pm
by Danjou
Hej forum
jeg har netop selv stået i samme situation og bare ikke kunne finde hoved eller hale på noget..

men så slog det mig at jeg havde sat mit domænenavn i cookies og det gjorde at jeg ikke kunne logge ind via admin sektionen..

løsningen var at åbne conf og ændre filen til: public $cookie_domain = '';
save og vupti så var der igen adgang.. håber at det kan hjælpe andre i samme situation :)