Brug af Sprites på forside

Her kan du spørge om hjælp til design, templates og css.

Moderator: b-ronnow

Locked
Mr DK
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Wed Aug 04, 2010 11:50 am

Brug af Sprites på forside

Post by Mr DK » Thu Jan 06, 2011 10:11 am

Hej Alle,

På denne forside har jeg brugt Sprites til et billede. Det har virket fint indtil i dag, hvor jeg må have gjort et eller andet.

Inde i Joomla Administrator ser det fint ud i selve redigeringsvinduet. I forhåndsvisning viser den ikke noget og på selve sitet heller intet.

Det er dette site http://michaelhallmauritzen.com.

Er der nogle som har prøvet et lignende problem?

DBH
Kim

 
Gadensgaard
Joomla! Champion
Joomla! Champion
Posts: 6139
Joined: Sat Nov 18, 2006 12:29 pm

Re: Brug af Sprites på forside

Post by Gadensgaard » Thu Jan 06, 2011 10:35 am

hej Kim

Igen tror jeg at du må forklare dit problem lidt nærmere. Der er ingen her der kan gætte sig til hvad du gerne vil opnå, hvordan det har set ud tidligere, eller hvordan det er meningen det skal se ud.

PS: Hvorfor i alverden lægger du din tekst ind som billeder? Det ødelægger vel hele pointen med et CMS..?

Mr DK
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Wed Aug 04, 2010 11:50 am

Re: Brug af Sprites på forside

Post by Mr DK » Thu Jan 06, 2011 12:37 pm

Ok det kan jeg godt se.

På forsiden skal der til venstre for teksten (som er et billede) være en knap/link, som skal have tre forskellige tilstande. Til dette har brugt Sprutes og skrevet følgende ind i /template/templatenavn/template.css


#HomePlayknap2{position:relative;}
#HomePlayknap2 li{margin:0;padding:0;list-style:none;position:absolute;top:0;}
#HomePlayknap2 li, #HomePlayknap2 a{height:341px;display:block;}

#knap2{left:0px;width:428px;}
#knap2{background:url(../../images/Home_PLAY_TreStadier.jpg) 0 0;}
#knap2 a:hover{background: url(../../images/Home_PLAY_TreStadier.jpg) 0 -45px;}

Det kalder jeg så i min artikel på følgende måde

<div id="samlet">
<div style="float: left;"><img alt="HOME_Tekst" src="images/stories/Billeder til Site Nov 2010/Home/HOME_Tekst.png" width="512" height="407" /></div>
<div style="position: relative; top: 40px; right: -540px;">
<ul id="HomePlayknap2" style="border-style: none;">
<li id="knap2"><a href="default.asp" style="border-style: none;"></a></li>
</ul>
</div>
<div style="clear: both;"></div>
</div>

Men den viser ikke noget billede?

Er det min URL som er forkert?

Kan simpelthen ikke finde fejlen...

Tak

PS At teksten er billeder skal også ændres på et senere tidspunkt.

Gadensgaard
Joomla! Champion
Joomla! Champion
Posts: 6139
Joined: Sat Nov 18, 2006 12:29 pm

Re: Brug af Sprites på forside

Post by Gadensgaard » Thu Jan 06, 2011 6:15 pm

Det ser ud til at du har et niveau for lidt i stien til dit billede:

Du har

../../images/Home_PLAY_TreStadier.jpg

men billedet ligger i

../images/Home_PLAY_TreStadier.jpg

 

Locked

Return to “Template, CSS og Design”