Problem IE6 og blank.png sammen med SEO

Alt om søgemaskine optimering og brugervenlige URLs

Moderator: b-ronnow

Locked
User avatar
g14435
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Sun Feb 05, 2006 7:17 pm
Location: Denmark

Problem IE6 og blank.png sammen med SEO

Post by g14435 » Tue Jul 22, 2008 1:01 pm

Hej
Mit logo vises ikke korrekt i IE6

Data: joomla 1.5.4

Konfig backend: SEO Settings
Search Engine Friendly URLs = Yes
Use Apache mod_rewrite = Yes (jeg kører med .htaccess)
Add suffix to URLs = Yes


IE7 og Mozilla firefox
ingen problemer.

IE6
under sider hvor mit logo skal være har jeg har et problem, logoet vises ikke korrekt.
højreklikkes på logoet for jeg denne URL :<...>/produkter/images/blank.png
denne mappe eksisterer ikke.

gør jeg det samme på forsiden af mit site får jeg denne URL<..>/produkter/images/blank.png
her vises logoet korrekt.

/Hesselberg
You do not have the required permissions to view the files attached to this post.
Last edited by zimmik on Thu Jan 01, 2009 5:55 pm, edited 2 times in total.
Reason: Begyndelsesbogstav i overskriften rettet til stort.

User avatar
zimmik
Joomla! Hero
Joomla! Hero
Posts: 2096
Joined: Thu Aug 18, 2005 12:57 pm
Location: Skanderborg, Denmark
Contact:

Re: Problem IE6 og blank.png sammen med SEO

Post by zimmik » Tue Jul 22, 2008 7:07 pm

Løsningen kan være, at gå ind i din templates index.php-fil, og finde det sted hvor der linkes til blank.png. Ret stien til http://ditdomæne.dk/images/blank.png. På den måde har den hele stien til billedet, og den skal ikke forsøge at regne noget om placeringen ud selv.
Last edited by zimmik on Thu Jan 01, 2009 5:56 pm, edited 1 time in total.
Reason: Begyndelsesbogstav i overskriften rettet til stort.
// Simon Milling Mikkelsen

Husk!: Google, og forummets søgefunktion er din ven!

User avatar
g14435
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Sun Feb 05, 2006 7:17 pm
Location: Denmark

Re: Problem IE6 og blank.png sammen med SEO

Post by g14435 » Mon Jul 28, 2008 1:13 pm

Hej Zimmik

Zimmik skrev:
Løsningen kan være, at gå ind i din templates index.php-fil, og finde det sted hvor der linkes til blank.png. Ret stien til http://ditdomæne.dk/images/blank.png. På den måde har den hele stien til billedet, og den skal ikke forsøge at regne noget om placeringen ud selv.

Dette løste desværre ikke problemmet.


Men se her!....I min index fil ligger denne variabel "enable_pngfix" jeg ændrede værdien fra "0" til "1"
Nu er det røde kryds i logoet væk.

$enable_pngfix = ($this->params->get("enablePngfix", 1) == 0)?"false":"true";
$enable_pngfix = ($this->params->get("enablePngfix", 1) == 1)?"false":"true";

/Hesselberg
Last edited by zimmik on Thu Jan 01, 2009 5:56 pm, edited 1 time in total.
Reason: Begyndelsesbogstav i overskriften rettet til stort.


Locked

Return to “SEO”