Page 1 of 1

Hjælp til SEF i Joomla

Posted: Fri Jul 25, 2008 11:26 am
by Lakaj
Jeg har en webshop baseret på Joomla 1.5.4 og Virtuemart 1.1 som jeg har liggende hos Gigahost. For at gøre en lang historie kort har jeg lige fundet ud af at der er noget som hedder SEO og at det nok er noget som jeg bliver nød til at sætte mig lidt ind i ;-) Jeg har derfor netop købt ARTIO JoomSEF 3.1.2 med VW Extension 2.0.0 modul til Joomla som jeg sidder og roder lidt med at få til at virke. Indtil videre går det ikke så godt.

Da jeg forsøgte at installere JoomSEF 3.1.2 fik jeg følgende meddelelse:

ARTIO JoomSEF installed succesfully!
You must first edit the configuration, enable it and save before it will become active.
Checking for .htaccess in Joomla! root...
not found.
Successfully created .htaccess file in your Joomla! root with the following content:
og så videre, og så videre...

Men i roden af Joomla har jeg nu både en fil som hedder .htaccess og en fil som hedder htaccess.txt

Efter installationen kan jeg ikke længere komme ind på webshoppen med min browser. Jeg får i stedet denne fejlmeddelelse:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

Jeg har derfor kontaktet ARTIO og fået dette svar som jeg ikke forsår noget som helst af:

Hello,
Please, check that your server hosting allows the .htaccess file usage and that it has the mod_rewrite installed in Apache.
Best regards,
ARTIO Support Team

Jeg håber meget I kan besvare spørgsmålet og hjælpe mig og forklare mig lidt bedre hvad det er jeg skal.

Re: Hjælp til SEF i Joomla

Posted: Fri Jul 25, 2008 12:00 pm
by tresan
Hvilken webhotel udbyder?

Kommenter linket med Symlinks i starten af .htaccess filen ud med ## foran linien og prøv så igen.

En del udbydere understøtter ikke symbolic links i htaccess (f.eks. one.com)

Re: Hjælp til SEF i Joomla

Posted: Fri Jul 25, 2008 12:32 pm
by Lakaj
Det er Gigahost.

Den nye .htaccess fil som blev tilføjet i roden af Joomla i forbindelse med ARTIO installationen indeholder følgende linier:


DirectoryIndex index.php
RewriteEngine On
RewriteBase /mexicovask

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$ [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits


Hvad er det for en linie du mener? Er det evt. i den anden fil htaccess.txt det skal ændres?
.htaccess filen ligger ved siden af den htaccess.txt fil der lå der i roden i forvejen - skal de ligge der begge to?

Re: Hjælp til SEF i Joomla

Posted: Fri Jul 25, 2008 2:12 pm
by tresan
RewriteBase /mexicovask

Dit website ligger vel ikke på domæne.dk/mexicovask - så derfor skal du kommentere rewritebase ud.

Re: Hjælp til SEF i Joomla

Posted: Fri Jul 25, 2008 8:02 pm
by Lakaj
Jeg har prøvet at redigere i .htaccess ved at sætte ## foran RewriteBase /mexicovask
Jeg har prøvet at redigere i htaccess.txt ved at sætte ## foran Options +FollowSymLinks

Ingen af delene har hjulpet.

Jeg har også prøvet på at udføre installation på webshoppen på min lokale WAMP server, men her er problemet det samme.

Har I andre gode forslag, for jeg er helt på bar bund ?

Re: Hjælp til SEF i Joomla

Posted: Sat Jul 26, 2008 8:13 am
by tresan
Prøv og kommenter directory index ud også (du behøver ikke kommentare symlinks ud på giga).

Ellers er der ikke noget i vejen med din htaccess fil.

Re: Hjælp til SEF i Joomla

Posted: Sat Jul 26, 2008 10:33 am
by Lakaj
Det hjalp heller ikke - det er saftsuseme sært.
Det eneste der ændrer noget er hvis jeg sletter .htaccess filen så jan jeg komme ind på hjemmesiden igen både frontend og backend - og sågar åbne ARTIO JoomSEF komponenten i backend. Men det er da vel ikke det der er meningen at man skal?

Kan det måske så i stedet være noget i htaccess.txt der skal ændres?
Eller måske en kombination at ting i både .htaccess og htaccess.txt der skal ændres?

Min htaccess.txt fil ser sådan ud:

##
# @version $Id: htaccess.txt 10492 2008-07-02 06:38:28Z ircmaxell $
# @package Joomla
# @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##


#####################################################
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
#
#####################################################

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

#
# mod_rewrite in use

RewriteEngine On

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root)

# RewriteBase /


########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$ [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section

Re: Hjælp til SEF i Joomla

Posted: Sat Jul 26, 2008 11:12 am
by tresan
Du skal slet ikke bruge htaccess.txt det er bare filens navn inden man omdøber den til .htaccess som er det filen skal hedde.

Hvis din fil ikke virker med de ting jeg har foreslået ligger fejlen ikke i din .htaccess fil men derimod i dit site eller opsætningen af artiosef.

Re: Hjælp til SEF i Joomla

Posted: Mon Jul 28, 2008 10:24 am
by KimM
Den fejlmelding du kommer skriver, at .htaccess ikke eksiterer, så derfor har Artio SEF oprettet den.

Det kan tyde på, at du ikke tidligere har omdøbt htaccess.txt til .htaccess.

Prøv følgende: Kopier alt fra din htaccess.txt over i din .htaccess fil og se om det giver noget.