yvComment - Comments extension for Joomla! 1.5

This forum is for general questions about extensions for Joomla! version 1.5.x.

Moderators: General Support Moderators, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
MikeSaville
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Jan 22, 2008 4:36 pm

Re: yvComment - Comments extension for Joomla! 1.5

Post by MikeSaville » Mon Feb 25, 2008 2:41 pm

This is a fantastic extension, thanks. One query though- another member asked way back in an earlier page and I haven't seen an answer, so forgive me if I've overlooked it.

The question raised was, for privacy reasons, is it possible to set the displayed name of a commenter to the user name, not the actual name? It is very important to many sites in view of data protection, etc.

If there is no plan to implement this en masse, is there a way I can edit it myself on one of the PHP files so it will draw the information from the preferred fields?

Thanks in advance. Great project :)

Mike

bokonon
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Wed Dec 26, 2007 1:50 am
Location: Serbia
Contact:

Re: yvComment - Comments extension for Joomla! 1.5

Post by bokonon » Mon Feb 25, 2008 2:59 pm

Hi there! The bigocaptcha plugin works perfectly in the offline version of my website, but it doesn't work on the server. You can check it out here:

http://serbiatravelers.org/cms/index.ph ... je?start=3

As you can see, instead of the picture with letters, I just get the alt text "The word for verification. Lowercase letters only with no spaces."

Maybe I should change permissions on some folders? I tried erasing and then installing the captcha plugin again, but to no avail. Any ideas?

Thanx,
Lazar

User avatar
yvolk
Joomla! Guru
Joomla! Guru
Posts: 979
Joined: Thu Jun 01, 2006 1:52 pm
Location: Moscow, Russia
Contact:

Re: yvComment - Comments extension for Joomla! 1.5

Post by yvolk » Mon Feb 25, 2008 4:13 pm

bokonon wrote:Hi there! The bigocaptcha plugin works perfectly in the offline version of my website, but it doesn't work on the server...
Please, look into the Bigo Captcha thread and post your report there, if necessary!

ewel
Joomla! Guru
Joomla! Guru
Posts: 522
Joined: Mon Oct 01, 2007 11:35 am

Re: yvComment - Comments extension for Joomla! 1.5

Post by ewel » Mon Feb 25, 2008 4:32 pm

In category blogs I have "Comments (1) " or a link to submit comments under each article intro. I would like to prevent yvComment from showing anything at all in section or category blog views, I always like to keep those pages free from plugins.

Where in the code could I try to make a modification to achieve that yvComment will not display anything in section or category blog views?

User avatar
yvolk
Joomla! Guru
Joomla! Guru
Posts: 979
Joined: Thu Jun 01, 2006 1:52 pm
Location: Moscow, Russia
Contact:

Re: yvComment - Comments extension for Joomla! 1.5

Post by yvolk » Mon Feb 25, 2008 4:46 pm

ewel wrote:In category blogs I have "Comments (1) " or a link to submit comments under each article intro. I would like to prevent yvComment from showing anything at all in section or category blog views, I always like to keep those pages free from plugins.
This is configurable. Please see description of the "Link 'Comments(n)' text to some other page" option.

ewel
Joomla! Guru
Joomla! Guru
Posts: 522
Joined: Mon Oct 01, 2007 11:35 am

Re: yvComment - Comments extension for Joomla! 1.5

Post by ewel » Mon Feb 25, 2008 5:38 pm

I don't think that option removes yvComment output from the front page and section/blog views altogether.

If I set that option to 'Comments of one Article' my front page and blog views have a "Add your comment" link. Likewise if I set it to 'Article page with comments'. If I set it to 'No' I get "Comments (0)" in my front page and blog views.

What I am after it that I don't get either that "Add your comment" link or "Comments (0)".

User avatar
yvolk
Joomla! Guru
Joomla! Guru
Posts: 979
Joined: Thu Jun 01, 2006 1:52 pm
Location: Moscow, Russia
Contact:

Re: yvComment - Comments extension for Joomla! 1.5

Post by yvolk » Mon Feb 25, 2008 6:31 pm

ewel wrote:I don't think that option removes yvComment output from the front page and section/blog views altogether.

If I set that option to 'Comments of one Article' my front page and blog views have a "Add your comment" link. Likewise if I set it to 'Article page with comments'. If I set it to 'No' I get "Comments (0)" in my front page and blog views.

What I am after it that I don't get either that "Add your comment" link or "Comments (0)".
Read another time: there is third value there: "Hide" ;)

ewel
Joomla! Guru
Joomla! Guru
Posts: 522
Joined: Mon Oct 01, 2007 11:35 am

Re: yvComment - Comments extension for Joomla! 1.5

Post by ewel » Mon Feb 25, 2008 8:20 pm

It wasn't in my older version, but now that I updated to the latest version I can see that option. Thanks!

bokonon
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Wed Dec 26, 2007 1:50 am
Location: Serbia
Contact:

Re: yvComment - Comments extension for Joomla! 1.5

Post by bokonon » Mon Feb 25, 2008 10:06 pm

Since there seems to be no way to make my Bigo Captcha show the image with letters, is there any other captcha plugin that works with yvComment? Thanx.

abacotc
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Sat Oct 27, 2007 8:22 pm

Re: yvComment - Comments extension for Joomla! 1.5

Post by abacotc » Tue Feb 26, 2008 12:08 am

Hi Yuri, great extension. I have a couple of quick questions . I am trying change some of the language on the form itself like "Add your Comment" to something else. Is this where I make the change "en-GB.com_yvcomment.ini"?
Also I am using registered users only with Community Builders login instead of Joomla's. I would like the "username" to show up instead of "users real name" for comments. Is there any way to change this?
Thank You

User avatar
izhere
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Fri Sep 14, 2007 1:57 pm
Location: Shanghai,China
Contact:

Re: yvComment - Comments extension for Joomla! 1.5

Post by izhere » Tue Feb 26, 2008 4:15 am

hi yuri,after using yvcomment for months,i suddenly get a basic question:if a user created an ID like "abc",then if he didn't login as "abc",he couldn't add any comment with the username "abc" right? always showing a message "Please choose other alias (Your name), this alias is in use (or it is part of some other existing alias): 'abc'". dose it mean that the users of my site must login before adding any comment?sometimes ppl just wanna add some comment,no need to login

User avatar
izhere
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Fri Sep 14, 2007 1:57 pm
Location: Shanghai,China
Contact:

Re: yvComment - Comments extension for Joomla! 1.5

Post by izhere » Tue Feb 26, 2008 5:13 am

oh well i'm sorry,i should disable the "check guest name".my fault

User avatar
yvolk
Joomla! Guru
Joomla! Guru
Posts: 979
Joined: Thu Jun 01, 2006 1:52 pm
Location: Moscow, Russia
Contact:

Re: yvComment - Comments extension for Joomla! 1.5

Post by yvolk » Tue Feb 26, 2008 6:52 am

abacotc wrote:Hi Yuri, great extension. I have a couple of quick questions . I am trying change some of the language on the form itself like "Add your Comment" to something else. Is this where I make the change "en-GB.com_yvcomment.ini"?
All frontend strings are in
/language/en-GB/en-GB.com_yvcomment.ini
abacotc wrote: Also I am using registered users only with Community Builders login instead of Joomla's. I would like the "username" to show up instead of "users real name" for comments. Is there any way to change this?
Thank You
Please note, that yvComment shows exactly what Joomla! itself shows for the Authors of Articles: "Name" attribute. And it's not configurable (like in Joomla! core for Articles...).
But nobody requres that "Name" to be "Real Name" (There is Joomla! "Contacts" component for real names). You may put some alias there...
If you don't like this, you have to hack the code (Sorry, I can't give exact line to change...)

User avatar
yvolk
Joomla! Guru
Joomla! Guru
Posts: 979
Joined: Thu Jun 01, 2006 1:52 pm
Location: Moscow, Russia
Contact:

Re: yvComment - Comments extension for Joomla! 1.5

Post by yvolk » Tue Feb 26, 2008 7:03 am

bokonon wrote:Since there seems to be no way to make my Bigo Captcha show the image with letters, is there any other captcha plugin that works with yvComment? Thanx.
Please RTFM :)

Mickey974
Joomla! Apprentice
Joomla! Apprentice
Posts: 23
Joined: Mon Feb 04, 2008 8:26 pm

Re: yvComment - Comments extension for Joomla! 1.5

Post by Mickey974 » Tue Feb 26, 2008 8:23 am

Hello, and thank you for your plugin yvolk

it works perfectly.

However, I have a little problem with my template under certain conditions of use. Maybe not you know where it's coming?

I put two links to screenshots that will show you the problem.

When I click on the link commentary (N), my template does not display correctly.

Template poorly displayed

and after a clic on Internet explorer's refresh button, My template is displayed correctly

Template correctly displayed

I also have a link that displays the article with the comments without any problem. That link looks like this:

http://localhost/index.php?option=com_c ... &Itemid=53

and the link on commentary(N) is :

http://localhost/index.php?option=com_c ... #yvComment

Both links displays the same page. The first no problem in the template, not the second.

Do you have an idea of the problem? And if so how to fix it?

Thank you

User avatar
yvolk
Joomla! Guru
Joomla! Guru
Posts: 979
Joined: Thu Jun 01, 2006 1:52 pm
Location: Moscow, Russia
Contact:

Re: yvComment - Comments extension for Joomla! 1.5

Post by yvolk » Tue Feb 26, 2008 8:51 am

Mickey974 wrote:However, I have a little problem with my template under certain conditions of use. Maybe not you know where it's coming?
I also have a link that displays the article with the comments without any problem. That link looks like this:
http://localhost/index.php?option=com_c ... &Itemid=53
and the link on commentary(N) is :
http://localhost/index.php?option=com_c ... #yvComment

Both links displays the same page. The first no problem in the template, not the second.

Do you have an idea of the problem? And if so how to fix it?
As I see, "Search Engine Friendly URLs" don't work for you. So you may try to turn it off in Global configuration (yvComment will follow these settings...)

Mickey974
Joomla! Apprentice
Joomla! Apprentice
Posts: 23
Joined: Mon Feb 04, 2008 8:26 pm

Re: yvComment - Comments extension for Joomla! 1.5

Post by Mickey974 » Tue Feb 26, 2008 11:39 am

thanks for your answer yvolk !

I tested your solution. :'( Don't work. And the problem occurs only when you click on the button Commentary(N). I put links to screenshots to show you what link the problem occurs.

1 - Link 1
link 1 : It's good
Text url : http://localhost/index.php?option=com_c ... &Itemid=53 with Global configuration setting for SEF

Text url : http://localhost/index.php/accueil with Global configuration setting for SEF

Text url : http://localhost/index.php/accueil.html with Global configuration setting for SEF

2 - Link 2
link 2 : It's good
Text url : http://localhost/index.php?option=com_c ... &Itemid=53 with Global configuration setting for SEF

Text url : http://localhost/index.php/accueil/1-la ... leternelle with Global configuration setting for SEF

Text url : http://localhost/index.php/accueil/1-la ... nelle.html with Global configuration setting for SEF

3 - Link 3
link 3 : It's not good
Text url : http://localhost/index.php?option=com_c ... #yvComment with Global configuration setting for SEF

Text url : http://localhost/index.php/accueil/1-la ... #yvComment with Global configuration setting for SEF

Text url : http://localhost/index.php/accueil/1-la ... #yvComment with Global configuration setting for SEF

My question: Is it necessary to place at the end of the url the word : #yvComment ?

My impression is that if you don't place this word (#yvComment) the url works and the browser display correctly the web site (Look at the above urls).

Thanks yvolk

Joomla! 1.5 build 9961 (Stable)
yvComment : v.1.14.0

EDIT :

In the view.html.php file under ..\www\components\com_yvcomment\views\comment, if i put line 197 in a commentary like this :

Code: Select all

	  	default:
	  	  $linkOn = $yvComment->ContentIDToURL($ArticleID);
	  	  if (!($linkOn == '')) {
	  	  	//$linkOn .= '#yvComment';
	  	  }
	  	  break;
the Commentary(N) link works perfectly and the browser display perfectly the template for the web site. The question now is whether this comment will not generate problems elsewhere?

User avatar
yvolk
Joomla! Guru
Joomla! Guru
Posts: 979
Joined: Thu Jun 01, 2006 1:52 pm
Location: Moscow, Russia
Contact:

Re: yvComment - Comments extension for Joomla! 1.5

Post by yvolk » Wed Feb 27, 2008 4:26 am

Mickey974 wrote:When I click on the link commentary (N), my template does not display correctly.
...and after a clic on Internet explorer's refresh button, My template is displayed correctly...

(without #yvComment ) the Commentary(N) link works perfectly and the browser display perfectly the template for the web site. The question now is whether this comment will not generate problems elsewhere?
Of cause, this #yvComment is not necessary, you may easily apply the hack... but the question still remains: what causes the problem?

I think, that most possible cause is in browser, see some similar post
There are only problems with Firefox, when you first time open site with my plugin enabled (Seems like content page is fragmented: on left side: news, on right side: blank). Every next time while you refresh site, everything is OK: it's something like just: "Oh, I understand that I did something wrong, and I have to render site in diffrent way." (words of web browser)
May you test your site with other browsers?

And, I think, you have to inspect HTML code of the page generated (is it valid HTML etc...)

mits
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Sat Sep 08, 2007 3:39 pm

Problems with Digg and yvComment?

Post by mits » Wed Feb 27, 2008 12:51 pm

I have a site under development running Joomla 1.5 and yvComment 1.14 and I tried to Digg an article yesterday but Digg refused and gave me this error:

This link does not appear to be a working link. Please check the URL and try again

I played around with turning SEF off etc. and eventually uploaded a static html file to make sure my domain didn't have a problem. I eventually found that if I turn yvComment off then Digg accepts my URLs but with yvComment enabled none of my site URLs are accepted by Digg.

Anyone have any ideas?

User avatar
yvolk
Joomla! Guru
Joomla! Guru
Posts: 979
Joined: Thu Jun 01, 2006 1:52 pm
Location: Moscow, Russia
Contact:

Re: Problems with Digg and yvComment?

Post by yvolk » Wed Feb 27, 2008 1:40 pm

mits wrote:I have a site under development running Joomla 1.5 and yvComment 1.14 and I tried to Digg an article yesterday but Digg refused and gave me this error:

This link does not appear to be a working link. Please check the URL and try again

I played around with turning SEF off etc. and eventually uploaded a static html file to make sure my domain didn't have a problem. I eventually found that if I turn yvComment off then Digg accepts my URLs but with yvComment enabled none of my site URLs are accepted by Digg.

Anyone have any ideas?
Today I tried to figure this out and couldn't figure out, what exactly digg.com doesn't like.
I think, to find the cause of problem, you have to create static page with the same static content as dynamic page with "yvComment turned on" and edit it (deleting and inserting something...) to figure this out.
Please post your results here!

mits
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Sat Sep 08, 2007 3:39 pm

Re: yvComment - Comments extension for Joomla! 1.5

Post by mits » Wed Feb 27, 2008 1:59 pm

Thanks yvolk,

I just opened up my Joomla page (with yvComment enabled) and made sure Digg refused it. Then I viewed the page source and copied this into a static PHP page and Digg is happy with it!

I'm more confused than ever now - the static version with exactly the same output as the dynamic version is accepted by Digg.

Could it be that Digg's bot sees the pages differently to how the browser does and yvComment somehow affects how the bot sees the page?

User avatar
yvolk
Joomla! Guru
Joomla! Guru
Posts: 979
Joined: Thu Jun 01, 2006 1:52 pm
Location: Moscow, Russia
Contact:

Re: yvComment - Comments extension for Joomla! 1.5

Post by yvolk » Wed Feb 27, 2008 3:15 pm

mits wrote:Could it be that Digg's bot sees the pages differently to how the browser does and yvComment somehow affects how the bot sees the page?
Maybe... you need to log entire page on the server, when digg.com requests it to see the difference... (and to log, what files/URLs digg.com requests...)

mits
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Sat Sep 08, 2007 3:39 pm

Re: yvComment - Comments extension for Joomla! 1.5

Post by mits » Wed Feb 27, 2008 4:21 pm

Digg doesn't get very far - one single line in the log (My IP and domain obscured)

2008-02-27 15:50:50 W3SVC5408 SERVERNAME XX.XX.XX.XX HEAD /index.php - 80 - 64.191.203.34 HTTP/1.1 Mozilla/4.0+(compatible;+MSIE+5.01;+Windows+NT+5.0) - - http://www.domainname.com 200 0 0 594 168 437

I give up! ;-)

mits
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Sat Sep 08, 2007 3:39 pm

Re: yvComment - Comments extension for Joomla! 1.5

Post by mits » Wed Feb 27, 2008 4:33 pm

Just looking and here's what Digg requests when yvComment is disabled:

2008-02-27 16:23:40 W3SVC5408 SERVERNAME XX.XX.XX.XX HEAD /index.php - 80 - 64.191.203.34 HTTP/1.1 Mozilla/4.0+(compatible;+MSIE+5.01;+Windows+NT+5.0) - - http://www.domainname.com 200 0 0 532 164 531
2008-02-27 16:23:41 W3SVC5408 SERVERNAME XX.XX.XX.XX GET /index.php - 80 - 64.191.203.34 HTTP/1.1 PEAR+HTTP_Request+class+(+http://pear.php.net/+) - - http://www.domainname.com 200 0 0 12525 160 828
2008-02-27 16:23:41 W3SVC5408 SERVERNAME XX.XX.XX.XX HEAD /images/M_images/printButton.png - 80 - 64.191.203.34 HTTP/1.1 PEAR+HTTP_Request+class+(+http://pear.php.net/+) - - http://www.domainname.com 200 0 0 298 192 140
2008-02-27 16:23:42 W3SVC5408 SERVERNAME XX.XX.XX.XX HEAD /images/M_images/emailButton.png - 80 - 64.191.203.34 HTTP/1.1 PEAR+HTTP_Request+class+(+http://pear.php.net/+) - - http://www.domainname.com 200 0 0 298 192 156
2008-02-27 16:23:42 W3SVC5408 SERVERNAME XX.XX.XX.XX HEAD /images/M_images/livemarks.png - 80 - 64.191.203.34 HTTP/1.1 PEAR+HTTP_Request+class+(+http://pear.php.net/+) - - http://www.domainname.com 200 0 0 297 190 156
2008-02-27 16:23:42 W3SVC5408 SERVERNAME XX.XX.XX.XX GET /images/M_images/livemarks.png - 80 - 64.191.203.34 HTTP/1.1 PEAR+HTTP_Request+class+(+http://pear.php.net/+) - - http://www.domainname.com 200 0 0 1022 189 156
2008-02-27 16:23:42 W3SVC5408 SERVERNAME XX.XX.XX.XX GET /images/M_images/emailButton.png - 80 - 64.191.203.34 HTTP/1.1 PEAR+HTTP_Request+class+(+http://pear.php.net/+) - - http://www.domainname.com 200 0 0 726 191 156
2008-02-27 16:23:43 W3SVC5408 SERVERNAME XX.XX.XX.XX GET /images/M_images/printButton.png - 80 - 64.191.203.34 HTTP/1.1 PEAR+HTTP_Request+class+(+http://pear.php.net/+) - - http://www.domainname.com 200 0 0 677 191 156


So it's either not getting as far as or sticking on

2008-02-27 16:23:41 W3SVC5408 SERVERNAME XX.XX.XX.XX GET /index.php - 80 - 64.191.203.34 HTTP/1.1 PEAR+HTTP_Request+class+(+http://pear.php.net/+) - - http://www.domainname.com 200 0 0 12525 160 828

Does the PEAR reference give us any clues?

User avatar
yvolk
Joomla! Guru
Joomla! Guru
Posts: 979
Joined: Thu Jun 01, 2006 1:52 pm
Location: Moscow, Russia
Contact:

yvComment v.1.14.1 - fixed work with digg.com

Post by yvolk » Thu Feb 28, 2008 9:54 am

mits wrote:Just looking and here's what Digg requests when yvComment is disabled:
2008-02-27 16:23:40 W3SVC5408 SERVERNAME XX.XX.XX.XX HEAD /index.php - 80 - 64.191.203.34 HTTP/1.1 Mozilla/4.0+(compatible;+MSIE+5.01;+Windows+NT+5.0) - - http://www.domainname.com 200 0 0 532 164 531
Thank you! This was enough for me to make quick fix:
I simply don't execute yvComment's code for 'HEAD' request, something like this:

Code: Select all

if (strtoupper( $_SERVER['REQUEST_METHOD'] ) == 'HEAD') {
	// hide, cause something works wrong in this case	
} elseif
See v.1.14.1 of yvComment.

mits
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Sat Sep 08, 2007 3:39 pm

Re: yvComment - Comments extension for Joomla! 1.5

Post by mits » Thu Feb 28, 2008 10:17 am

Installed and working perfectly with Digg!

Thanks Yuri ;D

Steve.

Mickey974
Joomla! Apprentice
Joomla! Apprentice
Posts: 23
Joined: Mon Feb 04, 2008 8:26 pm

Re: yvComment - Comments extension for Joomla! 1.5

Post by Mickey974 » Sat Mar 01, 2008 10:12 am

yvolk wrote:May you test your site with other browsers?

And, I think, you have to inspect HTML code of the page generated (is it valid HTML etc...)
My web site is valid xhtml transitional 1.0 (validator.org)

I test it with :
Internet Explorer 7.0.7530.11
Safari 3.0.4 523.15
Firefox 2.0.0.12
Opera 9.26 8835

The Commentary(N) link's problem occurs on Internet Explorer, Safari, Firefox. Only Opera display correctly the web site. And if i remove the word #yvComment in the link of Commentary(N), all browsers display correctly the web site.

Have you any idea where is the problem ? And does you understand why if i remove this word (#yvComment) in the url link of Commentary(N), all works ?

Thanks yuri

tonetu
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sat Mar 10, 2007 2:58 pm

Re: yvComment - Comments extension for Joomla! 1.5

Post by tonetu » Sun Mar 02, 2008 6:25 pm

Hi;

This is reallty great component .. thanx :)

how can we change the test align to right-to-left?

also; is there a way to add a link for guests "Add Comment" and when they click on they get send to login/register page?

Regards;

luis.depedro
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Wed Jan 23, 2008 5:03 pm

Re: yvComment - Comments extension for Joomla! 1.5

Post by luis.depedro » Thu Mar 06, 2008 8:11 pm

For some reason, the tag "Add your comment" (in Spanish "Agregue su comentario") appears on the same line as the title of the next article, forcing it to break in two. How can I make it appear on the line higher of the next article's title?

TheMBC
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Fri Mar 07, 2008 10:02 pm

Re: yvComment - Comments extension for Joomla! 1.5

Post by TheMBC » Sat Mar 08, 2008 1:25 am

Okay, I fixed my problem. It's a great plugin! However, it should work without each article having to be Comments >> Unsorted Comments.


Locked

Return to “Extensions for Joomla! 1.5”