Joomla V 1.5.0 - I can not install ANY extensions

This forum is for general questions about extensions for Joomla! version 1.5.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
ryansdistrict
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Sun Sep 16, 2007 11:11 pm
Contact:

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by ryansdistrict » Wed Dec 12, 2007 2:25 pm

it does but the error below is appearing


Warning: array_push() [function.array-push]: First argument should be an array in /home/ryan/public_html/about-lebanon/includes/menu.php on line 67

Fatal error: Maximum execution time of 30 seconds exceeded in /home/ryan/public_html/about-lebanon/modules/mod_mainmenu/helper.php on line 46

 
soupman
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Dec 10, 2007 9:38 pm
Location: Tampa

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by soupman » Wed Dec 12, 2007 8:01 pm

I have been following this thread looking for an answer to easily use the extension manager. I have changed file permissions and have upgraded to PHP 5.2.4 as that was pointed out with no success. I have installed this on a Windows box and everything works fine - the problem seems to be running Joomla on Linux.
I believe the root of this problem to be the install process and the ftp layer as I cannot verify a valid ftp account which would handle the permissions.
I have not been working that long with Linux and as a recent convert it is at times frustrating.

Is there something wrong with MY ftp "ProFTPD" installation, that is cascading down and creating a problem for Joomla? or is this a bug in Joomala?

Can anyone assist me in getting these extensions to work?

Here is the system:

Linux ######.com 2.6.23.1-21.fc7 #1 SMP Thu Nov 1 21:09:24 EDT 2007 i686 i686 i386 GNU/Linux
XAMPP for Linux 1.6.4
Apache 2.2.6
MySQL 5.0.45
PHP 5.2.4 & 4.4.7
PEAR + SQLite 2.8.17/3.3.17
ProFTPD 1.3.1

On install this is the 1st  error message:

:'( The FTP settings are not valid or your FTP server is not compatiblewith Joomla!: The function "STOR" failed.

Moving on we SELECT NO in the ftp install -(doesn't matter I tried both yes and no)

Try to install from upload:
Upload Package File
Package File: com_puarcade_2_1_2b.zip
:'( Warning! - Failed to move file

Try from a directory:
Install from Directory
:'( Install Directory:/opt/lampp/htdocs/joomla/com_puarcade_2_1_2b.zip_FILES

Your Extension appears to be written for an older version of Joomla!. You must enable the System - Legacy Plugin in the Plugin Manager if you wish to complete this task.

Enable Legacy support: DONE


Try again from a directory:
Install from Directory
Install Directory:/opt/lampp/htdocs/joomla/com_puarcade_2_1_2b.zip_FILES


        * JFolder::create: Could not create directory
        * Component Install: Failed to create directory: "/opt/lampp/htdocs/joomla/components/com_puarcade"

I cannot get past this point, chmod files and folder it ends here.

UPDATE
--------------------------
I am able to now install components by chmod 777 the following files. It is by no means the correct way-which is fixing "MY" ftp client. I don't think joomla 1.5 is bugged it is just that the developers have assumed everyones ftp is configured properly- mine is not and not having a lot of experience with Linux well it simply isn't the developers fault but they may want to take this into consideration.

administrator/backups
administrator/components
administrator/modules
administrator/templates
cache
components
images
images/banners
images/stories
language
media
modules
templates

Change file permission back when done!
Last edited by soupman on Fri Dec 14, 2007 4:19 pm, edited 1 time in total.

wene
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 203
Joined: Sat Aug 20, 2005 1:40 am
Location: south of France

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by wene » Tue Dec 18, 2007 12:56 am

the problem is not solved for my opinion.
i think that it depends on the file sizes.
i can install small components but not biggers.
i cant change my folders permissions because i use a shared hosting.
i have all the directory writable in
administrator/index.php?option=com_admin&task=sysinfo
im not able to enable the ftp layer too

edit: my hoster has disabled ftp from php... ok, so i can forget j1.5 extensions now ....
Last edited by wene on Tue Dec 18, 2007 11:22 pm, edited 1 time in total.

Chishiki
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Dec 19, 2007 4:09 pm

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by Chishiki » Wed Dec 19, 2007 4:45 pm

Hello,

Allow me, as a relatively novice user, to throw my two cents in...

I've never had any problems whatsoever with Joomla 1.0.x, and I've done dozens of Joomla installs. Many a client were led to believe that I actually knew something about PHP thanks to Team Joomla's efforts. I really need Joomla 1.5 for its utf-8 support (my clients are Japanese) and am dying to get this working.

Gentoo linux, apache, mysql, php... all the latest and greatest current stable versions installed... LAMP should be a go... but no. Server admin doesn't allow FTP access (WinSCP OK though) so I have to resort to CHMODing directories. 1.0.x always helpfully told me which directories to CHMOD, but RC3 doesn't it.

It installs seamlessly, which seemed surprising, I was expecting to have to change directory permissions. Skeptical, I tried to upload an extension. It naturally told me to get hosed.

I spent 30 minutes trying to find a list of which 1.5 directories I should CHMOD to no avail... the install did work fine when I put all directories on 777, but that just seems like ridiculous overkill, and asking for trouble. Can anybody post a simple list of directories that need to be writable?

whitebirch
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 183
Joined: Wed Oct 25, 2006 9:47 pm

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by whitebirch » Wed Dec 19, 2007 4:52 pm

I have been following this post.  I also couldn't install any components, mods, or plug-ins.  I wasn't to concerned because I was hacked prior to my rebuild and I felt safer knowing I didn't have anything installed with security holes.  I ended up wanting to install some stuff I bought for my pre-hacked site so I upgraded my Joomla 1.5RC3 to the latest nightly build, turned off my FTP, and everything works fine.  I am running the latest build, like I had mentioned, under PHP5, which solved all of my previous issues I was having under PHP4.3.  The only thing I set to chmod 777 is the folders/files Joomla tells me that are writable/unwritable.  When I finish my installs I simple set them back to 755.

Chishiki
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Dec 19, 2007 4:09 pm

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by Chishiki » Thu Dec 20, 2007 6:56 am

I didn't see anything in the web install that told me which files / directories to CHMOD...?
The only thing I set to chmod 777 is the folders/files Joomla tells me that are writable/unwritable.
Could I impose upon you and get you to tell me which folders? If they are exactly the same as Joomla 1.0.x installs no problem I guess... but I'd like to know for sure.

whitebirch
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 183
Joined: Wed Oct 25, 2006 9:47 pm

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by whitebirch » Thu Dec 20, 2007 2:18 pm

It is up by the Joomla help. It'll tell you what is writable and what isn't. For modifications they need to be writable and for security they need to be unwritable. 

j.yumi
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Fri Dec 21, 2007 6:09 am

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by j.yumi » Fri Dec 21, 2007 12:40 pm

Thank you soupman! The list of directories to chmod 777 worked for me!

Michael

sabounchi
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sat Dec 22, 2007 4:30 am

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by sabounchi » Wed Dec 26, 2007 1:02 am

I have the same problem and using the latest 1.5 version 4

User avatar
darb
Joomla! Ace
Joomla! Ace
Posts: 1658
Joined: Thu Jul 06, 2006 12:57 pm
Location: Stockholm Sweden
Contact:

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by darb » Fri Dec 28, 2007 10:08 am

sabounchi wrote: I have the same problem and using the latest 1.5 version 4
Same here about execution time....Try to install JoomlaExplorer first but can not... so I can do some settings to a USB pendrive I have.

Got this error
Fatal error: Maximum execution time of 30 seconds exceeded in W:\var\www\webb\libraries\joomla\filesystem\file.php on line 298
Success in the long run Its not about the code its about the people and community that's make it!
Its not what you say its what you do that matters!

Darb - aka ssnobben

User avatar
darb
Joomla! Ace
Joomla! Ace
Posts: 1658
Joined: Thu Jul 06, 2006 12:57 pm
Location: Stockholm Sweden
Contact:

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by darb » Fri Dec 28, 2007 10:39 am

Strange. :-\

I used the Wamp on my local c: directory and with a english version then I could install JoomlaExplorer but then when I switch to an J 1.5 with another language (swedish) I could not install this first component - JoomlaExplorer.

Got this errors
      * JFolder::create: ??Infinite loop detected??
        * •Varning - Failed to move the file (Misslyckades att flytta filen)•
        * JFile::read: ??Unable to open file??: 'W:\var\www\karinawebb\tmp\com_joomlaxplorer_1.6.2.tar.gz'
        * Unable to read archive


Warning: fopen(W:\var\www\karinawebb\tmp\com_joomlaxplorer_1.6.2.tar.gz) [function.fopen]: failed to open stream: No such file or directory in C:\wamp\www\karinawebb\libraries\joomla\filesystem\file.php on line 240
•Dont find the installation package (Hittar inte ett installationspaket)•
•Load package (Ladda upp paket)•
•Package file (Paketfil)•:
•Install from catalogue (Installera från katalog)•
•Installation catalogue (Installationskatalog)•:
•Install from URL (Installera från URL)•
•Installation -URL (Installations-URL)•:

Joomla! •är fri programvara publicerad under GNU/GPL Licensen.•
•Profile information•
Application afterLoad: 0.002 seconds, 0.35 MB
Application afterInitialise: 0.064 seconds, 2.67 MB
Application afterRoute: 0.065 seconds, 2.67 MB
Application afterDispatch: 0.132 seconds, 4.95 MB
Application afterRender: 0.189 seconds, 5.71 MB
•Memoryusage•
6034368
•12 questions logged•

  1.
      SELECT *
        FROM jos_session
        WHERE session_id = 'f0db3d2b7febb1bf85191e17610ef2d3'
  2.
      DELETE
        FROM jos_session
        WHERE ( time = 1
        AND access "com_frontpage"
        AND `option` "com_media"
        AND enabled = 1
        ORDER BY ordering, name
  11.
      SELECT COUNT(*)
        FROM jos_messages
        WHERE state = 0
        AND user_id_to = 62
  12.
      SELECT COUNT( session_id )
        FROM jos_session
        WHERE guest 1

•Loaded languages files.  (Laddade språkfiler)•

    * C:\wamp\www\karinawebb\administrator\language\sv-SE\sv-SE.ini 1
    * C:\wamp\www\karinawebb\administrator\language\sv-SE\sv-SE.plg_system_debug.ini 1
    * C:\wamp\www\karinawebb\administrator\language\sv-SE\sv-SE.com_installer.ini 1
    * C:\wamp\www\karinawebb\administrator\language\sv-SE\sv-SE.tpl_khepri.ini 1
    * C:\wamp\www\karinawebb\administrator\language\sv-SE\sv-SE.mod_submenu.ini 1
    * C:\wamp\www\karinawebb\administrator\language\sv-SE\sv-SE.mod_title.ini 1
    * C:\wamp\www\karinawebb\administrator\language\sv-SE\sv-SE.mod_toolbar.ini 1
    * C:\wamp\www\karinawebb\administrator\language\sv-SE\sv-SE.mod_menu.ini 1
    * C:\wamp\www\karinawebb\administrator\language\sv-SE\sv-SE.com_contact.menu.ini 1
    * C:\wamp\www\karinawebb\administrator\language\sv-SE\sv-SE.com_poll.menu.ini 1
    * C:\wamp\www\karinawebb\administrator\language\sv-SE\sv-SE.com_search.menu.ini 1
    * C:\wamp\www\karinawebb\administrator\language\sv-SE\sv-SE.com_banners.menu.ini 1
    * C:\wamp\www\karinawebb\administrator\language\sv-SE\sv-SE.com_newsfeeds.menu.ini 1
    * C:\wamp\www\karinawebb\administrator\language\sv-SE\sv-SE.com_weblinks.menu.ini 1
    * C:\wamp\www\karinawebb\administrator\language\sv-SE\sv-SE.mod_status.ini 1

•Not translated strings.  (Ej översatta strängar)•

INFINITE LOOP DETECTED JFolder::create() [C:\wamp\www\karinawebb\libraries\joomla\filesystem\folder.php:159]
UNABLE TO OPEN FILE JFile::read() [C:\wamp\www\karinawebb\libraries\joomla\filesystem\archive\gzip.php:72]

any ideas what It could be ? is it a bug??
Success in the long run Its not about the code its about the people and community that's make it!
Its not what you say its what you do that matters!

Darb - aka ssnobben

reverendspam
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Apr 11, 2006 5:20 pm

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by reverendspam » Tue Jan 01, 2008 5:13 pm

darb wrote: Strange. :-\

I used the Wamp on my local c: directory and with a english version then I could install JoomlaExplorer but then when I switch to an J 1.5 with another language (swedish) I could not install this first component - JoomlaExplorer.

Got this errors
      * JFolder::create: ??Infinite loop detected??
        * •Varning - Failed to move the file (Misslyckades att flytta filen)•
        * JFile::read: ??Unable to open file??: 'W:\var\www\karinawebb\tmp\com_joomlaxplorer_1.6.2.tar.gz'
        * Unable to read archive

I had the same errors as well. This was due to owner privileges and permissions not set correctly.

Check the permissions of the the directory you have joomla installed in by firing up your favorite terminal program using the command

ls -l

My directory was owned by "root" and I was accessing joomla through a browser with my user account "joe". This would not let me install any components since "root" owned the directory.

I changed the directory to allow the user "joe" to be able to access it and all worked well afterwards.

I have reverted back to using Linux after an 10 year lapse and got lazy with windows. My brain got lazy and I had to re-learn how linux was structured and now understand the beauty and simplicity of it.

hope this helps,

-Joe

User avatar
darb
Joomla! Ace
Joomla! Ace
Posts: 1658
Joined: Thu Jul 06, 2006 12:57 pm
Location: Stockholm Sweden
Contact:

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by darb » Wed Jan 02, 2008 10:19 am

Thanks Joe I will try this..just switching this between two local wamp servers on my local machine when having this problem..
Success in the long run Its not about the code its about the people and community that's make it!
Its not what you say its what you do that matters!

Darb - aka ssnobben

ExypherIT
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Nov 12, 2007 5:35 pm

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by ExypherIT » Thu Jan 03, 2008 1:19 am

soupman wrote: UPDATE
--------------------------
I am able to now install components by chmod 777 the following files. It is by no means the correct way-which is fixing "MY" ftp client. I don't think joomla 1.5 is bugged it is just that the developers have assumed everyones ftp is configured properly- mine is not and not having a lot of experience with Linux well it simply isn't the developers fault but they may want to take this into consideration.

administrator/backups
administrator/components
administrator/modules
administrator/templates
cache
components
images
images/banners
images/stories
language
media
modules
templates

Change file permission back when done!

Do this and install from a local folder on the server.

Make sure to only chmod the directories and not the files. You'll also need to get the sub-folders in the language directories in both your document root as well as in the ./administrator/language/...

Oh, and disable FTP.

Re-enable everything when finished. No problems using either Verio VPS servers or the Mosso Hosting System. Mosso provided tons of support to get this working for me!

kat_smith
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Jun 26, 2006 12:14 am

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by kat_smith » Thu Jan 03, 2008 5:14 pm

I changed all my directory permissions to chmod 777 but still couldn't install extensions. In the original install, the  FTP user was the owner/creator of all files and folders, but subsequent temp folders for installing extensions were created by the Apache user. One of the features restricted by safe mode is mkdir():

"Checks whether the directory in which you are about to operate has the same UID (owner) as the script that is being executed."

Switching safe mode off solved the problem and allowed me to install extensions.

ExypherIT
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Nov 12, 2007 5:35 pm

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by ExypherIT » Thu Jan 03, 2008 6:50 pm

Though isn't safe mode disabled by default?

User avatar
moonstar2005
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 247
Joined: Sun Nov 25, 2007 10:40 pm

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by moonstar2005 » Thu Jan 03, 2008 7:55 pm

I wonder if instead of installing the WAMP package, maybe try to install apache, sql and php 5 separately.  I read that there is a lot of problems installing the softwares using the WAMP package. Maybe that would solve the problem? That was how I installed my apache, sql and php 5 and I have no problems.

ExypherIT
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Nov 12, 2007 5:35 pm

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by ExypherIT » Thu Jan 03, 2008 8:06 pm

moonstar2005 wrote: I wonder if instead of installing the WAMP package, maybe try to install apache, sql and php 5 separately.  I read that there is a lot of problems installing the softwares using the WAMP package. Maybe that would solve the problem? That was how I installed my apache, sql and php 5 and I have no problems.
I use commercial hosts, but on my test and dev networks I roll my own installs from source. Same problem(s).

moutsatsos
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Jan 04, 2008 3:25 am

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by moutsatsos » Fri Jan 04, 2008 10:16 am

I have had this problem as well and have struggled while trying to install a template and several plugins and I have found a solution.  For some reason you need to turn OFF ftp in Global Configuration.  Through some quirkyness in the programming logic, Joomla only attempts to read and write to configuration.php (where the ftp details are stored) when it thinks that FTP has  been disabled.  Don't worry, it actually does do an FTP when the setting is OFF. 

User avatar
danobie
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Jan 02, 2008 8:02 pm

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by danobie » Fri Jan 04, 2008 10:13 pm

moutsatsos wrote: I have had this problem as well and have struggled while trying to install a template and several plugins and I have found a solution.  For some reason you need to turn OFF ftp in Global Configuration.  Through some quirkyness in the programming logic, Joomla only attempts to read and write to configuration.php (where the ftp details are stored) when it thinks that FTP has  been disabled.  Don't worry, it actually does do an FTP when the setting is OFF. 
Hi everyone,
I have been fighting this issue as well, and the above solution worked for me.  The ONLY thing I did was to disable FTP in the Global Configuration.  I did not change ANY directory permissions, and I did not have to upload the installation to the webserver ahead of time.  I simply disabled FTP, then browsed to the installation package on my local machine, and the installation worked fine.

Good Luck!
-Obie
"I don't know what I'm going for, but I'm gonna go for it, for sure" R.H.

User avatar
theladyboo
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sun Nov 12, 2006 5:33 pm
Location: Freezing Wisconsin
Contact:

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by theladyboo » Fri Jan 11, 2008 5:26 pm

i got it to work. i temporarily changed my tmp and modules directory to 777. ftp access was already off.
+++++
My Joomla Board - http://www.telecommuteresource.com

fearless
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Jan 14, 2008 10:07 pm

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by fearless » Mon Jan 14, 2008 10:17 pm

I have solved this issue for myself with no permissions changing. this is how i did it;
I had installed joomla 1.5 RC4 with the FTP helper activated due to a server restriction of safe mode. I still could not add any plugins or extensions.

I opened the configuration.php file in the root joomla directory and noticed that even though all the FTP info had been saved into the file the line:

var $ftp_enable = '0';

was set to '0' I changed this '0' to '1' and all was happy. I have had no problems installing since making this change.  If you did not set up the FTP settings, take this opportunity to add that info into the appropriate 'var $ftp' setting.

this may be a bug in the install script.

mlines
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Mon Sep 11, 2006 11:15 am

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by mlines » Wed Jan 16, 2008 11:51 am

I am having similar problems since upgrading to RC4 (latest nightly build)

However your discussions are all around FTP and directory permissions which I don't feel apply in my case.

I am attempting to install extensions and they all give the "Error 500 Server Error" message after a long delay.

The System Info reports all my directories are writeable, no messages are left in the logs but the "broken" installation files are left in the /tmp directory (it appears to have unzipped them all under an install***** subdirectory.

I have turned debug on and nothing is logged/displayed.

This is on a hosted server so I do not have full access to the system

Do you have any idea where I should start looking or what information I can contribute to aid diagnosis.

as a starter....


HP Built on:  Linux infong 2.4 #1 SMP Thu Jan 13 08:59:31 CET 2005 i686 unknown
Database Version: 5.0.45-log
Database Collation: utf8_general_ci
PHP Version: 4.4.7
Web Server: Apache/1.3.33 (Unix)
Web Server to PHP interface: cgi
Joomla! Version: Joomla! 1.5.0 Production/Stable [ Karibu ] 19-December-2007 19:00 GMT
User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11



Martin

mlines
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Mon Sep 11, 2006 11:15 am

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by mlines » Wed Jan 16, 2008 3:18 pm

As a followup to my above email perhaps someone could break down a list of the chain of scripts (php) that run as part of the Joomla extension installation process so I can put a few debug statements in so I can see where the process is failing.

Thanks

willmarsh
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sun Jan 13, 2008 8:19 pm

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by willmarsh » Thu Jan 17, 2008 9:36 pm

I was having similar problems installing extensions. The thing that my systems administrator found that solved this for me was a script timeout setting for PHP which was set at 30 secs by default. He set this to 60 seconds and then the extensions installed perfectly. He had to restart Apache to make the change effective.

Hope that helps.

User avatar
moonstar2005
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 247
Joined: Sun Nov 25, 2007 10:40 pm

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by moonstar2005 » Fri Jan 18, 2008 6:32 am

Can you give us exactly where your admin change the php code to 30 secs?

mlines
Joomla! Apprentice
Joomla! Apprentice
Posts: 28
Joined: Mon Sep 11, 2006 11:15 am

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by mlines » Fri Jan 18, 2008 8:36 am

That suggestion nearly works! - one extension now loads and another still fails with the same message, so it looks like we are looking in the right area.

As I am on a hosted service I do not have direct access to the php configuration so I achieved this by creating a "php.ini" file in the root directory and the admin directory of my website, with the following contents:

register_globals = Off;
max_input_time=600;
memory_limit 16M;

Martin

alta
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Wed Dec 12, 2007 5:54 pm

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by alta » Fri Jan 25, 2008 2:31 pm

I was having similar problems, i got installation problems after somethin happend with MySQL at hoster company, after that i couldn't install anything...
Here is the solution I've found and it worked out for me:

In configuration.php there are two lines with paths looking like that

Code: Select all

var $tmp_path = 'hsphere/local/home/YOURLOGINNAME/YOURSITENAME.com/tmp';
I've noticed that path is different now (after the hoster messed up with the database) and it looks like that now:

Code: Select all

var $tmp_path = '/var/hsphere/local/home/YOURLOGINNAME/YOURSITENAME.com/tmp';
So i just fixed the path and it was working fine now. If i didn't knew about database  problem i wouldn't even know where to look for the answers.
Hope it will help someone.
Last edited by alta on Fri Jan 25, 2008 2:32 pm, edited 1 time in total.

dalkin
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Sun Aug 06, 2006 5:04 am

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by dalkin » Sat Jan 26, 2008 7:13 am

This issue is clearly linked to the ftp settings.  If disabled, enable and try again.  If enabled (and unsuccessful) disable and try again.  On a hosted server, port 21 seems to do the trick.

libby
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 215
Joined: Mon Oct 31, 2005 1:01 pm

Re: Joomla V 1.5.0 - I can not install ANY extensions

Post by libby » Wed Jan 30, 2008 6:59 am

I am having this problem with the stable 1.5 - has anyone found a fix?

 

Locked

Return to “Extensions for Joomla! 1.5”