Page 2 of 3

Re: Plugin for [youtube] videos

Posted: Wed Jun 25, 2008 1:13 am
by mandm
Please help me with the step ny step installation process for the plugin..
i have downloaded [youtube] 1.1 and now am stuck with this on how to install

Re: Plugin for [youtube] videos

Posted: Fri Jun 27, 2008 9:25 am
by fusionx1
how can I get [youtube] Id where can i get it? :-\

Re: Plugin for [youtube] videos

Posted: Wed Jul 02, 2008 6:43 am
by dustycat
I have downloaded and installed the plugin but when I create an article and put

{[youtube]}xxxxxxxx{/[youtube]}

in it and save the article, I cannot view it. I get the following error:
Internet Explorer cannot open the internet site:
http://www.mydomain.com/index.php?optio ... &itemid=83.
Operation aborted
I am able to open articles in this section and category that aren't using the plugin.

Could you tell me what I need to do to fix this.

Thanks

Oh, by the way FusionX1 you get the [youtube] id for the video you want at [youtube]. The easiest way is to go to the video you want to embed. In the URL at the top you will see something like:

http://www.[youtube].com/watch?v=1hnB20w6bgQ

The string after v= is the id for that video.

Re: Plugin for [youtube] videos

Posted: Thu Jul 10, 2008 6:16 pm
by genesis33
When I put in the code nothing comes up, I've enabled the plugin and inserted the code into an article and nothing shows. Can you confim that Im putting in the correct code:


{[youtube]}<object width="425" height="350"> <param name="movie" value="http://www.[youtube].com/v/LTg6zkJVFuE"> </param> <embed src="http://www.[youtube].com/v/LTg6zkJVFuE" type="application/x-shockwave-flash" width="425" height="350"> </embed> </object>{/[youtube]}

Thanks
Steve

Re: Plugin for [youtube] videos

Posted: Fri Jul 11, 2008 9:35 am
by dustycat
I've since found a better plugin that works straightaway - mgmediabot2. OK so it's running in legacy mode in 1.5 but it works!!!

http://extensions.joomla.org/component/ ... Itemid,35/

Re: Plugin for [youtube] videos

Posted: Wed Jul 30, 2008 9:35 pm
by atramo
genesis33 wrote:When I put in the code nothing comes up, I've enabled the plugin and inserted the code into an article and nothing shows. Can you confim that Im putting in the correct code:


{[youtube]}<object width="425" height="350"> <param name="movie" value="http://www.[youtube].com/v/LTg6zkJVFuE"> </param> <embed src="http://www.[youtube].com/v/LTg6zkJVFuE" type="application/x-shockwave-flash" width="425" height="350"> </embed> </object>{/[youtube]}

Thanks
Steve
Hi Steve. Excuse me for my poor english...
I'm a beginner, but it seems to me it's simpler than you believe ... in your example you have only to write {[youtube]}LTg6zkJVFuE{/[youtube]} in your article in Joomla! The plugin inserts the details for you; if you want you can see the generated html when the page is displayed. I hope this helps you!
Bye, Andrea.

Re: Plugin for [youtube] videos

Posted: Thu Jul 31, 2008 12:33 pm
by jandalfas
Hello, it's really nice plugin I use it in my project until now. I need to put video tu module and plugin doesn't work.

I create custom module and insert my video into: {[youtube]}edwdwefw{/[youtube]} On front page in this module I saw teh same code: {[youtube]}edwdwefw{/[youtube]} without a video.

As I understand this plugin need some tweaking or modification to show videos in modules ?

I'm right ?

Maybe some one could help me to solve this problem or advice some other plugin ?

Thank you.

Re: Plugin for [youtube] videos - place in module

Posted: Fri Aug 01, 2008 8:03 am
by jandalfas
Hello Stian,

could you provide any information on my previous post ?

Thank you

Re: Plugin for [youtube] videos

Posted: Sun Aug 24, 2008 6:02 am
by OnTheMarkDesign
Stian wrote:So, the short version is that the plugin doesn't work at all?

Have you tried it in for example Firefox? If it works there I think you need to tweak the security/privacy options in IE.

Stian
Plugin works fine in both IE and Firefox when you are not logged in as a user of the Joomla site.
Once you login (or already logged in), it can't open the page in either IE or Firefox!!!!!!

Sounds like it's a Joomla/[youtube] plugin issue to me!

Re: Plugin for [youtube] videos

Posted: Mon Sep 22, 2008 7:30 pm
by burot
Hi,

I have installed this plugin, i have create a new article and i have wrote {[youtube]}IDxxxx{/[youtube]}

When I enter in that article i can see the box with the video, but when i push the "play" button the video doesnt load and this message appears:

We're are sorry, this video is no longer available

It happens with all the [youtube] videos. I can see the video in the [youtube] web but in my site is no loger available

¿any idea?

Thanks

Re: Plugin for [youtube] videos

Posted: Wed Nov 19, 2008 12:54 pm
by vladanjovanovic
Problem with Internet explorer and embedding [youtube] videos is explained well in following webpage:http://www.bernzilla.com/item.php?id=681

I fixed this problem by modifying [youtube].php in plugins/content folder. Replace what is in the "else" branch (line 38) with:

Code: Select all

$html .= '<object type="application/x-shockwave-flash" style="width:' . $newSize["width"] . 'px; height:' . $newSize["height"] . 'px;"';

$html .= ' data="http://www.[youtube].com/' . $playerType . '/' . $query . '"><param name="movie" value="http://www.[youtube].com/' .$playerType . '/' . $query\
 . '"/></object>';

This should generate proper code that won't crash IE and works in Firefox too.

Also disable SWF object use and inclusion in plugin setup!

Re: Plugin for [youtube] videos

Posted: Mon Dec 01, 2008 6:19 pm
by drewgg
vladanjovanovic wrote:Problem with Internet explorer and embedding [youtube] videos is explained well in following webpage:http://www.bernzilla.com/item.php?id=681

I fixed this problem by modifying [youtube].php in plugins/content folder. Replace what is in the "else" branch (line 38) with:

[snip]

This should generate proper code that won't crash IE and works in Firefox too.

Also disable SWF object use and inclusion in plugin setup!
I was also having the problem with IE users getting a fatal error and vladanjovanovic's solution worked for me. (though the else statement was on line 85 instead of 38 in plugins/content/[youtube].php). Secondly, in the code vladanjovanovic posted, it has...

Code: Select all

'/' . $query\
. '"/></object>';
php was giving me warnings over that "\" in there, so I got rid of it...

Code: Select all

'/' . $query . '"/></object>';

Re: Plugin for [youtube] videos

Posted: Tue Jan 06, 2009 3:21 am
by afandi
yeah it works, just put the =" " from u tube website for example {[youtube]}ESFt7r5HCDQ{/[youtube]}

from a complete URL http://www.[youtube].com/watch?v=ESFt7r5HCDQ

see the result: http://energy4all.biz

Re: Plugin for [youtube] videos

Posted: Thu Jan 08, 2009 4:30 am
by JackBauer
I put this code into my article: {[youtube]}sxRc7cUv8Ac{/[youtube]}

It still is displaying that code, not the video.

Re: Plugin for [youtube] videos

Posted: Fri Jan 30, 2009 1:59 am
by alex82
hi there, I have download this component "com_mgmedia2-1.17n" and bot "bot_mgmedia2-0.8" and installed. When I try to put this code "{mgmediabot2}type=[youtube]|[youtube]=3g-yrjh58ms|popup=[youtube] Popup|width=425|height=350{/mgmediabot2}" the result is the same code on the page?! Why? Can enyone help me with this problem? I installed joomla 1.5.8 version.

Re: Plugin for [youtube] videos

Posted: Thu Mar 05, 2009 5:47 am
by mgeorge27
Can the creator of this plugin update this to support playing HD videos by default and Full screen option in the player bar.

Re: Plugin for [youtube] videos

Posted: Thu Mar 05, 2009 11:04 am
by ggmittal
i think joomla 1.5.9 is already supporting [youtube] and other videos.. no need to install extra plugin..

Re: Plugin for [youtube] videos

Posted: Mon Mar 09, 2009 4:53 pm
by Chacapamac
I’m testing your player and it work perfecly... I like to embeded a custom player from [youtube]. How do you do that, because I didn’t find a tutorial or some hints in the documentation?

Thanks in advance for your help!

UPDATE: I was able to play a custom player and is attach vidéos by inserting the full [youtube] code:

{[youtube]}<object width="746" height="413"><param name="movie" value="http://www.[youtube].com/cp/xxxxxxxxxxxxx ... ram><embed src="http://www.[youtube].com/cp/xxxxxxxxxxxxxxxxxxxxxxx=" type="application/x-shockwave-flash" width="746" height="413"></embed></object>{/[youtube]}

Curiously that doesn’t work with the default player with a playlist?????
I have to insert the normal code to make it work:
{[youtube]}xxxxxxxxxxxxxxxxxxxxxx{/[youtube]}

and both make the original video bigger ( Ireally like them to play at 100% of the size
I kept the plugin without size to be able to play videos of different size...

Anybody know how to insert the size in the code or to say to you tube to play them at 100%?

Good Day everybody! :)

Re: Plugin for [youtube] videos

Posted: Thu Mar 12, 2009 7:09 pm
by nesomis
Thanks !!! This is a great stuff and work so simply !!!

Re: Plugin for [youtube] videos

Posted: Mon Apr 20, 2009 6:43 pm
by cyberrob
Thank you for this great plugin. I installed it and it worked without any problems.
Just one thing: I'd like to use additional parameters , e. g. one named "allowFullScreen".
Do I have to change the code in "[youtube].php" or is there a less difficult way?
Regards,
Roland

Re: Plugin for [youtube] videos

Posted: Tue Apr 21, 2009 9:48 pm
by solidtartan
Great plug in for single vids but when I put in a playlist nothing shows....is there something I am missing?

Re: Plugin for [youtube] videos

Posted: Wed Apr 22, 2009 8:40 pm
by marsav
drewgg wrote:
vladanjovanovic wrote:Problem with Internet explorer and embedding [youtube] videos is explained well in following webpage:http://www.bernzilla.com/item.php?id=681

I fixed this problem by modifying [youtube].php in plugins/content folder. Replace what is in the "else" branch (line 38) with:

[snip]

This should generate proper code that won't crash IE and works in Firefox too.

Also disable SWF object use and inclusion in plugin setup!
I was also having the problem with IE users getting a fatal error and vladanjovanovic's solution worked for me. (though the else statement was on line 85 instead of 38 in plugins/content/[youtube].php). Secondly, in the code vladanjovanovic posted, it has...

Code: Select all

'/' . $query\
. '"/></object>';
php was giving me warnings over that "\" in there, so I got rid of it...

Code: Select all

'/' . $query . '"/></object>';
Thanks a million. That solved the problem I was having.

Brilliant plugin

Re: Plugin for [youtube] videos

Posted: Thu Apr 23, 2009 8:10 am
by wanderfus
it is not work...

Re: Plugin for [youtube] videos

Posted: Sat May 02, 2009 6:25 am
by Raji
ggmittal wrote:i think joomla 1.5.9 is already supporting [youtube] and other videos.. no need to install extra plugin..
Can you plz tell me how it works? means I want to know how can I put [youtube] or google video url under my articles?

Re: Plugin for [youtube] videos - Cant get custom player working

Posted: Fri May 15, 2009 3:12 am
by sw6media
Hi mate,

I am trying to get my custom player working on my site and cant seem to get it to show.
I can get a single video playing no prob.

But i have tried every (almost) combination of link and nothing seems to show at all.

Here is the original link to the custom player which works in a browser by it self.
"http://www.[youtube].com/cp/vjVQa1PpcFOYw ... gB8bCHPkk="

and ive tried.{[youtube]}.......{/[youtube]}
vjVQa1PpcFOYwXPgT-_outmEMHfYRP-8XvgB8bCHPkk=
vjVQa1PpcFOYwXPgT
8XvgB8bCHPkk=
outmEMHfYRP-8XvgB8bCHPkk=
etc

Am i doing anything wrong?

Thanks,

nick

Re: Plugin for [youtube] videos

Posted: Fri May 15, 2009 7:04 pm
by marsav
I'm new to this, but have you tried the following:

{[youtube]}<object width="560" height="340"><param name="movie" value="http://www.[youtube].com/v/hSfikcr7txU&hl ... ram><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.[youtube].com/v/hSfikcr7txU&hl=en&fs=1" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="560" height="340"></embed></object>{/[youtube]}


Also to just play it normally on the page you can try the followng:

{[youtube]}hSfikcr7txU{/[youtube]}
I have taken the embed parameters from [youtube].

When you are creating the article with the video embedded, make sure you go into edit HTML. I have found that it has a habit of adding in HTML attributes.

In HTML view this is correct:

<p>Test Video 3</p></div></span><p>{[youtube]}o7Tqk-xf4s4{/[youtube]} </p>

This is wrong:

<p>Test Video 3 </p><p> {[youtube]}o7Tqk-xf4s4{/[youtube]}</p><p> </p><span style="color: #000000; font-family: 'Times New Roman'; font-size: 16px; line-height: normal" class="Apple-style-span"><div style="background-image: initial; background-repeat: initial; background-attachment: initial; -webkit-background-clip: initial; -webkit-background-origin: initial; background-color: #ffffff; font-family: Tahoma, Helvetica, Arial, sans-serif; line-height: 1.3em; font-size: 76%; color: #333333; display: block">

Hope it helps

Re: Plugin for [youtube] videos

Posted: Fri Jul 10, 2009 10:46 pm
by solidtartan
Is there a way to make the video autoplay?

Cannot install plugin

Posted: Fri Aug 14, 2009 9:54 pm
by pal4life26
hi,
Sorry for being a nobb.
I downlaoded the zip for the plugin on to my hard drive and from the Extension manager-> upload package File. Selected the zip file and clicked on upload and install but joomla instead returns a message saying Unable to find install package. Also tried to install using the URL http://joomlacode.org/gf/download/frsre ... ube1.1.zip
Got the same response. Is there an alternative way to install this plugin or am I doing this the wrong way?

Thanking you

Re: Plugin for [youtube] videos

Posted: Sat Aug 29, 2009 2:05 pm
by jen2swt
Works great for me...however it would be nice to add a [youtube] button to the editor toolbar that will insert the {[youtube]}{/[youtube]} code only needing to add the ID in between the two...

Re: Plugin for [youtube] videos

Posted: Mon Aug 31, 2009 4:29 pm
by sisaenko
Hi, I love this module is perfect for what I am doing, but I have a few unresolved issues...

Is there a fullscreenmode button that could be added to the player,
some videos that I ember {[youtube]}xxxx{/[youtube]}
do no have the fullscreen option, would be nice.

Thanks