XML-RPC MetaWeblog API plugin

This forum is for general questions about extensions for Joomla! version 1.5.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
justo.derivera
Joomla! Intern
Joomla! Intern
Posts: 56
Joined: Tue Dec 11, 2007 2:35 am
Location: Madrid, Spain

XML-RPC MetaWeblog API plugin

Postby justo.derivera » Wed Feb 06, 2008 5:52 pm

Hello, I'm Justo and I have been working in the MetaWeblog API plugin for the GHOP contest.

It works fine so far but maybe there are some errors that I haven't seen or some feature missing, so I'm looking for some feedback :)

JoomlaCode page of the last version (0.7)

Configuration:

-Install and enable the MetaWeblog plugin
-Install and enable the RSD plugin
-Disable the blogger plugin (this won't be neccesary later, it's being patched by the Joomla! team)

In the blog editor:

-Create a new account
-Type the url of your homepage and your user and password
-If the auto configuration doesn't work:
  Select MetaWeblog API in the type of blog
  XML-RPC url is http://yoursite.com/xmlrpc/index.php

The clients in wich I tested this are Live Writter, Flock, ScribeFire. If you know any other client, please test it and report the errors you get (If you get any)

Thanks
Last edited by justo.derivera on Wed Feb 06, 2008 6:22 pm, edited 1 time in total.

User avatar
pvh123
Joomla! Ace
Joomla! Ace
Posts: 1125
Joined: Wed Oct 05, 2005 7:25 am
Location: Amsterdam

Re: XML-RPC MetaWeblog API plugin

Postby pvh123 » Thu Feb 07, 2008 10:35 am

Hi justo,

Just to let you know that I will be using your code for testing the J! 1.5 xml-rpc interface.
Note: Sending me private messages for personal support, without this been requested, would lead to ignoring any of your posts in future!

nikez2k4
Joomla! Intern
Joomla! Intern
Posts: 54
Joined: Wed Jan 18, 2006 11:52 am
Location: Derby, UK

Re: XML-RPC MetaWeblog API plugin

Postby nikez2k4 » Thu Feb 07, 2008 1:54 pm

Hey Justo :)

Wow!

I have been working on an update to our College website and I wanted to implement a blog of some kind. I have been looking at Blogger, WordPress, Moveable Type and many others but I was put of by the fact I had to signup and rely on a 3rd party server to store the content.

I don't have any experience with xml-rpc or MetaWeblog, to be honest it is not something I had ever needed, nor needed to play with. But I first learned about it in this thread:

http://forum.joomla.org/index.php/topic,244266.60.html

Incidently that is where I first heard about your plugin. I have followed the advice above and installed your plugin aswell as the RSD plugin. Everything went smoothly but, as with other blog related plugins, I thought Windows Live Writer was going to fail on me again...however to my suprise I put the URL of the site in along with my Joomla username and password and it automatically configured WLW for me! I didn't need to do anytihng else.

Obviously this is what is supposed to happen, however I wanted to share my experience with you as it seems so seemless!!

There is one thing I am having trouble with though, maybe you or someone else can help. I have managed to publish a blog entry but I couldn't figure out where it was publishing it to. I looked in the Article Manager and found that my article was there but Uncategorized...making it a static content item (as was in Joomla 1.0).

This might sound like a stupid question...but is there any way to create a blog under a category, so that when I publish new entries it places them in a "Blog" category, for example?

Other than that it seems to be spot on. Very impressed!!

I would really love to test this out a lot further for you as it is something that I hope to implement in the near future on our website. Please let me know what you would like me to test and I would be happy to help!

Thanks again,
James

(sorry for the long post!  8))

justo.derivera
Joomla! Intern
Joomla! Intern
Posts: 56
Joined: Tue Dec 11, 2007 2:35 am
Location: Madrid, Spain

Re: XML-RPC MetaWeblog API plugin

Postby justo.derivera » Thu Feb 07, 2008 4:20 pm

pvh123 wrote:Hi justo,

Just to let you know that I will be using your code for testing the J! 1.5 xml-rpc interface.

Nice to know :)

nikez2k4 wrote:Incidently that is where I first heard about your plugin. I have followed the advice above and installed your plugin aswell as the RSD plugin. Everything went smoothly but, as with other blog related plugins, I thought Windows Live Writer was going to fail on me again...however to my suprise I put the URL of the site in along with my Joomla username and password and it automatically configured WLW for me! I didn't need to do anytihng else.

I'm glad everything worked fine  8)

nikez2k4 wrote:This might sound like a stupid question...but is there any way to create a blog under a category, so that when I publish new entries it places them in a "Blog" category, for example?


Yes, in the blog editors there is an option to select the category in wich the entry will be published. In Live Writer it's at bottom left:
Image

nikez2k4 wrote:I would really love to test this out a lot further for you as it is something that I hope to implement in the near future on our website. Please let me know what you would like me to test and I would be happy to help!

You could test:
  • Uploading images: in the blog editor add an image to your article.
  • Using the frontpage category: In the plugin manager click the MetaWeblog plugin and then in Plugin Parameters select Use the Frontpage category. Then in the blog editor select the frontpage category if you want the entry to be on frontpage and also the category you want the entry to be published.

Thanks ;)

User avatar
pvh123
Joomla! Ace
Joomla! Ace
Posts: 1125
Joined: Wed Oct 05, 2005 7:25 am
Location: Amsterdam

Re: XML-RPC MetaWeblog API plugin

Postby pvh123 » Thu Feb 07, 2008 4:47 pm

Justo,
got it working first time round.
Wonderful.
Great job done by you :)
Note: Sending me private messages for personal support, without this been requested, would lead to ignoring any of your posts in future!

nikez2k4
Joomla! Intern
Joomla! Intern
Posts: 54
Joined: Wed Jan 18, 2006 11:52 am
Location: Derby, UK

Re: XML-RPC MetaWeblog API plugin

Postby nikez2k4 » Thu Feb 07, 2008 4:57 pm

justo.derivera wrote:Yes, in the blog editors there is an option to select the category in wich the entry will be published. In Live Writer it's at bottom left


I knew I had missed something! Thanks. I'm still very new to blogging - being a web developer you would have thought I should have known better! :)

Anyways - I have been messing about with some WLW features for you.

  • Posting general text and a title works fine and picks up the styles as it should.
  • I have added tables, blockquotes, bullets and various other things from WLW and they work fine too
  • I have uploaded an image using the "Insert Picture..." link in WLW and also the "Insert Map..." link, which adds a screenshot from Virtual Earth, and both seem to work ok*

*The only problem I had with uploading an image is that I got a nasty undescriptive error message from WLW. After looking at the PHP I found that the images are being uploaded to the "media" folder and I realised that it wasn't writable. After I changed the permissions on it image uploads worked fine. Might be worth a mention??

I haven't tried using the front page category yet but will update you when I have.

I have just tried out the front page category, but maybe I am missing something? On the settings page for the plugin, there are 2 options for using the frontpage category; Always and Use the Frontpage category. What is the difference between these 2 becuase the both seem to do the same thing? At least in WLW...

I made sure Always was selected and then posted a new article. It was uncategorized as I mentioned above. I then created a new post and selected the Frontpage category and it posted it under the General Content section in the Front Page Content category. However the Front Page column had a cross in it, signifying it was not published on the front page. I then changed the setting on the plugin to "Use the frontpage category" and posted a new item and the same thing happened again. Could you explain what should happen when you select the different options and what I should be seeing?


Hope that helps :)

I don't really understand the backend workings of WLW...yet...but you know WLW can grab the styles used on your blog site? Would it be possible to get your plugin to grab the template styles used in the Joomla template so that it will look like you are editing right on the website? For me that was the only thing WLW didn't pick up on the setup. If you select Web Layout from the View menu it does display, to a certain extent, the current Joomla template and allow you to edit in the right sections, however it isn't exactly as smooth as it could be :)

Is this something you can work on, or do you have to embed something within the CSS/template itself that WLW picks up?

J  8)
Last edited by nikez2k4 on Thu Feb 07, 2008 5:19 pm, edited 1 time in total.

User avatar
T.G
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Dec 14, 2007 5:27 pm
Contact:

Re: XML-RPC MetaWeblog API plugin

Postby T.G » Thu Feb 07, 2008 5:00 pm

Congratulations on a job well done!!!

justo.derivera
Joomla! Intern
Joomla! Intern
Posts: 56
Joined: Tue Dec 11, 2007 2:35 am
Location: Madrid, Spain

Re: XML-RPC MetaWeblog API plugin

Postby justo.derivera » Thu Feb 07, 2008 6:14 pm

nikez2k4 wrote:*The only problem I had with uploading an image is that I got a nasty undescriptive error message from WLW. After looking at the PHP I found that the images are being uploaded to the "media" folder and I realised that it wasn't writable. After I changed the permissions on it image uploads worked fine. Might be worth a mention??

I will add a code to try to change the permissions, then upload the image and then set the permissions to its previous state. I think there is a code that does that in the com_installer files of Joomla, so I will use that. Also I will change the error message to something like "Please change the permissions of the media folder".

nikez2k4 wrote:Could you explain what should happen when you select the different options and what I should be seeing?

When you chose Always the entries are automatically added to the frontpage. If you chose Use Frontpage category there will appear a new category (Frontpage) on the category list in the editor, if you select this category then the entry will be posted to the front page, otherwise it wont.
You can select multiple categories, so you could for example select Frontpage and Latest (News) and the article will be published on the Latest category and also on the front page.
Also make sure the user you are using has permission to publish, only administrators can publish articles directly. If you don't have permission to publish, the article will be added to the database but it won't be published (it can't be seen by normal users), the system administrator has to check it and then publish it.

nikez2k4 wrote:Is this something you can work on, or do you have to embed something within the CSS/template itself that WLW picks up?

Yes, there is indeed a xml-rpc call to get the template (getTemplate()), I'm working on implementing it.

Thanks everyone for the feedback :)

AmyStephen
Joomla! Champion
Joomla! Champion
Posts: 7056
Joined: Wed Nov 22, 2006 3:35 pm
Location: Nebraska
Contact:

Re: XML-RPC MetaWeblog API plugin

Postby AmyStephen » Thu Feb 07, 2008 6:36 pm

T.G wrote:Congratulations on a job well done!!!


Justo - I want you to meet T.G, the community member who started this ball rolling. It was his request that we heard, created the task, that you then came in and provided for us.

To both of you, I thank you as a blogger who loves Joomla!. It is a good example of a community process and each of you played important roles.

Respect,
Amy :)

nikez2k4
Joomla! Intern
Joomla! Intern
Posts: 54
Joined: Wed Jan 18, 2006 11:52 am
Location: Derby, UK

Re: XML-RPC MetaWeblog API plugin

Postby nikez2k4 » Thu Feb 07, 2008 7:44 pm

Amen Amy!

It was just luck that led me to the post and I was very lucky that this has been released so recently :)

Justo, I have read your post and have some more info for you, but I'm at home at the moment, so will reply to your post tomorrow.

Have a good evening everyone.

J

Umit
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Mon May 28, 2007 1:12 am

Re: XML-RPC MetaWeblog API plugin

Postby Umit » Thu Feb 07, 2008 10:06 pm

I think I might have found a bug.

When using ScribeFire you cannot delete blog posts. It says the url doesn't exist. And is says something about deletehistorycall.

Hope this helps you out a bit.

And btw, great plugin :D

justo.derivera
Joomla! Intern
Joomla! Intern
Posts: 56
Joined: Tue Dec 11, 2007 2:35 am
Location: Madrid, Spain

Re: XML-RPC MetaWeblog API plugin

Postby justo.derivera » Fri Feb 08, 2008 3:53 am

Umit wrote:I think I might have found a bug.

When using ScribeFire you cannot delete blog posts. It says the url doesn't exist. And is says something about deletehistorycall.

Hope this helps you out a bit.

And btw, great plugin :D

Thanks! I totally forgot of the deletePost() function  :-[ I added it in the 0.8 version 

New version (MetaWeblog0.8 ):
  • Fixed an error when getting the parameters. It was caused by a CaSe problem :laugh:
  • Added the deletePost() function. Note: only admins can delete posts (send to the trash)
  • Added a code to change the media folder permissions when uploading content (! not tested !)

Also new version of the RSD plugin (1.1):
  • Fixed an error when getting the parameters. Same cause as in the MetaWeblog plugin

AmyStephen
Joomla! Champion
Joomla! Champion
Posts: 7056
Joined: Wed Nov 22, 2006 3:35 pm
Location: Nebraska
Contact:

Re: XML-RPC MetaWeblog API plugin

Postby AmyStephen » Fri Feb 08, 2008 4:37 am

Justo -

In Flickr, there is capability to select a picture and use it to post to your blog.

If you set up a Flickr account (it is free - to a certain number of pictures each month), you can define your blog on your Account Extended page < http://www.flickr.com/account/?tab=extend&nbsp; >

It allows you to define a blog that uses a MetaWeblog API (yea!) and it works - you can post right into a Joomla! article using your work.

But, it doesn't allow you to specify your section-category - and goes into unspecified. I wonder (don't know the answer, here) but would it make sense to specify a "default" category for those interfaces that do not allow you to specify a category.

Most blogging software simply has one place for posts - like WordPress or Blogger - so, Flickr is very simple. But, it is one of many data service providers that will likely follow this approach.

Anyway, give it some thought about whether a default might make sense - perhaps even offering "Unclassified" as another option, in addition to a specific category.

Thanks for this, very much,
Amy :)

User avatar
k4lch
Joomla! Hero
Joomla! Hero
Posts: 2791
Joined: Sat Dec 31, 2005 1:58 am
Contact:

Re: XML-RPC MetaWeblog API plugin

Postby k4lch » Fri Feb 08, 2008 5:51 am

just tried to get this working on my web I'm getting invalid response getusersblog
Loyd Headrick

jhkc
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Fri Feb 08, 2008 12:42 am

Re: XML-RPC MetaWeblog API plugin

Postby jhkc » Fri Feb 08, 2008 6:05 am

Justo,

I tried your metaweblog plugin and it installed fine.
But when I tried to install RSD plugin, it came back with this error:
JInstaller::install: File '/home/askch0/public_html/tmp/install_47abef1d3ea19/rsd/installedapis.php' does not exist

What did I do wrong? I am a newbie to Joomla, and very little understanding of XMLRPC. Please help.

jhkc

zoechi
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Feb 08, 2008 9:03 am

Re: XML-RPC MetaWeblog API plugin

Postby zoechi » Fri Feb 08, 2008 9:12 am

It's my first look at Joomla and Live Writer support is critical to me.
I installed it using the instructions above.

Works like a charm.

I have one little problem left and hope someone has a hint how to solve it.

Umlauts seem not to be supported.

The title in WLW
"Lizenzfreie Fotos für deinen Blog"
results in
"Lizenzfreie Fotos für deinen Blog"
on the Joomla page

AmyStephen
Joomla! Champion
Joomla! Champion
Posts: 7056
Joined: Wed Nov 22, 2006 3:35 pm
Location: Nebraska
Contact:

Re: XML-RPC MetaWeblog API plugin

Postby AmyStephen » Fri Feb 08, 2008 2:00 pm

Loyd and zoechi -

You might want to try a different tool and see if that works.

1. Flock web browser ( http://www.flock.com/ )
2. Windows Live Writer (proprietary - but free - http://writer.live.com)
3. ScribeFire (Firefox plugin - https://addons.mozilla.org/en-US/firefox/addon/1730)
4. Flickr - http://www.flickr.com/account/?tab=extend

jhkc -

You can still use the client tools without the RSD plugin - so - if you are interested, please continue testing with one of the tools.

I'm loving it!
Amy :)

justo.derivera
Joomla! Intern
Joomla! Intern
Posts: 56
Joined: Tue Dec 11, 2007 2:35 am
Location: Madrid, Spain

Re: XML-RPC MetaWeblog API plugin

Postby justo.derivera » Fri Feb 08, 2008 4:35 pm

AmyStephen wrote:But, it doesn't allow you to specify your section-category - and goes into unspecified. I wonder (don't know the answer, here) but would it make sense to specify a "default" category for those interfaces that do not allow you to specify a category.

Yes, thanks for the suggestion, I will add a default category parameter to the next release :)

zoechi wrote:The title in WLW
"Lizenzfreie Fotos für deinen Blog"
results in
"Lizenzfreie Fotos für deinen Blog"
on the Joomla page

I fixed that, now every character should be displayed correctly

k4lch wrote:just tried to get this working on my web I'm getting invalid response getusersblog

What client are you using? Have you disabled the blogger API plugin?

jhkc wrote:I tried your metaweblog plugin and it installed fine.
But when I tried to install RSD plugin, it came back with this error:
JInstaller::install: File '/home/askch0/public_html/tmp/install_47abef1d3ea19/rsd/installedapis.php' does not exist

I also noticed that there is a problem with the rsd folder. When uninstalling the plugin, the rsd folder is not deleted. I will try to fix it

justo.derivera wrote:Yes, there is indeed a xml-rpc call to get the template (getTemplate()), I'm working on implementing it.

I tested the get template option on WLW (I don't know of any other editor that uses it) and it worked almost perfectly :)

I will release the new version soon.

Again, thanks to everyone ;)

User avatar
T.G
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Dec 14, 2007 5:27 pm
Contact:

Re: XML-RPC MetaWeblog API plugin

Postby T.G » Fri Feb 08, 2008 4:37 pm

Justo,

I just finished testing your 0.8 build on a XAMPP server with FTP and a fresh 1.5 install. I installed both the rsd and metaweblog plugins (no hassle at all!) I set up a user with 'publisher' permissions. I set up Live Writer with a new account and set it to use the FTP transfer for images to the images/story folder. I used the FTP capability because LR creates an unique folder for images for each post.

Since I use LR on a daily basis with multiple sites on another platform ...with some fairly complex layouts ... I tried to emulate all of the 'whoops and adjustments' republishing, reformatting and catching a typo after a post has been published.  These articles included multiple images of all sizes, redirects, tables and formatting for fonts etc.

I was not able to break it  ;D and believe me I tried ;) I was also able to import other previously posted articles from other sources and redirect them to the J! test site.

My only comment has to do with the 'delete' permission... and this may be a larger policy decision which others would have to speak to...
but when one is publishing to multiple sites and is tired or has a shaky mouse finger, it is possible to accidentally publish/post to the wrong site (this actually happened to me two days ago) and being able to delete it quickly is important. I am not sure that every 'publisher' should/would have 'Admin' privileges.

I suspect that there will be some other bugs that crop up... and different tools have different issues, but I just wanted to once again thank you for the time and effort... not to mention skill... that went into providing this contribution!!

AmyStephen
Joomla! Champion
Joomla! Champion
Posts: 7056
Joined: Wed Nov 22, 2006 3:35 pm
Location: Nebraska
Contact:

Re: XML-RPC MetaWeblog API plugin

Postby AmyStephen » Fri Feb 08, 2008 5:06 pm

T.G wrote:My only comment has to do with the 'delete' permission... and this may be a larger policy decision which others would have to speak to...
but when one is publishing to multiple sites and is tired or has a shaky mouse finger, it is possible to accidentally publish/post to the wrong site (this actually happened to me two days ago) and being able to delete it quickly is important. I am not sure that every 'publisher' should/would have 'Admin' privileges.


Ian and I discussed this, too. In Joomla!, only Managers and above are able to delete articles. That ACL requirement should also be applied to the xml-rpc APIs, I think. I'll ask Ian to weigh in on this, as well.

User avatar
k4lch
Joomla! Hero
Joomla! Hero
Posts: 2791
Joined: Sat Dec 31, 2005 1:58 am
Contact:

Re: XML-RPC MetaWeblog API plugin

Postby k4lch » Sat Feb 09, 2008 2:00 am

Got my 1.5 to work now. had to enable the web services in globlal configuation. now to see if i can get it to work with 1.0.14
Loyd Headrick

pixital
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Feb 09, 2008 4:06 am

Re: XML-RPC MetaWeblog API plugin

Postby pixital » Sat Feb 09, 2008 4:29 am

Hello justo,

Very nice plugin, it makes managing multiple Joomla installations easy.  I've tested your plugin using Windows Live Writer (elegant and free) and ScribeFire on a Joomla 1.5 installation.

The one issue I ran into was that the jos_content.alias field wasn't being populated - for those who use SEF urls.

If anyone else is using SEF with Joomla, you can add the following to Line 211 of plugins/xmlrpc/metaweblog.php (right after $item->title = $content['title'] )

$Valias = preg_replace(array('/\s+/','/[^A-Za-z0-9\-]/'), array('-',''), $content['title']);
$item->alias = trim(strtolower($Valias));

The preg_replace code is from JFilterOutput::stringURLSafe. Thanks!

justo.derivera
Joomla! Intern
Joomla! Intern
Posts: 56
Joined: Tue Dec 11, 2007 2:35 am
Location: Madrid, Spain

Re: XML-RPC MetaWeblog API plugin

Postby justo.derivera » Sat Feb 09, 2008 11:51 am

New version (MetaWeblog0.9)
  • Now the titles support special characters (like öòúûç)
  • The alias value is now set correctly
  • Default category, select it in the plugin parameters
Now I'm writing documentation about installation and configuration on the wiki

T.G wrote:I was not able to break it  ;D and believe me I tried ;) I was also able to import other previously posted articles from other sources and redirect them to the J! test site.

Great, thanks for testing :)
pixital wrote:The one issue I ran into was that the jos_content.alias field wasn't being populated - for those who use SEF urls.

Thanks, fixed on the new version

AmyStephen wrote:Ian and I discussed this, too. In Joomla!, only Managers and above are able to delete articles.

Okay, I kept it that way

k4lch wrote:Got my 1.5 to work now. had to enable the web services in globlal configuation. now to see if i can get it to work with 1.0.14

This plugin is only for 1.5

User avatar
wadscookin
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Fri Jun 09, 2006 12:02 am
Location: Northampton, UK
Contact:

Re: XML-RPC MetaWeblog API plugin

Postby wadscookin » Sat Feb 09, 2008 9:12 pm

Hi Justo,

Very excited to discover your work on this yesterday as I'm redeveloping a site for an Evangelist friend who needs a way to post articles quickly and intuitively. Live Writer looks ideal as a familiar and competent front-end for this, and I've installed metaWeblog and RSD, and checked that the Blogger API is disabled.  Using Joomla! 1.5.1 security update on a local server running on my PC.
Live Writer logs onto my test Joomla! site and is happy for me to compose an article. However when I try to post it, I get the following error.... 

"The response to the metaWeblog.newMediaObject method received from the weblog server was invalid:
Invalid response document returned from XmlRpc server"

My apologies if another post answers this, but I can't find one. I'm not a developer and don't have more information, so any help on what to do next would be valuable.

Many thanks to everyone who's worked on this and of course T.G for pushing the idea forward constructively. I know it's going to be a 'must have' feature of Joomla! and I'm really looking forward to using it.

John  :)
If Jesus is your co-pilot, change seats.

User avatar
T.G
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Dec 14, 2007 5:27 pm
Contact:

Re: XML-RPC MetaWeblog API plugin

Postby T.G » Sat Feb 09, 2008 10:38 pm

Hi wadscookin,

I have not seen that error... but someone else may have. What would be really helpful would be to know what type and configuration of a 'local server' you are using as well as the operating system. It can narrow down things a bit since these are early days in the testing process. Also, do you have FTP enabled for your local server? What are your image settings in Live Writer... ?

Where there any images as part of the post?

Thanks, T.G

User avatar
wadscookin
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Fri Jun 09, 2006 12:02 am
Location: Northampton, UK
Contact:

Re: XML-RPC MetaWeblog API plugin

Postby wadscookin » Sun Feb 10, 2008 12:40 am

Hi T.G

I'm using XP Professional updated with service packs and security updates. My server is the Uniform server, which is based on Apache and mySql and is not using the FTP layer. I've also tried this on a live site running 1.5.1 on a standard Linux hosting account with Apache and mySql. Again the FTP layer is not implemented, this time because I couldn't get it to work on the Joomla! installation.

On both sites with one or more images in the document, I get the error
"The response to the metaWeblog.newMediaObject method received from the weblog server was invalid:
Invalid response document returned from XmlRpc server"

However if I remove the images, the document is uploaded to the server and the error message is still displayed.
The document always loads to the Front Page, whatever page I point Live Writer to.

The image setting in Live Writer is "Upload images to my weblog".

Hope this helps a little.

Thanks, John  :)
Last edited by wadscookin on Sun Feb 10, 2008 12:45 am, edited 1 time in total.
If Jesus is your co-pilot, change seats.

justo.derivera
Joomla! Intern
Joomla! Intern
Posts: 56
Joined: Tue Dec 11, 2007 2:35 am
Location: Madrid, Spain

Re: XML-RPC MetaWeblog API plugin

Postby justo.derivera » Sun Feb 10, 2008 12:44 am

I have tested the uploading of images on a online server and I got that error too... It's a problem with the code I added to change the permissions of the media folder.
Hopefully I will get it fixed soon.
Thanks both wadscookin and T.G ;)

User avatar
wadscookin
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Fri Jun 09, 2006 12:02 am
Location: Northampton, UK
Contact:

Re: XML-RPC MetaWeblog API plugin

Postby wadscookin » Sun Feb 10, 2008 1:32 am

Thanks Justo,

I just implemented the FTP layer on my live site and FTP seems to be working. Don't know why I had trouble at installation. Anyway with FTP configured on the server and in Live Writer, I still get the error message but the document with photos is now uploaded to the Front Page and looks fine. I don't know how to load to a different section/category.
However Live Writer tells me that it can't download the styles from the server. Is that why I can't see sections/categories or am I just missing something?

Cheers, John  :)
If Jesus is your co-pilot, change seats.

justo.derivera
Joomla! Intern
Joomla! Intern
Posts: 56
Joined: Tue Dec 11, 2007 2:35 am
Location: Madrid, Spain

Re: XML-RPC MetaWeblog API plugin

Postby justo.derivera » Sun Feb 10, 2008 1:41 am

The list of the sections/categories should appear at the bottom left in live writer:
Image

I'm still working on the uploading error. I will also take a look to download styles problem later.

:)

User avatar
wadscookin
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Fri Jun 09, 2006 12:02 am
Location: Northampton, UK
Contact:

Re: XML-RPC MetaWeblog API plugin

Postby wadscookin » Sun Feb 10, 2008 11:45 am

This rocks guys!

I've just implemented the SlimFTPd server on my PC to complement the Uniform web server, reconfigured the Images settings on Live Writer to use FTP and I can now upload documents with images to my test site. Thanks Justo for pointing out the button bottom left to set sections/categories. This seems to work fine.

Conclusion: So as long as the FTP layer is enabled, the upload works on both WAMP and LAMP servers, as does editing previously uploaded content.

Many thanks for all the hard work going into this. It moves Joomla! 1.5 from very good to truly awesome in my book!

John  :)
If Jesus is your co-pilot, change seats.


Return to “Extensions for Joomla! 1.5”

Who is online

Users browsing this forum: No registered users and 45 guests