Page 1 of 1

Trouble installing extensions

Posted: Mon Feb 11, 2008 11:30 pm
by Nimai
I've got a fresh install of Joomla 1.5.0
On my local installation, I can install extensions just fine.
Using the version up on my web host at http://bceboosterclub.org/bcbc , I get the following when I try to install an extension.

        * JFolder::create: ??Could not create directory??
        * •Warning! - Failed to move file•


At this point, several hours later, I feel like I've tried just about everything.
  • with/without FTP enabled
  • with/without Legacy
  • with/without debug enabled
  • double checked the tmp path in the configuration
  • made my whole Joomla subdirectory Writeable
:'(

I don't see the file showing up in the tmp directory.  Is that a clue?  Where else can I look for better error information?  There's nothing good revealed with debug enabled, and nothing in the logs.  Any direction greatly appreciated.

Re: working with the login forum and discusion forums

Posted: Wed Feb 13, 2008 2:02 pm
by tafadzwa
i cant seem to get the login in form working and the discussion forum when you click on the balloon icon to converse with someone through text it says page cannot be displayed go to main menu im in south africa please help me out girls and guys iv worked with html and other pogrammes before

Re: Trouble installing extensions

Posted: Wed Feb 13, 2008 2:18 pm
by Nimai
:-[ Oh boy...

Back on topic - my problems still persist. Any direction appreciated. Thank you.

Re: Trouble installing extensions

Posted: Thu Feb 14, 2008 3:17 am
by Nimai
OH MY GOSH!
I got mine to work! For the love of all that's holy! Haha-

OK, I did not have to chmod anything to 777. I agree - that's just whack. Everything is 755.
My problem may not be the same as yours, and I will reiterate that Joomla's errors need to do a better job of pointing us to the problem. Out of curiosity, I added the $path parameter to the raiseWarning call in JFTP::mkdir. The dir that I saw it having trouble making was the root dir I had specified in my configuration.php. For me, I had it set to this:

var $tmp_path = '/mysite.com/joomla/tmp';

I set this value initially because when I connected with my FTP client, this was the path to the tmp directory. I took a look at the FTP configuration page on my web hosting provider. One line-item in the data about my FTP service was something called Home Directory. I thought to add this to the front of my FTP path:

var $tmp_path = '/hsphere/local/home/myusername/mysite.com/joomla/tmp';

That did it. I sincerely hope this helps some one!