Extension installation

This forum is for general questions about extensions for Joomla! version 1.5.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
User avatar
Pinc
Joomla! Guru
Joomla! Guru
Posts: 827
Joined: Thu Mar 22, 2007 1:42 pm

Re: Extension installation

Post by Pinc » Sun Jul 05, 2009 6:06 am

Go into your admin site for the Joomla.
Look in the Help link for the site and select system info.
It will tell you there.
;)
”Character isn't how you act when every one is watching; character is how you act when no one is watching.” ~ Anonymous
JOOMLA 2.5 AND 3.0

 
Kotetsu52
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Fri Jul 03, 2009 11:37 am

Re: Extension installation

Post by Kotetsu52 » Sun Jul 05, 2009 6:38 am

Just realized that when looking for my Joomla version. Thanky you.

I'm trying to upgrade Joomla to 1.5.12 right now. I'll post if it fixed ma issues.

Thanks again for you help Pinc

Kotetsu52
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Fri Jul 03, 2009 11:37 am

Re: Extension installation

Post by Kotetsu52 » Sun Jul 05, 2009 2:13 pm

Ok, Ver 1.5.12 installed successfully. Site working well.

However, it didn't change any thing I keep having "Unable to find install package" message when trying to install something (no big surprise so far).

My PHP version by the way: 5.2.6

This thing is turning me nuts...


For the record, it's still impossible to change any setttings through the server global config in the backend:

- JFTP::write: Bad response
- An Error has occurred! Unable to open configuration.php file to write!

The only modification that actually works there is when deactivating the FTP but it doesn't work the other way around...

User avatar
Pinc
Joomla! Guru
Joomla! Guru
Posts: 827
Joined: Thu Mar 22, 2007 1:42 pm

Re: Extension installation

Post by Pinc » Mon Jul 06, 2009 2:13 am

Are you changing permissions in your server,or how?
;)
”Character isn't how you act when every one is watching; character is how you act when no one is watching.” ~ Anonymous
JOOMLA 2.5 AND 3.0

Kotetsu52
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Fri Jul 03, 2009 11:37 am

Re: Extension installation

Post by Kotetsu52 » Mon Jul 06, 2009 2:24 am

Pinc wrote:Are you changing permissions in your server,or how?
;)
I just found this problem when trying to change the server settings ont the global configuration page of the backend. config.php file is 777 but it changes nothing. Always have to change the config by editing the configuration.php with a text editor or other software.

Anyway that's not the problem I think. I the files permission all should be "writable" in order to install new components. The fact is that temp file and log files NEVER appear as "writable" even if both their permission are 777.

User avatar
Pinc
Joomla! Guru
Joomla! Guru
Posts: 827
Joined: Thu Mar 22, 2007 1:42 pm

Re: Extension installation

Post by Pinc » Mon Jul 06, 2009 2:32 am

Recommended permission settings are 755 for folders and 644 for files.
If you want to, send me a PM with the user name and password for your server account, FTP info would be great too, and I'll take a look for you.
;)
”Character isn't how you act when every one is watching; character is how you act when no one is watching.” ~ Anonymous
JOOMLA 2.5 AND 3.0

Buflonob
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Tue Oct 14, 2008 10:32 pm

Re: Extension installation

Post by Buflonob » Sun Jul 12, 2009 3:32 pm

Having the same problme as this.

Have a QNAP NAS box and running Joomla on it.

It has phpmyadmin.

basically, configuration.php was blank when i went to it, used ther site file to recreate but still gives the errors, any deas?

how would i change the write permissions if it's on my NAS, just fileview and right click vai windows etc?

User avatar
Pinc
Joomla! Guru
Joomla! Guru
Posts: 827
Joined: Thu Mar 22, 2007 1:42 pm

Re: Extension installation

Post by Pinc » Mon Jul 13, 2009 12:34 am

Please read this for your solution:
http://www.legitreviews.com/article/950/10/
;)
”Character isn't how you act when every one is watching; character is how you act when no one is watching.” ~ Anonymous
JOOMLA 2.5 AND 3.0

Markus64
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Mon Jan 18, 2010 9:28 pm

Re: Extension installation

Post by Markus64 » Mon Jan 18, 2010 9:37 pm

Specifying the verbose 'tmp' pathway worked tickety-boo for me.

morgandlm
Joomla! Intern
Joomla! Intern
Posts: 64
Joined: Thu Dec 24, 2009 2:41 pm

Re: Extension installation

Post by morgandlm » Tue Jan 19, 2010 5:42 pm

I too am having a problem installing extensions. I get the following response:-

* JFTP::mkdir: Bad response
* JFTP::chmod: Bad response
* JFTP::store: Bad response
* Warning! Failed to move file

I'm using Joomla 1.5.15
PHP vers 5.2.6
Sever is running Linux.

I have successfully installed an extension (JEvents) but now without having changed anything I am unable to install any more. I have read this forum extensively and been somewhat frightened in that this problem seems fairly widespread. I have tried all sorts of config changes but without success.

I note the recommendation to change some file security settings - how do I do this?
Can some guru please assist.
Morgan

ernienet
Joomla! Intern
Joomla! Intern
Posts: 54
Joined: Fri Oct 20, 2006 5:32 am

Re: Extension installation

Post by ernienet » Mon Jan 25, 2010 7:08 am

I'm uncomfortable changing permissions - this makes the site vulnerable.

Check these three things:

1. Do you have enough disk space? Check your WHM or space available in your cPanel.
2. In configuration.php, check the
  • $log_path = '/home/yoursite/public_html/logs';
    $tmp_path = '/home/yoursite/public_html/tmp';
to be sure they match your actual path. Don't give up easily on tweaking these a few times to see if that fixes it.
3. Your .htaccess or htaccess.txt is an empty file - you may have to open it in notepad to confirm. I have trouble getting the cPanel File Manager to display files that start with a '.', and sometimes when I upload the file, it only uploads the filename without any of the contents.

I hope this helps.

Ernie

jammosh
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Mar 22, 2010 1:32 pm

Re: Extension installation

Post by jammosh » Sat May 29, 2010 9:10 pm

Pinc wrote:Check out this post and see if the solution works for you:

http://forum.joomla.org/viewtopic.php?f=470&t=294163

;)


thank you it worked you rocked my world

User avatar
corrado444
Joomla! Guru
Joomla! Guru
Posts: 856
Joined: Thu Jul 06, 2006 8:30 am
Location: Sacramento
Contact:

Re: Extension installation

Post by corrado444 » Sat Jan 22, 2011 12:21 am

I wanted to put my $0.02 in the discussion here. I found this post after getting the same error on a fairly new installation of Joomla 1.5.22.

After banging my head against it for a while, I checked the server and realized that the account was running out of space. I first deleted some file (some in the tmp folder) that were taking up space and that solved the issue.

Then I went and increased the allocation to that account in WHM. (of course, I can do that ebcause I am on a dedicated server).

Problem solved. So at least first check your space.
Watch the 10 Minute Joomla! Tips Video Podcast
Itunes: [url]itpc://10minutejoomlatips.blip.tv/rss/itunes[/url]
Feedburner http://feeds.feedburner.com/10MinutesJoomlaTips

oirmak1975
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Tue Nov 17, 2009 8:38 pm
Contact:

Re: Extension installation

Post by oirmak1975 » Sat Jan 22, 2011 6:48 pm

Does the error only gives joomseo notDid he all add-ons gives the same error, then the plug-in is causing the error if you just joomseo properly if you have to make you all add-ons is causing the error to help the German company then you need hosting.

My site is: http://www.joomlawebtasarimi.com[/quote]

Icescream
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Thu Jun 02, 2011 3:13 pm

Re: Extension installation

Post by Icescream » Thu Jun 02, 2011 3:23 pm

Alright,

To me it seemed i made a stupid noob action and never realised the consequences of it.

After i installed Joomla and everything on it i renamed my folder where i installed joomla in.
( example: renamed "joomla364" to "joomla 111")

I never realised i had to go into my configuration and change the foldername accordingly.
After that i checked in the extension field and the global configuration if it was set to the correct foldername and after that all was well and the install was fine.

So it was a question of backtracking my own steps!

I hope this is helpful for others. Enjoy!

User avatar
corrado444
Joomla! Guru
Joomla! Guru
Posts: 856
Joined: Thu Jul 06, 2006 8:30 am
Location: Sacramento
Contact:

Re: Extension installation

Post by corrado444 » Thu Jun 02, 2011 7:34 pm

Actually, the reason of the problem is that by changing the folder name the log and tmp folders ceased to exist. Had you duplicated and then renamed the folder it would have worked just fine, using log and tmp from the other installation.
Watch the 10 Minute Joomla! Tips Video Podcast
Itunes: [url]itpc://10minutejoomlatips.blip.tv/rss/itunes[/url]
Feedburner http://feeds.feedburner.com/10MinutesJoomlaTips

MarianMN
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Sep 14, 2011 10:28 am

Re: Extension installation

Post by MarianMN » Wed Sep 14, 2011 10:45 am

I had the problem with "Please enter a package directory"

It was because i had moved my site to a new directory and therefore had to change my

configuration.php file

Example: from directory web125 to web118

var $log_path = '/var/www/web125/web/logs';
var $tmp_path = '/var/www/web125/web/tmp';
to
var $log_path = '/var/www/web118/web/logs';
var $tmp_path = '/var/www/web118/web/tmp';

neekfenwick
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Oct 10, 2012 4:44 am

Re: Extension installation

Post by neekfenwick » Wed Oct 10, 2012 7:59 am

I'm using Joomla 2.5.6. On top of the above issues (directory permissions such that the httpd process didn't have write permissions to various directories, and configuration.php $log_path and $tmp_path being invalid for my system) I also had to adjust SELinux. My httpd process did not have write permissions to the required folders, even if the file system permissions were set correctly. Thought I'd record some info here for posterity.

To fix, with my joomla install in /var/www/joomla, I labelled the following with "httpd_cache_t":

Code: Select all

/var/www/joomla/tmp(/.*)?
/var/www/joomla/components(/.*)?
/var/www/joomla/administrator/components(/.*)?
/var/www/joomla/language(/.*)?
I did this with the "SELinux Management" application in my Fedora Linux system, your mileage may vary. After setting up the labels, don't forget to apply them.

Code: Select all

$ restorecon -r /var/www/joomla
You can test SELinux labels with the 'Z' flag to ls:

Code: Select all

[root@myserver joomla]# ls -ldZ plugins/
drwxrwxr-x. me apache system_u:object_r:httpd_sys_content_t:s0 plugins/
This shows the files have httpd_sys_content_t. After running restorecon to apply your new label:

Code: Select all

[root@myserver joomla]# ls -ldZ plugins/
drwxrwxr-x. me apache system_u:object_r:httpd_cache_t:s0 plugins/
It now has the httpd_cache_t context and httpd can write to it.

To be honest it's probably better to give the entire joomla directory a context that will allow httpd to write, e.g.:

Code: Select all

/var/www/joomla(/.*)?
If you let the installer get part way through and fail, it'll leave some files in place, and a subsequent re-install of the same component will fail, and you're left picking up the pieces manually. I also had to go delete rows from the j_extensions and j_assets tables by hand.

 

Locked

Return to “Extensions for Joomla! 1.5”