Xmap Installation error on Joomla 1.5.23

This forum is for general questions about extensions for Joomla! version 1.5.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
boizan
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 168
Joined: Mon Sep 14, 2009 11:18 pm

Xmap Installation error on Joomla 1.5.23

Post by boizan » Tue Jul 26, 2011 9:40 pm

Hello There!
When I installed the last version of Xmap (pkg_com_xmap-2.0) on Joomla 1.5.23 I get the error: " Error! Could not find a Joomla! XML setup file in the package."
When I install all the other versions from 1.10 to 1.13 it goes on okay, but the control panel lacks the usual list of all the other plugins included, and I get this error: "Warning: Invalid argument supplied for foreach() in /home/content/a/b/o/aboizan/html/soutlet/administrator/components/com_xmap/classes/XmapConfig.php on line 59" Also on the Plugin Manager list Xmap has not data: no version, no date, no author.
When I publish a map it shows up a similar error.
I would appreciate your help!

User avatar
stevepops
Joomla! Intern
Joomla! Intern
Posts: 53
Joined: Tue Nov 27, 2007 2:28 am

Re: Xmap Installation error on Joomla 1.5.23

Post by stevepops » Sat Aug 13, 2011 1:58 am

the release notes clearly states pkg_com_xmap-2.0 is NOT compatible with 1.5.x

From Joolacode.org: "This is the first stable version of Xmap 2.0 for Joomla 1..6 and 1.7. It's a complete rewrite of Xmap trying to follow the Joomla's coding standards. This is not compatible with Joomla 1.5, please use Xmap 1.2.X instead."

User avatar
stevepops
Joomla! Intern
Joomla! Intern
Posts: 53
Joined: Tue Nov 27, 2007 2:28 am

Re: Xmap Installation error on Joomla 1.5.23

Post by stevepops » Sat Aug 13, 2011 2:06 am

Do you happen to have akeeba backup or akeeba admin tools installed?

I have just seen the situation you described, and after uninstalling both akeeba components, the install worked flawlessly

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 37464
Joined: Sat Apr 05, 2008 9:58 pm

Re: Xmap Installation error on Joomla 1.5.23

Post by Webdongle » Sat Aug 13, 2011 2:09 am

boizan wrote:...
When I install all the other versions from 1.10 to 1.13 it goes on okay, but the control panel lacks the usual list of all the other plugins included, ...
By installing 1.10 first may have mixed things up. Uninstall then reinstall 1.13 ???

The Download is a little confusing but if you RTFM before installing anything then it may help. Also having a test site with sample data helps when trying an extension.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

User avatar
alexwalker
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 158
Joined: Thu Sep 15, 2005 3:54 pm
Location: Lancaster, UK (near the Lake District)
Contact:

Re: Xmap Installation error on Joomla 1.5.23

Post by alexwalker » Thu Nov 24, 2011 1:24 pm

stevepops wrote:Do you happen to have akeeba backup or akeeba admin tools installed?

I have just seen the situation you described, and after uninstalling both akeeba components, the install worked flawlessly
No need to uninstall any Akeeba Products. All you have to do is click on the "Back to the Standard Installer" in the extensions installation page OR disabling the "System - System Restore Points" plugin when you are installing XMap
Alex Walker
"to assume is to make an ass of u and me"

boizan
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 168
Joined: Mon Sep 14, 2009 11:18 pm

Re: Xmap Installation error on Joomla 1.5.23

Post by boizan » Sat Nov 26, 2011 6:16 pm

stevepops wrote:the release notes clearly states pkg_com_xmap-2.0 is NOT compatible with 1.5.x

From Joolacode.org: "This is the first stable version of Xmap 2.0 for Joomla 1..6 and 1.7. It's a complete rewrite of Xmap trying to follow the Joomla's coding standards. This is not compatible with Joomla 1.5, please use Xmap 1.2.X instead."
Hello,
Thank you so much for your reply! I am migrating all my sites to Joomla 1.7 so am delighted to hear that I will be able to use Xmap well.
Thanks,

andoverv
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Thu Feb 03, 2011 4:54 am
Location: minnesota
Contact:

Re: Xmap Installation error on Joomla 1.5.23

Post by andoverv » Fri Jan 13, 2012 2:07 pm

I have the issue too, but I don't have system-system restore points, so i can't disable it. Any other method?


Locked

Return to “Extensions for Joomla! 1.5”