E-mail could not be sent.

This forum is for general questions about extensions for Joomla! version 1.5.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
nickc25
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Mon Feb 23, 2009 12:24 pm

E-mail could not be sent.

Post by nickc25 » Fri Feb 27, 2009 1:01 pm

Hi

I have recently installed joomla and am in the process of moving all my content over to joomla, I am testing things out. The pdf and print functions work fine but the send email button does not work.

It brings up a form upon clicking, fill the information in and the following error happens:

E-mail could not be sent.

Any ideas?

nniiccoollee
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 177
Joined: Fri Dec 08, 2006 8:07 pm
Location: Michigan, USA
Contact:

Re: E-mail could not be sent.

Post by nniiccoollee » Thu Mar 12, 2009 2:52 pm

I'm having the same issue, but here are some additional details:

- Joomla 1.5.9 (native) running on Apache
- Sending emails from contact form works, so I don't think it's the server.
- The complete error message is "E-mail could not be sent." even with all the error reporting turned on.
- This message is received once the "Send" button is clicked. (The send form launches just fine when you click the email to a friend button. I'm getting the same error when attempting to send a content item or an event (EventList).

Any help or advice would be much appreciated!


Thanks!
Nicole

nickc25
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Mon Feb 23, 2009 12:24 pm

Re: E-mail could not be sent.

Post by nickc25 » Thu Mar 12, 2009 3:10 pm

nniiccoollee wrote:I'm having the same issue, but here are some additional details:

- Joomla 1.5.9 (native) running on Apache
- Sending emails from contact form works, so I don't think it's the server.
- The complete error message is "E-mail could not be sent." even with all the error reporting turned on.
- This message is received once the "Send" button is clicked. (The send form launches just fine when you click the email to a friend button. I'm getting the same error when attempting to send a content item or an event (EventList).

Any help or advice would be much appreciated!


Thanks!
Nicole
nobody seems to want to help, posted many threads on it now and got nowhere in two weeks. :(

nniiccoollee
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 177
Joined: Fri Dec 08, 2006 8:07 pm
Location: Michigan, USA
Contact:

Re: E-mail could not be sent.

Post by nniiccoollee » Thu Mar 12, 2009 3:20 pm

Is your situation the same as I described in my post? (Same Joomla version, etc?)

I'm checking the code repository for a bug report now. (I found a login patch that way so maybe we'll both get lucky!)

Cross your fingers!
Nicole

nniiccoollee
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 177
Joined: Fri Dec 08, 2006 8:07 pm
Location: Michigan, USA
Contact:

Re: E-mail could not be sent.

Post by nniiccoollee » Thu Mar 12, 2009 3:24 pm

There IS a bug reported: http://joomlacode.org/gf/project/joomla ... m_id=14809

I'll post back here if I find a fix.

Nicole

nickc25
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Mon Feb 23, 2009 12:24 pm

Re: E-mail could not be sent.

Post by nickc25 » Thu Mar 12, 2009 3:42 pm

nniiccoollee wrote:There IS a bug reported: http://joomlacode.org/gf/project/joomla ... m_id=14809

I'll post back here if I find a fix.

Nicole
cheers, I posted about it on a few forums. Id only want the feature on a few of my pages too lol

boeli
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Mar 07, 2009 11:57 pm

Re: E-mail could not be sent.

Post by boeli » Fri Mar 27, 2009 2:28 pm

Anyone found a solution for this problem?

nickc25
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Mon Feb 23, 2009 12:24 pm

Re: E-mail could not be sent.

Post by nickc25 » Fri Mar 27, 2009 3:42 pm

Helpful bunch this lot. I think I will have to ununstall joomla and use mambo or something. Too many errors and problems without solutions. I even do not mind paying people to help but no one is interested.

metaltome
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Fri Jan 23, 2009 7:47 pm

Re: E-mail could not be sent.

Post by metaltome » Wed Apr 15, 2009 11:48 pm

Is this ever going to be addressed or fixed? I am having the same issue. It wasn't resolved in 1.5.10 :(

I have noticed that if I enter an email address in the "From Email" with my @mydomain.com it will actually send out the email. The error only pops up if you try to put in an email address outside of your domain.

metaltome
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Fri Jan 23, 2009 7:47 pm

Re: E-mail could not be sent.

Post by metaltome » Wed Apr 22, 2009 1:00 am

I've opened a new ticket regarding this, since the other one was closed without a resolution (or at least I couldn't seem to find one in the bug tracker ticket). Anyone with any advice or ideas on how to correct this issue please Follow-Up at the URL below:

http://joomlacode.org/gf/project/joomla ... m_id=16076

User avatar
mcsmom
Joomla! Exemplar
Joomla! Exemplar
Posts: 7985
Joined: Thu Aug 18, 2005 8:43 pm
Location: New York
Contact:

Re: E-mail could not be sent.

Post by mcsmom » Wed Apr 22, 2009 9:40 pm

Can everyone please try using the from address from within your own domains?

This is an issue with the server set up where for security reasons they do not send email that is not from their own domain. This makes sense at some level because it prevents your domain's mail server from being used to spam people.

If you are hosted and you do have this no outside domain issue, please check with your host about how to deal with it.
So we must fix our vision not merely on the negative expulsion of war, but upon the positive affirmation of peace. MLK 1964.
http://officialjoomlabook.com Get it at http://www.joomla.org/joomla-press-official-books.html Buy a book, support Joomla!.

keith4298
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sun Feb 01, 2009 7:00 pm

Re: E-mail could not be sent.

Post by keith4298 » Tue Apr 28, 2009 9:00 pm

his is an issue with the server set up where for security reasons they do not send email that is not from their own domain. This makes sense at some level because it prevents your domain's mail server from being used to spam people.
That's the problem. Thanks for letting us know.

lordnukem
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Mar 06, 2009 3:12 am

Re: E-mail could not be sent.

Post by lordnukem » Tue May 05, 2009 4:13 pm

Hi guys,

I got this error on my Joomla 1.5 installation on 1 server while another server the function works..
I noticed that the mailx package was missing on the server that has this Error.

a quick 'yum install mailx' and 'service httpd restart' fixed the problem..

Hope it helps.


-Eddie

namduyledung
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Mon Mar 02, 2009 4:35 am
Contact:

Re: E-mail could not be sent.

Post by namduyledung » Tue May 05, 2009 6:22 pm

Use: http://translate.google.com/translate_t?hl=en#
Tiếp theo tại tài khoản mail server của bạn phải thiết lập chế độ cho phép gửi bằng SMTP như sau:

Log in vào tài khoản của bạn tại http://gmail.com
Chọn phần Setting phía trên cùng bên phải màn hình
Trong Tab Forwading and POP/IMAP chọn giá trị là Enable POP for all mail (even mail that's already been downloaded) và save lại

Sau khi hoàn tất phần thiết lập các thông số, bạn vào Tool-> Mass mail và gửi thử email đến các thành viên của website

Phần dành cho phiên bản Joomla >=1.5.9, gặp lỗi với bản Patch ở trên

Download bản hướng dẫn sau về để thực hiện sửa code

Hướng dẫn code SMTP support SSL/TPL mail for Joomla

Giải thích thêm về việc thêm code:

diff -burN stlcc-backup/administrator/components/com_config/controllers/application.php -> tìmđến file có địa chỉ /administrator/components/com_config/controllers/application.php


+ $config_array['smtpsecure'] = JRequest::getVar('smtpsecure', 'none', 'post', 'word');

--> có dấu "+" ở đầu dòng nghĩa là thêm vào đoạn code đó


- $mail->useSMTP($smtpauth, $smtphost, $smtpuser, $smtppass);

--> có dấu "-"ở đầu dòng nghĩa là xóa đoạn code này đi

mbohanon
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Fri Nov 30, 2007 12:37 am

Re: E-mail could not be sent.

Post by mbohanon » Wed May 13, 2009 8:49 pm

This is a fix for if you are receiving the error "E-mail could not be sent" when using the e-mail link (and pop-up send to form) from within an article or content page in Joomla.

To resolve this problem, open this file:

components/com_mailto/controller.php

Locate the following line of code (approximately line 57):

if($timeout == 0 || time() - $timeout < 20) {

Change the line to the following:

if($timeout == 0 || time() - $timeout > 20) {

You can also increase the time from 20 to say 50.

You can also check out this report here:
http://joomlacode.org/gf/project/joomla ... m_id=14809

Good luck!
Monica Bohanon
http://AllegroConsultants.com/opensource | 804-553-1130
Allegro has the Open-Source Experts You Need
SugarCRM, Joomla, osCommerce, PHP, and More

llimch
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Nov 01, 2008 1:13 am

Re: E-mail could not be sent.

Post by llimch » Wed May 20, 2009 8:55 am

Hi mbohanon,

You are a life saver!!! The above suggestion works for me for V1.5.10.

Hopes everyone try this out

keith4298
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sun Feb 01, 2009 7:00 pm

Re: E-mail could not be sent.

Post by keith4298 » Wed May 20, 2009 4:04 pm

Worked for me too! Thanks a lot.

User avatar
syhussaini
Joomla! Explorer
Joomla! Explorer
Posts: 402
Joined: Sat Jan 03, 2009 2:20 pm
Location: Hyderabad-India
Contact:

Re: E-mail could not be sent.

Post by syhussaini » Sun May 24, 2009 9:23 am

I tried the above as suggested, however had no luck.

It works well in Firefox but not in IE.

I am using Joomla 1.5.10 (Upgraded recently from 1.5.8)

Please help.

mbohanon
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Fri Nov 30, 2007 12:37 am

Re: E-mail could not be sent.

Post by mbohanon » Sun May 24, 2009 9:30 pm

Hi Syed,
What type of errors are you getting in IE? What version of IE are you using? Can you provide more detail or the link to the site you're working on?
Thanks,
~Monica
Monica Bohanon
http://AllegroConsultants.com/opensource | 804-553-1130
Allegro has the Open-Source Experts You Need
SugarCRM, Joomla, osCommerce, PHP, and More

User avatar
syhussaini
Joomla! Explorer
Joomla! Explorer
Posts: 402
Joined: Sat Jan 03, 2009 2:20 pm
Location: Hyderabad-India
Contact:

Re: E-mail could not be sent.

Post by syhussaini » Mon May 25, 2009 6:22 pm

Hi Monica,

I am using IE: 7
Joomla Version: 1.5.10(1.5.8)
Website: www.hadithcollection.com

Error when i send an email: E-mail could not be sent.
When i create a PDF, it simply gives me a blank page under IE.
It works fine in Firefox.

These problems started since i upgraded. The admin console and site also keeps timing out since upgrade frequently. It was perfect before the upgrade.

Please Help.

Note: I still have an option to rollback within 12 days to my previous version.

User avatar
syhussaini
Joomla! Explorer
Joomla! Explorer
Posts: 402
Joined: Sat Jan 03, 2009 2:20 pm
Location: Hyderabad-India
Contact:

Re: E-mail could not be sent.

Post by syhussaini » Mon May 25, 2009 6:26 pm

Well, The email problem started in Firefox also.
Please help.

malcontentious
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Thu Apr 23, 2009 10:20 pm

Re: E-mail could not be sent.

Post by malcontentious » Mon Jun 15, 2009 5:03 pm

Not working at all with the code change provided. Using joomla 1.5.10. Very disappointing.

mbohanon
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Fri Nov 30, 2007 12:37 am

Re: E-mail could not be sent.

Post by mbohanon » Mon Jun 15, 2009 5:13 pm

Could also be your memory, you can set/increase this in your php.ini or .htaccess by adding the following:

php_value memory_limit 32M

By changing the memory limit, it resolved the blank PDF issue for me. Also, below is a link to another thread that may help. Search for "browser_detection.php" (after clicking the link below), which is a file you will need to create and upload to your server. There's step-by-step instructions here:

http://forum.joomla.org/viewtopic.php?f ... 7t+get+pdf

Good luck!
~m
Monica Bohanon
http://AllegroConsultants.com/opensource | 804-553-1130
Allegro has the Open-Source Experts You Need
SugarCRM, Joomla, osCommerce, PHP, and More

malcontentious
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Thu Apr 23, 2009 10:20 pm

Re: E-mail could not be sent.

Post by malcontentious » Mon Jun 15, 2009 5:39 pm

Thanks but...the PDF part works. It is the email that will not go out. I don't know about editing the php.ini file but maybe I will try it. For now, I am hiding the pesky and unworking email icon on all articles.

ashaqhussain
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Fri Jun 26, 2009 5:07 pm

Re: E-mail could not be sent.

Post by ashaqhussain » Fri Jun 26, 2009 5:50 pm

not working :(

Fireflight
Joomla! Intern
Joomla! Intern
Posts: 65
Joined: Fri Mar 30, 2007 4:29 pm

Re: E-mail could not be sent.

Post by Fireflight » Tue Jul 07, 2009 5:21 pm

This problem still exists even on Joomla's own site! http://www.joomla.org/announcements/gen ... rward.html

Try using the email article option. Unless you enter a @joomla.org email as the from the email will not send!

I'm sick of dealing with this idiotic problem, so I simply commented out the code that adds the time delay as I was waiting much longer than 20 seconds between successfully sent emails. I also commented out the check for a local domain. In com_mailto/controller.php comment out the following two blocks.

Code: Select all

$timeout = $session->get('com_mailto.formtime', 0);
		if($timeout == 0 || time() - $timeout < 20) {
			JError::raiseNotice( 500, JText:: _ ('EMAIL_NOT_SENT' ));
			return $this->mailto();
		}
and

Code: Select all

if(!JURI::isInternal($link)) {
			//Non-local url...  
			JError::raiseNotice( 500, JText:: _ ('EMAIL_NOT_SENT' ));
			return $this->mailto();
		}
Now your emails will send successfully! However, the form's security has been reduced, but at this point I just don't give a damn about spammers. I just want the email to friend function to work.

I also love the helpful error messages of "Email not sent"! Thanks guys, those are real helpful for debugging what the problem is when every error state throws the same error message.

User avatar
bulesz
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Mon Jul 02, 2007 10:28 am

Re: E-mail could not be sent.

Post by bulesz » Thu Jul 23, 2009 12:15 pm

Thanks, this last "killer" solution is working well!

ashaqhussain
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Fri Jun 26, 2009 5:07 pm

Re: E-mail could not be sent.

Post by ashaqhussain » Thu Jul 23, 2009 12:43 pm

@FireFlight i am sick with this problem please explain what does comment out mean.

User avatar
bulesz
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Mon Jul 02, 2007 10:28 am

Re: E-mail could not be sent.

Post by bulesz » Thu Jul 23, 2009 1:57 pm

Yo, please read the post again...those quoted rows... its easy as 123...

mbohanon
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Fri Nov 30, 2007 12:37 am

Re: E-mail could not be sent.

Post by mbohanon » Thu Jul 23, 2009 2:07 pm

ashaqhussain wrote:@FireFlight i am sick with this problem please explain what does comment out mean.

Commenting php code can be done either by block:

/* block comment */

or by single line like so:

// block comment

The rest is spelled out for you above.
Good luck!
~m
Monica Bohanon
http://AllegroConsultants.com/opensource | 804-553-1130
Allegro has the Open-Source Experts You Need
SugarCRM, Joomla, osCommerce, PHP, and More


Locked

Return to “Extensions for Joomla! 1.5”