Plugin for [youtube] videos

This forum is for general questions about extensions for Joomla! version 1.5.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
mandm
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Jun 23, 2008 2:47 pm

Re: Plugin for [youtube] videos

Postby mandm » Wed Jun 25, 2008 1:13 am

Please help me with the step ny step installation process for the plugin..
i have downloaded [youtube] 1.1 and now am stuck with this on how to install

User avatar
fusionx1
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Tue Jun 06, 2006 10:08 am
Location: Makati, Philippines
Contact:

Re: Plugin for [youtube] videos

Postby fusionx1 » Fri Jun 27, 2008 9:25 am

how can I get [youtube] Id where can i get it? :-\

dustycat
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Thu Jun 26, 2008 1:34 pm

Re: Plugin for [youtube] videos

Postby dustycat » Wed Jul 02, 2008 6:43 am

I have downloaded and installed the plugin but when I create an article and put

{[youtube]}xxxxxxxx{/[youtube]}

in it and save the article, I cannot view it. I get the following error:

Internet Explorer cannot open the internet site:
http://www.mydomain.com/index.php?optio ... &itemid=83.
Operation aborted


I am able to open articles in this section and category that aren't using the plugin.

Could you tell me what I need to do to fix this.

Thanks

Oh, by the way FusionX1 you get the [youtube] id for the video you want at [youtube]. The easiest way is to go to the video you want to embed. In the URL at the top you will see something like:

http://www.[youtube].com/watch?v=1hnB20w6bgQ

The string after v= is the id for that video.

genesis33
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Jul 10, 2008 6:09 pm

Re: Plugin for [youtube] videos

Postby genesis33 » Thu Jul 10, 2008 6:16 pm

When I put in the code nothing comes up, I've enabled the plugin and inserted the code into an article and nothing shows. Can you confim that Im putting in the correct code:


{[youtube]}<object width="425" height="350"> <param name="movie" value="http://www.[youtube].com/v/LTg6zkJVFuE"> </param> <embed src="http://www.[youtube].com/v/LTg6zkJVFuE" type="application/x-shockwave-flash" width="425" height="350"> </embed> </object>{/[youtube]}

Thanks
Steve

dustycat
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Thu Jun 26, 2008 1:34 pm

Re: Plugin for [youtube] videos

Postby dustycat » Fri Jul 11, 2008 9:35 am

I've since found a better plugin that works straightaway - mgmediabot2. OK so it's running in legacy mode in 1.5 but it works!!!

http://extensions.joomla.org/component/option,com_mtree/task,viewlink/link_id,440/Itemid,35/

atramo
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Jul 30, 2008 9:18 pm

Re: Plugin for [youtube] videos

Postby atramo » Wed Jul 30, 2008 9:35 pm

genesis33 wrote:When I put in the code nothing comes up, I've enabled the plugin and inserted the code into an article and nothing shows. Can you confim that Im putting in the correct code:


{[youtube]}<object width="425" height="350"> <param name="movie" value="http://www.[youtube].com/v/LTg6zkJVFuE"> </param> <embed src="http://www.[youtube].com/v/LTg6zkJVFuE" type="application/x-shockwave-flash" width="425" height="350"> </embed> </object>{/[youtube]}

Thanks
Steve


Hi Steve. Excuse me for my poor english...
I'm a beginner, but it seems to me it's simpler than you believe ... in your example you have only to write {[youtube]}LTg6zkJVFuE{/[youtube]} in your article in Joomla! The plugin inserts the details for you; if you want you can see the generated html when the page is displayed. I hope this helps you!
Bye, Andrea.

jandalfas
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Wed Jun 18, 2008 6:51 pm

Re: Plugin for [youtube] videos

Postby jandalfas » Thu Jul 31, 2008 12:33 pm

Hello, it's really nice plugin I use it in my project until now. I need to put video tu module and plugin doesn't work.

I create custom module and insert my video into: {[youtube]}edwdwefw{/[youtube]} On front page in this module I saw teh same code: {[youtube]}edwdwefw{/[youtube]} without a video.

As I understand this plugin need some tweaking or modification to show videos in modules ?

I'm right ?

Maybe some one could help me to solve this problem or advice some other plugin ?

Thank you.

jandalfas
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Wed Jun 18, 2008 6:51 pm

Re: Plugin for [youtube] videos - place in module

Postby jandalfas » Fri Aug 01, 2008 8:03 am

Hello Stian,

could you provide any information on my previous post ?

Thank you

User avatar
OnTheMarkDesign
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 191
Joined: Thu Apr 24, 2008 10:11 pm
Location: Inland Empire, California, USA
Contact:

Re: Plugin for [youtube] videos

Postby OnTheMarkDesign » Sun Aug 24, 2008 6:02 am

Stian wrote:So, the short version is that the plugin doesn't work at all?

Have you tried it in for example Firefox? If it works there I think you need to tweak the security/privacy options in IE.

Stian


Plugin works fine in both IE and Firefox when you are not logged in as a user of the Joomla site.
Once you login (or already logged in), it can't open the page in either IE or Firefox!!!!!!

Sounds like it's a Joomla/[youtube] plugin issue to me!
http://OnTheMarkDesign.com

Joomla! Community Magazine Team Member
Follow Me at https://twitter.com/OnTheMarkDesign

burot
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue Feb 26, 2008 11:48 am

Re: Plugin for [youtube] videos

Postby burot » Mon Sep 22, 2008 7:30 pm

Hi,

I have installed this plugin, i have create a new article and i have wrote {[youtube]}IDxxxx{/[youtube]}

When I enter in that article i can see the box with the video, but when i push the "play" button the video doesnt load and this message appears:

We're are sorry, this video is no longer available

It happens with all the [youtube] videos. I can see the video in the [youtube] web but in my site is no loger available

¿any idea?

Thanks

vladanjovanovic
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Aug 18, 2008 7:22 am

Re: Plugin for [youtube] videos

Postby vladanjovanovic » Wed Nov 19, 2008 12:54 pm

Problem with Internet explorer and embedding [youtube] videos is explained well in following webpage:http://www.bernzilla.com/item.php?id=681

I fixed this problem by modifying [youtube].php in plugins/content folder. Replace what is in the "else" branch (line 38) with:

Code: Select all

$html .= '<object type="application/x-shockwave-flash" style="width:' . $newSize["width"] . 'px; height:' . $newSize["height"] . 'px;"';

$html .= ' data="http://www.[youtube].com/' . $playerType . '/' . $query . '"><param name="movie" value="http://www.[youtube].com/' .$playerType . '/' . $query\
 . '"/></object>';



This should generate proper code that won't crash IE and works in Firefox too.

Also disable SWF object use and inclusion in plugin setup!

drewgg
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 161
Joined: Thu Oct 30, 2008 7:27 pm

Re: Plugin for [youtube] videos

Postby drewgg » Mon Dec 01, 2008 6:19 pm

vladanjovanovic wrote:Problem with Internet explorer and embedding [youtube] videos is explained well in following webpage:http://www.bernzilla.com/item.php?id=681

I fixed this problem by modifying [youtube].php in plugins/content folder. Replace what is in the "else" branch (line 38) with:

[snip]

This should generate proper code that won't crash IE and works in Firefox too.

Also disable SWF object use and inclusion in plugin setup!


I was also having the problem with IE users getting a fatal error and vladanjovanovic's solution worked for me. (though the else statement was on line 85 instead of 38 in plugins/content/[youtube].php). Secondly, in the code vladanjovanovic posted, it has...

Code: Select all

'/' . $query\
. '"/></object>';

php was giving me warnings over that "\" in there, so I got rid of it...

Code: Select all

'/' . $query . '"/></object>';

afandi
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 105
Joined: Tue May 23, 2006 6:50 am

Re: Plugin for [youtube] videos

Postby afandi » Tue Jan 06, 2009 3:21 am

yeah it works, just put the =" " from u tube website for example {[youtube]}ESFt7r5HCDQ{/[youtube]}

from a complete URL http://www.[youtube].com/watch?v=ESFt7r5HCDQ

see the result: http://energy4all.biz

JackBauer
Joomla! Apprentice
Joomla! Apprentice
Posts: 35
Joined: Sun Apr 09, 2006 3:28 am

Re: Plugin for [youtube] videos

Postby JackBauer » Thu Jan 08, 2009 4:30 am

I put this code into my article: {[youtube]}sxRc7cUv8Ac{/[youtube]}

It still is displaying that code, not the video.

alex82
Joomla! Intern
Joomla! Intern
Posts: 90
Joined: Fri Aug 29, 2008 4:08 pm
Location: Beograd

Re: Plugin for [youtube] videos

Postby alex82 » Fri Jan 30, 2009 1:59 am

hi there, I have download this component "com_mgmedia2-1.17n" and bot "bot_mgmedia2-0.8" and installed. When I try to put this code "{mgmediabot2}type=[youtube]|[youtube]=3g-yrjh58ms|popup=[youtube] Popup|width=425|height=350{/mgmediabot2}" the result is the same code on the page?! Why? Can enyone help me with this problem? I installed joomla 1.5.8 version.
sale

mgeorge27
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Mar 05, 2009 5:45 am

Re: Plugin for [youtube] videos

Postby mgeorge27 » Thu Mar 05, 2009 5:47 am

Can the creator of this plugin update this to support playing HD videos by default and Full screen option in the player bar.

User avatar
ggmittal
Joomla! Apprentice
Joomla! Apprentice
Posts: 32
Joined: Sat Aug 16, 2008 4:44 am
Location: Punjab, INDIA
Contact:

Re: Plugin for [youtube] videos

Postby ggmittal » Thu Mar 05, 2009 11:04 am

i think joomla 1.5.9 is already supporting [youtube] and other videos.. no need to install extra plugin..
Gaurav Mittal

http://www.till2day.com - Technology Tips and Tricks
http://baydark.com - Black Search Engine

User avatar
Chacapamac
Joomla! Guru
Joomla! Guru
Posts: 789
Joined: Wed Feb 20, 2008 6:50 am
Location: Canada, Montreal
Contact:

Re: Plugin for [youtube] videos

Postby Chacapamac » Mon Mar 09, 2009 4:53 pm

I’m testing your player and it work perfecly... I like to embeded a custom player from [youtube]. How do you do that, because I didn’t find a tutorial or some hints in the documentation?

Thanks in advance for your help!

UPDATE: I was able to play a custom player and is attach vidéos by inserting the full [youtube] code:

{[youtube]}<object width="746" height="413"><param name="movie" value="http://www.[youtube].com/cp/xxxxxxxxxxxxxxxxxxxxxxx="></param><embed src="http://www.[youtube].com/cp/xxxxxxxxxxxxxxxxxxxxxxx=" type="application/x-shockwave-flash" width="746" height="413"></embed></object>{/[youtube]}

Curiously that doesn’t work with the default player with a playlist?????
I have to insert the normal code to make it work:
{[youtube]}xxxxxxxxxxxxxxxxxxxxxx{/[youtube]}

and both make the original video bigger ( Ireally like them to play at 100% of the size
I kept the plugin without size to be able to play videos of different size...

Anybody know how to insert the size in the code or to say to you tube to play them at 100%?

Good Day everybody! :)
Can God help us?
Marketing, SEO, Web development - Powered by Joomla!
http://www.grafcomm.ca/

User avatar
nesomis
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Thu Mar 12, 2009 7:07 pm

Re: Plugin for [youtube] videos

Postby nesomis » Thu Mar 12, 2009 7:09 pm

Thanks !!! This is a great stuff and work so simply !!!

cyberrob
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Apr 20, 2009 6:38 pm

Re: Plugin for [youtube] videos

Postby cyberrob » Mon Apr 20, 2009 6:43 pm

Thank you for this great plugin. I installed it and it worked without any problems.
Just one thing: I'd like to use additional parameters , e. g. one named "allowFullScreen".
Do I have to change the code in "[youtube].php" or is there a less difficult way?
Regards,
Roland

solidtartan
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Jan 25, 2008 2:02 am

Re: Plugin for [youtube] videos

Postby solidtartan » Tue Apr 21, 2009 9:48 pm

Great plug in for single vids but when I put in a playlist nothing shows....is there something I am missing?

marsav
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Mon Apr 13, 2009 3:11 pm

Re: Plugin for [youtube] videos

Postby marsav » Wed Apr 22, 2009 8:40 pm

drewgg wrote:
vladanjovanovic wrote:Problem with Internet explorer and embedding [youtube] videos is explained well in following webpage:http://www.bernzilla.com/item.php?id=681

I fixed this problem by modifying [youtube].php in plugins/content folder. Replace what is in the "else" branch (line 38) with:

[snip]

This should generate proper code that won't crash IE and works in Firefox too.

Also disable SWF object use and inclusion in plugin setup!


I was also having the problem with IE users getting a fatal error and vladanjovanovic's solution worked for me. (though the else statement was on line 85 instead of 38 in plugins/content/[youtube].php). Secondly, in the code vladanjovanovic posted, it has...

Code: Select all

'/' . $query\
. '"/></object>';

php was giving me warnings over that "\" in there, so I got rid of it...

Code: Select all

'/' . $query . '"/></object>';


Thanks a million. That solved the problem I was having.

Brilliant plugin

wanderfus
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Apr 23, 2009 7:54 am

Re: Plugin for [youtube] videos

Postby wanderfus » Thu Apr 23, 2009 8:10 am

it is not work...
Do you believe your girlfriend?
http://www.smstrap.com/go/NDI3MTow/ Check Her SMS Box Online!
My girl is honest with me, how about your?
Signature rules: Literal URL's Only.

Raji
Joomla! Intern
Joomla! Intern
Posts: 52
Joined: Mon Feb 04, 2008 10:26 am

Re: Plugin for [youtube] videos

Postby Raji » Sat May 02, 2009 6:25 am

ggmittal wrote:i think joomla 1.5.9 is already supporting [youtube] and other videos.. no need to install extra plugin..


Can you plz tell me how it works? means I want to know how can I put [youtube] or google video url under my articles?

sw6media
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri May 15, 2009 3:06 am

Re: Plugin for [youtube] videos - Cant get custom player working

Postby sw6media » Fri May 15, 2009 3:12 am

Hi mate,

I am trying to get my custom player working on my site and cant seem to get it to show.
I can get a single video playing no prob.

But i have tried every (almost) combination of link and nothing seems to show at all.

Here is the original link to the custom player which works in a browser by it self.
"http://www.[youtube].com/cp/vjVQa1PpcFOYwXPgT-_outmEMHfYRP-8XvgB8bCHPkk="

and ive tried.{[youtube]}.......{/[youtube]}
vjVQa1PpcFOYwXPgT-_outmEMHfYRP-8XvgB8bCHPkk=
vjVQa1PpcFOYwXPgT
8XvgB8bCHPkk=
outmEMHfYRP-8XvgB8bCHPkk=
etc

Am i doing anything wrong?

Thanks,

nick

marsav
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Mon Apr 13, 2009 3:11 pm

Re: Plugin for [youtube] videos

Postby marsav » Fri May 15, 2009 7:04 pm

I'm new to this, but have you tried the following:

{[youtube]}<object width="560" height="340"><param name="movie" value="http://www.[youtube].com/v/hSfikcr7txU&hl=en&fs=1"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.[youtube].com/v/hSfikcr7txU&hl=en&fs=1" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="560" height="340"></embed></object>{/[youtube]}


Also to just play it normally on the page you can try the followng:

{[youtube]}hSfikcr7txU{/[youtube]}
I have taken the embed parameters from [youtube].

When you are creating the article with the video embedded, make sure you go into edit HTML. I have found that it has a habit of adding in HTML attributes.

In HTML view this is correct:

<p>Test Video 3</p></div></span><p>{[youtube]}o7Tqk-xf4s4{/[youtube]} </p>

This is wrong:

<p>Test Video 3 </p><p> {[youtube]}o7Tqk-xf4s4{/[youtube]}</p><p> </p><span style="color: #000000; font-family: 'Times New Roman'; font-size: 16px; line-height: normal" class="Apple-style-span"><div style="background-image: initial; background-repeat: initial; background-attachment: initial; -webkit-background-clip: initial; -webkit-background-origin: initial; background-color: #ffffff; font-family: Tahoma, Helvetica, Arial, sans-serif; line-height: 1.3em; font-size: 76%; color: #333333; display: block">

Hope it helps

solidtartan
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Jan 25, 2008 2:02 am

Re: Plugin for [youtube] videos

Postby solidtartan » Fri Jul 10, 2009 10:46 pm

Is there a way to make the video autoplay?

pal4life26
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Aug 14, 2009 9:51 pm

Cannot install plugin

Postby pal4life26 » Fri Aug 14, 2009 9:54 pm

hi,
Sorry for being a nobb.
I downlaoded the zip for the plugin on to my hard drive and from the Extension manager-> upload package File. Selected the zip file and clicked on upload and install but joomla instead returns a message saying Unable to find install package. Also tried to install using the URL http://joomlacode.org/gf/download/frsre ... ube1.1.zip
Got the same response. Is there an alternative way to install this plugin or am I doing this the wrong way?

Thanking you

jen2swt
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Fri Oct 26, 2007 7:50 pm

Re: Plugin for [youtube] videos

Postby jen2swt » Sat Aug 29, 2009 2:05 pm

Works great for me...however it would be nice to add a [youtube] button to the editor toolbar that will insert the {[youtube]}{/[youtube]} code only needing to add the ID in between the two...

sisaenko
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Jun 26, 2009 2:50 pm

Re: Plugin for [youtube] videos

Postby sisaenko » Mon Aug 31, 2009 4:29 pm

Hi, I love this module is perfect for what I am doing, but I have a few unresolved issues...

Is there a fullscreenmode button that could be added to the player,
some videos that I ember {[youtube]}xxxx{/[youtube]}
do no have the fullscreen option, would be nice.

Thanks


Return to “Extensions for Joomla! 1.5”

Who is online

Users browsing this forum: No registered users and 3 guests