1.5 Installer will not install SQL in XML file

Locked
RAGEDBULL
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 164
Joined: Wed Jun 21, 2006 2:50 am

1.5 Installer will not install SQL in XML file

Post by RAGEDBULL » Sat Jul 26, 2008 11:32 pm

Hello,

I want to know if this is just my server, or if this is a bug in Joomla. According to the DTD, you can tell Joomla to install SQL from a file location or pass individual quieries. I would prefer to use the external file for better managment and readability of the XML install file. However, it does not seem to install or even read the SQL file.

For example:

Code: Select all

             <install>
		<sql>
			<file driver="mysql" charset="utf8">install.mysql.sql</file>
			<file>install.mysql.sql</file>
		</sql>
	</install>

	<uninstall>
		<sql>
			<file driver="mysql" charset="utf8">uninstall.mysql.sql</file>
			<file>uninstall.mysql.sql</file>
		</sql>
	</uninstall>
It does not parse these install files. It will install the rest of the component without a problem, but it posts no error message. I am pretty sure the installation code is not even processing the SQL files because it I change the file name to something non existant:

Code: Select all

<sql>
	<file driver="mysql" charset="utf8">foobar.sql</file>
	<file>foobar.sql</file>
</sql>
It dosn't produce an error for the non existant foobar.sql.


I read somewhere that in the early betas that the processing of the external SQL was not implemented, but I was under the impression it was not, since every tutorial tells you to do it this way. I downloaded some other components that use this method, and they also did not work, which leads me to believe its my installation (??) Because they wouldn't have uploaded code that dosn't work for anyone most likely. For example, I looked at this one:
http://extensions.joomla.org/component/ ... Itemid,35/.

So any ideas on what's going on, or do I have to switch it to use query elements within the XML?

Thanks.

User avatar
carsten888
Joomla! Ace
Joomla! Ace
Posts: 1217
Joined: Sat Feb 11, 2006 8:32 am
Contact:

Re: 1.5 Installer will not install SQL in XML file

Post by carsten888 » Thu Jul 31, 2008 12:20 pm

I don't know why this does no longer work that way. But if you put your queries in an install.component_name.php it will work.

Code: Select all

function com_install(){
	global $database;

	//get database
	if(defined('_JEXEC')){
		//joomla 1.5
		$database = JFactory::getDBO();
	}	
	
	//table for item index
	$database->setQuery("CREATE TABLE IF NOT EXISTS #__pi_item_index (
  `id` int(11) NOT NULL auto_increment,
  `item_id` int(11) NOT NULL,
  `itemtype` tinytext NOT NULL,
  `show_title` tinyint(4) NOT NULL,
  PRIMARY KEY  (`id`)
) ");
$database->query();
hope that helps
:D
http://www.pages-and-items.com my extensions:
User-Private-Page, Redirect-on-Login, Admin-Help-Pages, Dynamic-Menu-Links, Admin-Menu-Manager, plugin load module in article, plugin pure css tooltip and more...

RAGEDBULL
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 164
Joined: Wed Jun 21, 2006 2:50 am

Re: 1.5 Installer will not install SQL in XML file

Post by RAGEDBULL » Thu Jul 31, 2008 3:23 pm

Does it no longer work for you (and/or others) or is is just me?

What I did for this particular component isuse individual query statements in the xml since there are only 3 tables and 1 with ready made data.

But if the spec calls for it in the DTD and even in the MVC tutorials on the wiki, it should work.

User avatar
carsten888
Joomla! Ace
Joomla! Ace
Posts: 1217
Joined: Sat Feb 11, 2006 8:32 am
Contact:

Re: 1.5 Installer will not install SQL in XML file

Post by carsten888 » Thu Jul 31, 2008 6:00 pm

Does it no longer work for you (and/or others) or is is just me?
not just you :D
I saw the old method, and wanted to make my components code work in all versions of joomla, so after finding out it does not work in 1.5.x is abandoned it. If its still in some tut contact the documentation department. good luck.
http://www.pages-and-items.com my extensions:
User-Private-Page, Redirect-on-Login, Admin-Help-Pages, Dynamic-Menu-Links, Admin-Menu-Manager, plugin load module in article, plugin pure css tooltip and more...

RAGEDBULL
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 164
Joined: Wed Jun 21, 2006 2:50 am

Re: 1.5 Installer will not install SQL in XML file

Post by RAGEDBULL » Thu Jul 31, 2008 9:10 pm

Places where the say this is the way for 1.5 (I don't recall this ever working for 1.0.xx). Also, I have no idea how this ever could have worked since PHP dosn't allow stacked statements in one call, and I am not sure how well it would be parsed by Joomla, since that would also open the doors for all sorts of injections too, which PHP limits somewhat with this inconvience:


http://extensions.joomla.org/component/ ... Itemid,35/

http://dev.joomla.org/component/option, ... orld_mvc3/

Then again, the documentation is pretty crapp and full of typos and sentences which make no sense. I have not played with enough third party apps to see if it works with someone elses setup.

The weird thing is, you specify the sql file, it does not report it as a broken XML file or anything during install, it just kind of skips over it or dosn't process it, which leads me to believe it is acceptable method, but there is an error somewhere and its not reporting it.

RAGEDBULL
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 164
Joined: Wed Jun 21, 2006 2:50 am

Re: 1.5 Installer will not install SQL in XML file

Post by RAGEDBULL » Thu Jul 31, 2008 9:12 pm

I think I will repost this topic in 1.5 DEV since I tend to get more of a response there.

User avatar
Alfred
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 142
Joined: Fri Aug 04, 2006 11:28 am
Contact:

Re: 1.5 Installer will not install SQL in XML file

Post by Alfred » Thu Jul 31, 2008 9:42 pm

This works just fine for me...

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
<install type="component" version="1.5.0">
  <name>ALFcontact</name>
  <creationDate>July 2008</creationDate>
  <author>Alfred Vink</author>
  <copyright>GNU/GPL</copyright>
  <authorEmail>alfred@alfsoft.com</authorEmail>
  <authorUrl>www.alfsoft.com</authorUrl>
  <version>1.5</version>
  <description>A simple contactform</description>
  <installfile>install.alfcontact.php</installfile>
  <uninstallfile>uninstall.alfcontact.php</uninstallfile>
  <params>
	<param name="title" default="Contact" />
	<param name="intro" default="" />
  </params>
  <install>
	<sql>
		<file driver="mysql" charset="utf8">install.mysql.sql</file>
	</sql>
  </install>
  <uninstall>
	<sql>
		<file driver="mysql" charset="utf8">uninstall.mysql.sql</file>
	</sql>
  </uninstall>
  <files>
    <filename>alfcontact.php</filename>
    <filename>alfcontact.html.php</filename>
	<filename>index.html</filename>
  </files>
  <languages>
		<language tag="en-GB">en-GB.com_alfcontact.ini</language>
  </languages>
  <administration>
    <menu>ALFContact</menu>
    <files>
      <filename>install.mysql.sql</filename>
	  <filename>uninstall.mysql.sql</filename>
	  <filename>admin.alfcontact.php</filename>
      <filename>admin.alfcontact.html.php</filename>
	  <filename>controller.php</filename>
      <filename>tables/alfcontact.php</filename>
      <filename>toolbar.alfcontact.php</filename>
      <filename>toolbar.alfcontact.html.php</filename>
	  <filename>config.xml</filename>
	  <filename>index.html</filename>
    </files>
	<languages>
		<language tag="en-GB">en-GB.com_alfcontact.ini</language>
		<language tag="en-GB">en-GB.com_alfcontact.menu.ini</language>
	</languages>
  </administration>
</install>
it looks like putting the sql files under administration/files instead of install/sql does the trick.

User avatar
hgraca
Joomla! Apprentice
Joomla! Apprentice
Posts: 30
Joined: Fri Jul 11, 2008 10:47 pm

Re: 1.5 Installer will not install SQL in XML file

Post by hgraca » Fri Aug 01, 2008 11:42 pm

hi, i just had this problem...

I think I found out what the problem is...

After trying lots of different combinations I end up with this:

Code: Select all

...
	<install>
		<sql>
			<file charset="utf8" driver="mysql">install.sql</file>
		</sql>
	</install>
	
	<uninstall>
		<sql>
			<file charset="utf8" driver="mysql">uninstall.sql</file>
		</sql>
	</uninstall>
		
	<administration>
		<menu>Herb File Selector</menu>
		
		<files folder="admin">
			<filename>admin.herbfileselector.php</filename>
			<filename>controller.php</filename>
			<filename>index.html</filename>
			<filename>install.sql</filename>
			<filename>uninstall.sql</filename>
			<folder>views</folder>
			<folder>models</folder>
		</files>		
... 
and what does the trick is this 2 lines in the administration section:

Code: Select all

			<filename>install.sql</filename>
			<filename>uninstall.sql</filename>
also, dont forget this:

Code: Select all

		<files folder="admin">
if you have your files inside an "admin" folder.

hope it helps, let us know how it goes.

RAGEDBULL
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 164
Joined: Wed Jun 21, 2006 2:50 am

Re: 1.5 Installer will not install SQL in XML file

Post by RAGEDBULL » Sat Aug 02, 2008 12:18 am

For me it didn't matter about the file locations, i tried putting them in every folder, including it in multiple locations, specifying root folders in the parent attribute, doing full paths, did not matter.

User avatar
hgraca
Joomla! Apprentice
Joomla! Apprentice
Posts: 30
Joined: Fri Jul 11, 2008 10:47 pm

Re: 1.5 Installer will not install SQL in XML file

Post by hgraca » Sat Aug 02, 2008 12:34 am

can you please post your full xml file?

tvahrst
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Jul 28, 2008 11:43 am

Re: 1.5 Installer will not install SQL in XML file

Post by tvahrst » Thu Aug 07, 2008 7:54 pm

Hi,
I had the same problem:
First, I forgot to put the install files into the admin filelist (thanks to hgrace for the tip).
After this, the install.sql script was again not executed during installation. Then I duplicated the install-entry
old:

Code: Select all

	<install>
		<sql>
			<file charset="utf8" driver="mysql">install.sql</file>
		</sql>
	</install>
now:

Code: Select all

	<install>
		<sql>
			<file charset="utf8" driver="mysql">install.sql</file>
			<file driver="mysql">install.sql</file>
		</sql>
	</install>
It seems, that the default charset of the mysql database isn't utf8, so I added the second default entry.
BTW: The single default entry should also work - my install.sql file contains only ASCII characters:

Code: Select all

	<install>
		<sql>
			<file driver="mysql">install.sql</file>
		</sql>
	</install>

User avatar
hgraca
Joomla! Apprentice
Joomla! Apprentice
Posts: 30
Joined: Fri Jul 11, 2008 10:47 pm

Re: 1.5 Installer will not install SQL in XML file

Post by hgraca » Thu Aug 07, 2008 9:27 pm

hi,

for me, this worked:

Code: Select all

      <sql>
         <file charset="utf8" driver="mysql">install.sql</file>
      </sql>
But since you mentioned the default charset, I checked mine and my MySQL db has its default charset as UTF-8, so thats why it works on my case.

And I just learned something more from this chat! tkx :)

polleke
Joomla! Intern
Joomla! Intern
Posts: 75
Joined: Thu Aug 31, 2006 6:32 pm

Re: 1.5 Installer will not install SQL in XML file

Post by polleke » Thu Aug 21, 2008 3:25 pm

Hi
i used the tips i red above and made my own XML for my component.

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
<install type="component" version ="1.5.0">
  <name>JBdateconv</name>
  <creationDate>08/21/2008</creationDate>
  <author>Jan Broos</author>
  <copyright>This component is released under the GNU/GPL License</copyright>
  <authorEmail>jan@broos.org</authorEmail>
  <authorUrl>http://www.broos.org</authorUrl>
  <version>1.2.0</version>
  <description>Convert dates from several different formats</description>
  <files>
    <filename>jbdateconv.php</filename>
  </files>
  	<languages>
		<language tag="nl-NL">nl-NL.com_jbdateconv.ini</language>
		<language tag="en-GB">en-GB.com_jbdateconv.ini</language>
		<language tag="de-DE">de-DE.com_jbdateconv.ini</language>		
	</languages>

  <administration>
    <files>
        <filename>install.jbdateconv.sql</filename>
    </files>
      <install>
        <sql>
            <file driver="mysql">install.jbdateconv.sql</file>
        </sql>
    </install>
  </administration>

</install>
The install file lokks like this.

Code: Select all

 INSERT INTO `#__components` (name, link, option) VALUES ('JBDateConv', 'option=com_jbdateconv', 'com_jbdateconv');
But the 'link' field in jos_components stays empty. The other two fields looks ok.
How comes ? Anyone ?

kind regards Jan

User avatar
hgraca
Joomla! Apprentice
Joomla! Apprentice
Posts: 30
Joined: Fri Jul 11, 2008 10:47 pm

Re: 1.5 Installer will not install SQL in XML file

Post by hgraca » Thu Aug 21, 2008 5:53 pm

try using that sql insert in phpmyadmin and see if it returns an error.

polleke
Joomla! Intern
Joomla! Intern
Posts: 75
Joined: Thu Aug 31, 2006 6:32 pm

Re: 1.5 Installer will not install SQL in XML file

Post by polleke » Thu Aug 21, 2008 7:06 pm

Hi,
i found an error,
so i changed the code into
INSERT INTO `#__components` (`id`, `name`, `link`, `option`) VALUES ('', 'jbdateconv', 'option=com_jbdateconv', 'option=com_jbdateconv');

And place the new code in the sql-installer.

This works in phpmy admin.

BUT NOT IN THE INSTALLER. de field "link" stays empty. the rest of the fields are ok.

Kind regards
Jan

polleke
Joomla! Intern
Joomla! Intern
Posts: 75
Joined: Thu Aug 31, 2006 6:32 pm

Re: 1.5 Installer will not install SQL in XML file

Post by polleke » Thu Aug 21, 2008 7:17 pm

Hi
something strange is happening.
But started debugging.
and restarted the installation. but without the sql (insert into) statement.
The debug says:

Code: Select all

SELECT * 
  FROM jos_components 
  WHERE parent = 0
SELECT folder AS type, element AS name, params 
  FROM jos_plugins 
  WHERE published >= 1 
  AND access <= 2 
  ORDER BY ordering
SELECT template 
  FROM jos_templates_menu 
  WHERE client_id = 1 
  AND menuid = 0
SELECT id, params, enabled 
  FROM jos_components 
  WHERE `option` = 'com_jbdateconv' 
  ORDER BY `parent` ASC
SELECT id 
  FROM jos_components 
  WHERE `option` = 'com_jbdateconv' 
  AND parent = 0
INSERT INTO jos_components 
  VALUES( "", 'JBdateconv', '', 0, 0, '', 'JBdateconv', 'com_jbdateconv', 0, '', 0, '', 1 )
Here the 'LINK'-field is left empty.

So i can conclude that the sql install file did not start !!!!!
What could be wrong?

kind regards
Jan

User avatar
hgraca
Joomla! Apprentice
Joomla! Apprentice
Posts: 30
Joined: Fri Jul 11, 2008 10:47 pm

Re: 1.5 Installer will not install SQL in XML file

Post by hgraca » Thu Aug 21, 2008 7:36 pm

in the xml file try putting this:

<install>
<sql>
<file driver="mysql">install.jbdateconv.sql</file>
</sql>
</install>

outside the <administration> tag.

i always put it outside.

polleke
Joomla! Intern
Joomla! Intern
Posts: 75
Joined: Thu Aug 31, 2006 6:32 pm

Re: 1.5 Installer will not install SQL in XML file

Post by polleke » Thu Aug 21, 2008 7:55 pm

no sorry .
didn't work

my XML file looks like this

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
<install type="component" version ="1.5.0">
  <name>JBdateconv</name>
  <creationDate>08/21/2008</creationDate>
  <author>Jan Broos</author>
  <copyright>This component is released under the GNU/GPL License</copyright>
  <authorEmail>jan@broos.org</authorEmail>
  <authorUrl>http://www.broos.org</authorUrl>
  <version>1.2.0</version>
  <description>Convert dates from several different formats</description>
  <files>
    <filename>jbdateconv.php</filename>
  </files>
<install>
<sql>
<file driver="mysql">install.jbdateconv.sql</file>
</sql>
</install>
  	<languages>
		<language tag="nl-NL">nl-NL.com_jbdateconv.ini</language>
		<language tag="en-GB">en-GB.com_jbdateconv.ini</language>
		<language tag="de-DE">de-DE.com_jbdateconv.ini</language>		
	</languages>

  <administration>
  </administration>

</install>
and install.jbdateconv.sql like this

Code: Select all

UPDATE `#__components` SET `link` = 'option=com_jbdateconv' WHERE `name` = 'JBdateconv';
An update because i think the rest is already in the JOS_COMPONENTS table.

I donn't believe the sql-file is executed at all.

SHOULD the SQL file not be installed before excuted ?

kind regards.

Jan

User avatar
hgraca
Joomla! Apprentice
Joomla! Apprentice
Posts: 30
Joined: Fri Jul 11, 2008 10:47 pm

Re: 1.5 Installer will not install SQL in XML file

Post by hgraca » Thu Aug 21, 2008 8:13 pm

now there is nothing in the admin tag.

this is my xml file:

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<install type="component" version="1.5">

	<name>Herb School Info</name>
	<creationDate>August 2008</creationDate>
	<author>Herberto Graça</author>
	<authorEmail>herberto.graca@gmail.com</authorEmail>
	<authorUrl>herbweb.no-ip.org</authorUrl>
	<copyright>Copyright (C) 2008 Herberto Graça. All rights reserved.</copyright>
	<license>http://www.gnu.org/licenses/gpl-2.0.html GNU/GPL</license>
	<version>1.0.0</version>
	<description>DESCRIPTION</description>

	<files folder="site">
		<folder>js</folder>
		<folder>logos_departs</folder>
		<folder>logos_grupos</folder>
		<folder>logos_profs</folder>
		<folder>models</folder>
		<folder>views</folder>
		<filename>controller.php</filename>
		<filename>herbschoolinfo.php</filename>
		<filename>index.html</filename>
	</files>
	
    <languages folder="site/lang">
        <language tag="pt-PT">pt-PT.com_herbschoolinfo.ini</language>
        <language tag="en-GB">en-GB.com_herbschoolinfo.ini</language>
    </languages>
	
	<install>
		<sql>
			<file charset="utf8" driver="mysql">install.sql</file>
		</sql>
	</install>
	
	<uninstall>
		<sql>
			<file charset="utf8" driver="mysql">uninstall.sql</file>
		</sql>
	</uninstall>
		
	<administration>
		<menu>Herb School Info</menu>
		
		<submenu>
			<menu act="profs">Professores</menu>
			<menu act="orgaos">Orgãos</menu>
			<menu act="turmas">Turmas</menu>
			<menu act="departamentos">Departamentos</menu>
			<menu act="grupos">Grupos disciplinares</menu>
			<menu act="cargos">Cargos</menu>
			<menu act="dir_turma">Directores de turma</menu>
		</submenu>
		
		<files folder="admin">
			<folder>imgs</folder>
			<folder>js</folder>
			<folder>models</folder>
			<folder>tables</folder>
			<folder>views</folder>
			<filename>admin.herbschoolinfo.php</filename>
			<filename>controller.php</filename>
			<filename>index.html</filename>
			<filename>install.sql</filename>
			<filename>uninstall.sql</filename>
		</files>		
	
	    <languages folder="admin/lang">
	        <language tag="pt-PT">pt-PT.com_herbschoolinfo.ini</language>
	        <language tag="en-GB">en-GB.com_herbschoolinfo.ini</language>
	    </languages>
	</administration>
	
	<params>
		<param name="pgtitle" default="a title" label="Page title" description="The page title" type="text" width="50" />
		<param name="show_downloads" default="1" label="Show download count? " description="Show or hide the download count" type="list" width="50">
			<option value="0">No</option>
			<option value="1">Yes</option>
		</param>
	</params>

	<installfile />
	<uninstallfile />
	<media />
</install>
and this is my package layout:
Image

what I want you to notice is that I have the sql files referenced inside the admin tag, but the install/sql is outside the admin tag. Also notice that I'm referencing the folder where the sql file is <files folder="admin">.

try making something similar.

hope it helps...

polleke
Joomla! Intern
Joomla! Intern
Posts: 75
Joined: Thu Aug 31, 2006 6:32 pm

Re: 1.5 Installer will not install SQL in XML file

Post by polleke » Thu Aug 21, 2008 8:31 pm

Well..
There is the problem. As soon as you have an back-end part in your component it will install corrctly.
But i donn't have an backend part so the administrationpart is empty.
And that's why i am looking for the solution :-)

I'll have look at your solution in the morning.

Jan

polleke
Joomla! Intern
Joomla! Intern
Posts: 75
Joined: Thu Aug 31, 2006 6:32 pm

Re: 1.5 Installer will not install SQL in XML file

Post by polleke » Fri Aug 22, 2008 7:59 am

hi,

I made like you said. But... sorry it doesnot work.

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
<install type="component" version ="1.5.0">
  <name>JBdateconv</name>
  <creationDate>08/21/2008</creationDate>
  <author>Jan Broos</author>
  <copyright>This component is released under the GNU/GPL License</copyright>
  <authorEmail>jan@broos.org</authorEmail>
  <authorUrl>http://www.broos.org</authorUrl>
  <version>1.2.0</version>
  <description>Convert dates from several different formats</description>
  <files>
    <filename>jbdateconv.php</filename>
  </files>
  <install>
    <sql>
  <file driver="mysql">install.jbdateconv.sql</file>
    </sql>
  </install>
  	<languages>
		<language tag="nl-NL">nl-NL.com_jbdateconv.ini</language>
		<language tag="en-GB">en-GB.com_jbdateconv.ini</language>
		<language tag="de-DE">de-DE.com_jbdateconv.ini</language>		
	</languages>
  <administration>
    <files>
        <filename>install.jbdateconv.sql</filename>
    </files>
  </administration>
</install>
The file is installed in the directory : ./administrator/components/com_jbdateconv/
So that is correct.
But it is not executed.

regards Jan

User avatar
hgraca
Joomla! Apprentice
Joomla! Apprentice
Posts: 30
Joined: Fri Jul 11, 2008 10:47 pm

Re: 1.5 Installer will not install SQL in XML file

Post by hgraca » Fri Aug 22, 2008 1:09 pm

than, I have no idea...:(

maybe it has something to do with the sql file encoding.

also, in my sql files I never work with joomla core tables, only with the ones I make myself, why do you need to do that?

polleke
Joomla! Intern
Joomla! Intern
Posts: 75
Joined: Thu Aug 31, 2006 6:32 pm

Re: 1.5 Installer will not install SQL in XML file

Post by polleke » Fri Aug 22, 2008 2:03 pm

I think i found a solution.
Here is the xml

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
<install type="component" version ="1.5.0">
	<name>JBdateconv</name>
	<creationDate>08/21/2008</creationDate>
	<author>Jan Broos</author>
	<copyright>This component is released under the GNU/GPL License</copyright>
	<authorEmail>jan@broos.org</authorEmail>
	<authorUrl>http://www.broos.org</authorUrl>
	<version>1.2.0</version>
	<description>Convert dates from several different formats</description>
	<files>
		<filename component="com_jbdateconv">jbdateconv.php</filename>
	</files>
  	<languages>
		<language tag="nl-NL">nl-NL.com_jbdateconv.ini</language>
		<language tag="en-GB">en-GB.com_jbdateconv.ini</language>
		<language tag="de-DE">de-DE.com_jbdateconv.ini</language>		
	</languages>
	<administration>
		<menu link="option=com_jbdateconv">JBDateconv</menu>	
	<files folder="admin">
		<filename>jbdateconv.php</filename>
	</files>		
	</administration>
</install>
And here the second php file within the admin-tag

Code: Select all

<?php
defined( '_JEXEC' ) or die( 'Restricted access' );
echo "<b>JBDateconv : 'No adminstration part needed, for this component'</b>"
?>
You know it is an component for frontend use only. But using the menu-tag in the admin section you will get a menuitem in the backend (but is works for the frontend). But i donnot have a backend part. But everthing bether than an 404-error.

So far thanks,
regards Jan


Locked

Return to “Joombie Coding Q/A”