XML Manifest Joomla 1.5 is incorrect

Post Reply
luigi.massa
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Aug 07, 2007 12:07 pm

XML Manifest Joomla 1.5 is incorrect

Post by luigi.massa » Mon Jun 23, 2008 10:31 am

Hi,
I've created a xml fiole with eclipse.
When eclipse check the format of the xml file, eclipse get an error.
The file created is:

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE install SYSTEM "home/lmassa/Desktop/component-install.dtd" >
<install type="component" version="">
  <name>name</name>
  <creationDate>creationDate</creationDate>
  <author>author</author>
  <authorEmail>authorEmail</authorEmail>
  <authorUrl>authorUrl</authorUrl>
  <copyright>copyright</copyright>
  <license>license</license>
  <version>version</version>
  <description>description</description>
  <installfile>installfile</installfile>
  <uninstallfile>uninstallfile</uninstallfile>
  <install type="component" version="">
    <name>name</name>
    <creationDate>creationDate</creationDate>
    <author>author</author>
    <authorEmail>authorEmail</authorEmail>
    <authorUrl>authorUrl</authorUrl>
    <copyright>copyright</copyright>
    <license>license</license>
    <version>version</version>
    <description>description</description>
    <installfile>installfile</installfile>
    <uninstallfile>uninstallfile</uninstallfile>
    <uninstall>
      <sql>
        <file charset="utf8" driver="nmtoken">file</file>
      </sql>
    </uninstall>
    <files folder="">
      <filename>filename</filename>
    </files>
    <languages folder="">
      <language tag="">language</language>
    </languages>
    <media destination="" folder="">
      <filename>filename</filename>
    </media>
    <administration>
      <menu act="nmtoken" controller="nmtoken" img="" layout="nmtoken" link="" sub="nmtoken" task="nmtoken" view="nmtoken">menu</menu>
    </administration>
    <params>
      <param addParameterDir="" class="nmtoken" client="nmtoken" cols="nmtoken" default="" description="" directory="" exclude="" filter="" hide_default="nmtoken" hide_none="nmtoken" id="nmtoken" label="" menu_type="nmtoken" name="nmtoken" rows="nmtoken" scope="nmtoken" section="nmtoken" size="nmtoken" state="nmtoken" stripext="" type="nmtoken">
        <option value="">option</option>
      </param>
    </params>
  </install>
  <uninstall>
    <sql>
      <file charset="utf8" driver="nmtoken">file</file>
    </sql>
  </uninstall>
  <files folder="">
    <filename>filename</filename>
  </files>
  <languages folder="">
    <language tag="">language</language>
  </languages>
  <media destination="" folder="">
    <filename>filename</filename>
  </media>
  <administration>
    <menu act="nmtoken" controller="nmtoken" img="" layout="nmtoken" link="" sub="nmtoken" task="nmtoken" view="nmtoken">menu</menu>
  </administration>
  <params>
    <param addParameterDir="" class="nmtoken" client="nmtoken" cols="nmtoken" default="" description="" directory="" exclude="" filter="" hide_default="nmtoken" hide_none="nmtoken" id="nmtoken" label="" menu_type="nmtoken" name="nmtoken" rows="nmtoken" scope="nmtoken" section="nmtoken" size="nmtoken" state="nmtoken" stripext="" type="nmtoken">
      <option value="">option</option>
    </param>
  </params>
</install>


In this file there are 2 INTSTALL NODES.

User avatar
dam-man
Joomla! Exemplar
Joomla! Exemplar
Posts: 7962
Joined: Fri Sep 09, 2005 2:13 pm
Location: The Netherlands
Contact:

Re: XML Manifest Joomla 1.5 is incorrect

Post by dam-man » Mon Jun 23, 2008 3:34 pm

Topic moved to Quality & Testing
Robert Dam - Joomla Forum Moderator
Dutch Boards | Joomla Coding Boards | English Support Boards

User avatar
ircmaxell
Joomla! Ace
Joomla! Ace
Posts: 1926
Joined: Thu Nov 10, 2005 3:10 am
Location: New Jersey, USA
Contact:

Re: XML Manifest Joomla 1.5 is incorrect

Post by ircmaxell » Mon Jun 23, 2008 6:27 pm

Moved to Joombie Dev Lab, as this is not a Joomla! bug...
Anthony Ferrara - Core Team - Development Coordinator - Bug Squad - JSST

http://moovum.com/ - The Bird is in the air! Get Mollom Anti-Spam on your Joomla! website with Moovur...
http://www.joomlaperformance.com For All Your Joomla Performance Needs

luigi.massa
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Aug 07, 2007 12:07 pm

Re: XML Manifest Joomla 1.5 is incorrect

Post by luigi.massa » Mon Jun 23, 2008 11:25 pm

ircmaxell wrote:Moved to Joombie Dev Lab, as this is not a Joomla! bug...

Try to check XML manifest with a DTD validator.
:geek:


Post Reply

Return to “Joombie Developer Lab”