"There was an error uploading this file to the server."

General questions regarding the use of languages in Joomla! 1.5.

Moderator: General Support Moderators

Locked
hanniball
Joomla! Intern
Joomla! Intern
Posts: 64
Joined: Fri Oct 13, 2006 1:29 am

"There was an error uploading this file to the server."

Post by hanniball » Wed Apr 30, 2008 3:44 am

I upgrade from 1.51 to 1.53 with Joomla_1.5.1_to_1.5.3-Stable-Patch_Package.zip.
Failed to install language package Joomla-1.5.3.zh-CN.installable.site-1.0.zip with an error message “There was an error uploading this file to the server.”
What's wrong?
Thanks advance!
"It was on my fifth birthday that Papa put his hand on my shoulder and said, 'Remember, my son, if you ever need a helping hand, you'll find one at the end of your arm.'"

--Sam Levenson

caymahallesi
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Wed Jul 23, 2008 12:54 am

Re: "There was an error uploading this file to the server."

Post by caymahallesi » Mon Dec 22, 2008 12:55 pm

did you fix your issue, or what did you learn from you experience?
I tried giving chmod 777 to files and folders but thats not helping.
thanks

User avatar
jessiered
Joomla! Intern
Joomla! Intern
Posts: 66
Joined: Sat Jan 10, 2009 4:50 am

Re: "There was an error uploading this file to the server."

Post by jessiered » Wed Jan 21, 2009 1:33 am

Hi I also have the same problem when I tried to Upload file and install it said
"There was an error uploading this file to the server."

When I tried to upload Joomla_1.5.8-Stable-Full_Package-French2.

Whats wrong with this?

Thanks in advance!
D * Jessiered * Smile
:: Never Finish a Negative Statement ::

User avatar
dizzi
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3136
Joined: Fri Dec 21, 2007 9:36 pm
Location: Yorkshire, UK

Re: "There was an error uploading this file to the server."

Post by dizzi » Fri Feb 20, 2009 6:27 pm

Hi the Joomla! zip archive is over 5M. It is possible that your server's file upload size limit has been set to a value lower than this. Providing you have the necessary permissions, this can be addressed in two ways.

1. In the php.ini file fine the following line "upload_max_filesize = xM" and replace "x" with a value of 10 (or more) for example, so it looks like this:

Code: Select all

upload_max_filesize = 10M
2. In your .htaccess add the following:

Code: Select all

php_value max_upload_size 10M
Regards
Freedom of expression ... some may try to suppress it but they can never take it away ...
There is no problem a good miracle can't fix.

ravi_mathews
Joomla! Intern
Joomla! Intern
Posts: 63
Joined: Fri Jan 22, 2010 7:01 am
Location: Hyderabad
Contact:

Re: "There was an error uploading this file to the server."

Post by ravi_mathews » Thu Nov 18, 2010 8:28 am

dizzi wrote:Hi the Joomla! zip archive is over 5M. It is possible that your server's file upload size limit has been set to a value lower than this. Providing you have the necessary permissions, this can be addressed in two ways.

1. In the php.ini file fine the following line "upload_max_filesize = xM" and replace "x" with a value of 10 (or more) for example, so it looks like this:

Code: Select all

upload_max_filesize = 10M
2. In your .htaccess add the following:

Code: Select all

php_value max_upload_size 10M
Regards

Hello, I applied both the solutions you suggested, but I am still facing the same problem, any idea what can be the reason.

Thanks.
-------------------------------------------------
Coding is World
http://www.filmitadka.in
http://www.motobuzz.in

justincase
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Sep 20, 2011 3:02 pm

Re: "There was an error uploading this file to the server."

Post by justincase » Tue Sep 20, 2011 6:11 pm

GRRRRRR!!!!!!! This is so crazy frustrating. I am not a NB and have been on the phone with Godaddy support still no resolution. CANNOT CHANGE MAX FILE UPLOAD SIZE IN 1.5 OR 1.7
DEFAULT 2M

Here are my files all of the fixes I find in this forum are for imaginary situations, such
another easy way in .htaccess.

RewriteEngine On
php_value post_max_size 1000M
php_value upload_max_filesize 1000M
php_value max_execution_time 6000000
- this does not exist... And yest I have tried adding with no result.

ANOTHER....
; Maximum allowed size for uploaded files.
upload_max_filesize = 2M

to

; Maximum allowed size for uploaded files.
upload_max_filesize = how much u wantM
.... THERE ARE NO php.ini or php5.ini files in joomla 1.5 install and yes I have tried creating with still no luck.

PLEASE SOMEONE HELP!!!! (WITHOUT A HALF *** RESPONSE PLZ!!)

System Information

Database Version 5.0.91-log
Database Collation utf8_general_ci
PHP Version 5.3.6
Web Server Apache
WebServer to PHP Interface cgi-fcgi
Joomla! Version Joomla! 1.7.0 Stable [ Ember ] 19-Jul-2011 14:00 GMT
Joomla! Platform Version Joomla Platform 11.1 Stable+Modified [ Ember ] 01-Jun-2011 06:00

Relevant PHP Settings
Setting Value

Safe Mode Off
Open basedir None
Display Errors On
Short Open Tags On
File Uploads On
Magic Quotes On
Register Globals Off
Output Buffering Off
Session Save Path None
Session Auto Start 0
XML Enabled Yes
Zlib Enabled Yes
Disabled Functions None
Mbstring Enabled Yes
Iconv Available Yes

Configuration File
Setting Value

offline 0
offline_message
sitename MYSITE.COM
editor tinymce
list_limit 20
access 1
dbtype mysql
host xxxxxx
user xxxxxx
password xxxxxx
db DATABASENAME
dbprefix jos_
secret
gzip 0
error_reporting -1
helpurl http://help.joomla.org/proxy/index.php? ... 16:{keyref}
ftp_host
ftp_port
ftp_user xxxxxx
ftp_pass xxxxxx
ftp_root
ftp_enable 0
tmp_path /tmp
log_path /var/logs
live_site http://MYSITE.com/
force_ssl 0
offset UTC
offset_user UTC
lifetime 15
session_handler database
mailer mail
mailfrom MYEMAIL@MYSITE.com
fromname MYSITE.com
sendmail /usr/sbin/sendmail
smtpauth 0
smtpuser xxxxxx
smtppass xxxxxx
smtphost localhost
caching 0
cachetime 15
cache_handler file
debug 0
debug_lang 0
MetaDesc
MetaKeys
MetaAuthor 1
sef 1
sef_rewrite 1
sef_suffix 0
unicodeslugs 0
feed_limit 10
feed_email author
smtpsecure none
smtpport 25
MetaRights
sitename_pagetitles 0
cookie_domain
cookie_path
language en-GB



Core
PHP Version 5.3.6

Directive Local Value Master Value
allow_call_time_pass_reference On On
allow_url_fopen On On
allow_url_include Off Off
always_populate_raw_post_data Off Off
arg_separator.input & &
arg_separator.output & &
asp_tags Off Off
auto_append_file no value no value
auto_globals_jit On On
auto_prepend_file no value no value
browscap no value no value
default_charset no value no value
default_mimetype text/html text/html
define_syslog_variables Off Off
disable_classes no value no value
disable_functions no value no value
display_errors On On
display_startup_errors Off Off
doc_root no value no value
docref_ext no value no value
docref_root no value no value
enable_dl On On
error_append_string no value no value
error_log no value no value
error_prepend_string no value no value
error_reporting 22519 no value
exit_on_timeout Off Off
expose_php On On
extension_dir /usr/local/php5_3/lib/php/extensions/no-debug-non-zts-20090626 /usr/local/php5_3/lib/php/extensions/no-debug-non-zts-20090626
file_uploads On On
highlight.bg #FFFFFF #FFFFFF
highlight.comment #FF8000 #FF8000
highlight.default #0000BB #0000BB
highlight.html #000000 #000000
highlight.keyword #007700 #007700
highlight.string #DD0000 #DD0000
html_errors On On
ignore_repeated_errors Off Off
ignore_repeated_source Off Off
ignore_user_abort Off Off
implicit_flush Off Off
include_path .:/usr/local/php5_3/lib/php .:/usr/local/php5_3/lib/php
log_errors Off Off
log_errors_max_len 1024 1024
magic_quotes_gpc On On
magic_quotes_runtime Off Off
magic_quotes_sybase Off Off
mail.add_x_header Off Off
mail.force_extra_parameters no value no value
mail.log no value no value
max_execution_time 30 30
max_file_uploads 20 20
max_input_nesting_level 64 64
max_input_time -1 -1
memory_limit 128M 128M
open_basedir no value no value
output_buffering 0 0
output_handler no value no value
post_max_size 8M 8M
precision 14 14
realpath_cache_size 16K 16K
realpath_cache_ttl 120 120
register_argc_argv On On
register_globals Off Off
register_long_arrays On On
report_memleaks On On
report_zend_debug On On
request_order no value no value
safe_mode Off Off
safe_mode_exec_dir /usr/local/php/bin /usr/local/php/bin
safe_mode_gid Off Off
safe_mode_include_dir no value no value
sendmail_from no value no value
sendmail_path /usr/sbin/sendmail -t -i /usr/sbin/sendmail -t -i
serialize_precision 17 17
short_open_tag On On
SMTP localhost localhost
smtp_port 25 25
sql.safe_mode Off Off
track_errors Off Off
unserialize_callback_func no value no value
upload_max_filesize 2M 2M <-------------------------CANNOT FIND THIS ON MY SERVER
upload_tmp_dir no value no value
user_dir no value no value
user_ini.cache_ttl 300 300
user_ini.filename .user.ini .user.ini
variables_order EGPCS EGPCS
xmlrpc_error_number 0 0
xmlrpc_errors Off Off
y2k_compliance On On
zend.enable_gc On On


I am terribly sorry to seem sharp tongued, I am very VERY frustrated! to be more specific any large upload via the administration upload receives the following error.

There was an error uploading this file to the server.

Unable to find install package

This appears to only be on the larger uploads PLEASE HELP!!!

User avatar
headghogg
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Feb 23, 2009 5:44 pm

Re: "There was an error uploading this file to the server."

Post by headghogg » Sat Oct 29, 2011 11:38 pm

create a file in your public_html directory or whichever is the root dir for Joomla called php5.ini

enter the following

max_execution_time = 60
upload_max_filesize = 10M
post_max_size = 10M
memory_limit = 24M
display_errors = 0
register_globals = 0

save and then try
Regards

Mark,
GoHost4U
http://www.gohost4webdesign

Ibrakadabra
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Nov 16, 2011 2:28 pm

Re: "There was an error uploading this file to the server."

Post by Ibrakadabra » Wed Nov 16, 2011 2:45 pm

I have the same error, I'm on Godaddy also...

So, "justincase" if u solve your problem, please give me some instructions.

Can anyone help me with this? Here are my php.ini and php5.ini files

php.ini:
register_globals = off
allow_url_fopen = off

expose_php = Off
max_input_time = 60
variables_order = "EGPCS"
extension_dir = ./
upload_tmp_dir = /tmp
precision = 12
SMTP = relay-hosting.secureserver.net
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="
memory_limit = 50M
post_max_size = 10M
file_uploads = On
upload_max_filesize = 32M

[Zend]
zend_extension=/usr/local/zo/ZendExtensionManager.so
zend_extension=/usr/local/zo/4_3/ZendOptimizer.so
rg_emulation=off

php5.ini:
max_execution_time = 60
upload_max_filesize = 10M
post_max_size = 10M
memory_limit = 24M
display_errors = 0
register_globals = 0

php5.ini is like "headghogg" suggest.

Should I clear cache before trying again, or? Please help...

User avatar
headghogg
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Feb 23, 2009 5:44 pm

Re: "There was an error uploading this file to the server."

Post by headghogg » Wed Nov 16, 2011 5:12 pm

Hi

When you get this message its normally a problem with file sizes or the time taken to unzip and execute the install. I had this recently with an extension which was 4mb and not matter what I did to the php.ini or using .htaccess and even adding code to the index file nothing worked. I decided to upload the files manually.

So use an ftp program like filefilla and create a sub directory in your tmp folder called "files"

Unzip the update you are trying to install to a local folder and then ftp the contents of this folder to your "files" folder.

Once done go to Extensions > Install/Uninstall and then edit the end of the url in the Install from directory adding "/files/" to the end like this:

/home/sites/yoursitename.com/public_html/tmp/files/

Now click install and it should be OK
Regards

Mark,
GoHost4U
http://www.gohost4webdesign

Ibrakadabra
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Nov 16, 2011 2:28 pm

Re: "There was an error uploading this file to the server."

Post by Ibrakadabra » Wed Nov 16, 2011 6:30 pm

How should my path look like?

Because it's not about my root website, it's in folder.

What about the end, after /files ???

Thank you

Edit:
I installed some templates, but when I choose my new template as a default I get empty page, with nothing on it... :(
What's the problem?! :/

User avatar
headghogg
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Feb 23, 2009 5:44 pm

Re: "There was an error uploading this file to the server."

Post by headghogg » Wed Nov 16, 2011 11:48 pm

Ibrakadabra wrote:How should my path look like?

Because it's not about my root website, it's in folder.

What about the end, after /files ???

Thank you

Edit:
I installed some templates, but when I choose my new template as a default I get empty page, with nothing on it... :(
What's the problem?! :/
Is your problem that you cannot install your template or an extension...email me details... mark@gohost4u.com
Regards

Mark,
GoHost4U
http://www.gohost4webdesign

toomy
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Nov 29, 2011 5:49 pm

Re: "There was an error uploading this file to the server."

Post by toomy » Tue Nov 29, 2011 9:06 pm

headghogg wrote:create a file in your public_html directory or whichever is the root dir for Joomla called php5.ini

enter the following

max_execution_time = 60
upload_max_filesize = 10M
post_max_size = 10M
memory_limit = 24M
display_errors = 0
register_globals = 0

save and then try
hi
I agreed with you Thank you

tuto
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Nov 29, 2011 6:03 pm

Re: "There was an error uploading this file to the server."

Post by tuto » Tue Nov 29, 2011 9:27 pm

Hello this problem has been addressed before, but also have the same problem back
Thank you

Ibrakadabra
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Nov 16, 2011 2:28 pm

Re: "There was an error uploading this file to the server."

Post by Ibrakadabra » Tue Nov 29, 2011 10:02 pm

I cannot install anything via upload button. When i choose some .zip file from my pc:/

With Extensions > Install/Uninstall, it works fine...

But, how can i fix this?! Is this possible? Is it way easier to install with choosing a zip file directly from pc.

Headghogg?

chromahoen
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Jan 24, 2012 6:38 pm

Re: "There was an error uploading this file to the server."

Post by chromahoen » Tue Jan 24, 2012 6:57 pm

I recently got a new server and I was having issues with this myself. My issue, as well as most of you, I believe, is that the PHP5 handler that apache is attempting to use is DSO, which allows the user "nobody" to run scripts. Ask your host or go into WHM and enable the SuExec and change the default PHP5 handler to SuPHP.

I had a lot of problems with my Joomla (and magento) installations until I did this. Good luck!

~chromahoen

kiwifisher
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Wed May 09, 2012 10:50 pm
Location: New Zealand
Contact:

Re: "There was an error uploading this file to the server."

Post by kiwifisher » Tue Jul 17, 2012 10:12 pm

headghogg wrote:Hi

When you get this message its normally a problem with file sizes or the time taken to unzip and execute the install. I had this recently with an extension which was 4mb and not matter what I did to the php.ini or using .htaccess and even adding code to the index file nothing worked. I decided to upload the files manually.

So use an ftp program like filefilla and create a sub directory in your tmp folder called "files"

Unzip the update you are trying to install to a local folder and then ftp the contents of this folder to your "files" folder.

Once done go to Extensions > Install/Uninstall and then edit the end of the url in the Install from directory adding "/files/" to the end like this:

/home/sites/yoursitename.com/public_html/tmp/files/

Now click install and it should be OK
YES! YES! YES! thanks headghogg!!!
I've been battling with this for days and spent hours trying to find files, change files etc to no avail then your suggestion....success in 2 mins! THANKS SO MUCH!
David
www.insites.co.nz
"One day your life will flash before your eyes - Make sure it's worth watching!"

tedvlee
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Apr 29, 2010 8:04 am
Contact:

Re: "There was an error uploading this file to the server."

Post by tedvlee » Wed Feb 27, 2013 3:30 pm

I just have to smile.
Uploading to a TMP directory, surelly, is a sollution (of a recent problem) and the easiest.
But with a need to installing another component - you will have same trouble.

The "cause" (причину) of that problem no one of you did not say. And this is problem not in "no access"


Locked

Return to “Language - Joomla! 1.5”