Japanese Install Error

General questions regarding the use of languages in Joomla! 1.5.

Moderator: General Support Moderators

Locked
nojiri
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Dec 05, 2008 8:16 am

Japanese Install Error

Post by nojiri » Fri Dec 12, 2008 3:59 am

Hi,

I'm trying to install Japanese plug-ins for both my site and administration, but when trying to upload, I get this error message:

JInstaller::install: File '/home/mysite/public_html/tmp/install_4941de31e8116/ja-JP_Joomla_1.5.8_site/ja-JP.com_menus.ini' does not exist.

Joomla version is 1.5.8. Language pack is ja-JP_Joomla_1.5.8_site.zip from joomlacode.org

What do I need to do to fix this?

Thanks!
nojiri

 
User avatar
ghosty
Joomla! Ace
Joomla! Ace
Posts: 1160
Joined: Fri Aug 19, 2005 7:42 am

Re: Japanese Install Error

Post by ghosty » Fri Dec 12, 2008 1:10 pm

Hi Nojiri,

I just checked the files and indeed the ja-JP.com_menus.ini is missing. I will contact the Translation teams and have them to fix it.

In the mean time what you could do is, Upload the files manualy by: unzip them to your local device and ftp them to your Joomla! installation /JoomlaRoot/language/

or take the one included in the main Joomla! Dirstrib en-GB.com_menus.ini rename and perhaps translate it to your needs.. and include it in the pack.

Cheers

Pete
Pete Coutts / ghosty · · GMT +1
---------------------------------

nojiri
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Dec 05, 2008 8:16 am

Re: Japanese Install Error

Post by nojiri » Fri Dec 12, 2008 4:34 pm

Hi Pete,

Thanks for checking. I'm still very new at this and not sure where to find the JoomlaRoot/language file. I unzipped the Japanese site files to a folder on my desktop, then ftped them to the: /public_html/administrator/language folder where I successfully uploaded Japanese administrator files yesterday. There's also an en-GB folder there. Was that the language folder I was supposed to ftp them too?

I must still be missing something because I still can't get Japanese to appear on the site. Any help is greatly appreciated!

cheers,
nojiri

User avatar
Pierre_NC
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Fri Jan 09, 2009 2:05 am
Location: Nouméa, New Caledonia
Contact:

Re: Japanese Install Error

Post by Pierre_NC » Fri Jan 09, 2009 2:30 am

Hello, 皆さんこにちは

I encountered the same pb, but maybe there is a trick to solve this: on joomlacode at http://joomlacode.org/gf/project/jtrans ... kage_id=33, you have two japanese language files for release 1.5.8, one for site, and one for admin. Indeed, menu_com file is missing in site language pack, but one is present in admin language pack:

# $Id: ja-JP.com_menus.ini 441 2008-12-04 10:13:22Z Nori $
# Joomla! Project
# Copyright (C) 2005 - 2007 Open Source Matters. All rights reserved.
# License http://www.gnu.org/licenses/gpl-2.0.html GNU/GPL, see LICENSE.php
# Note : All ini files need to be saved as UTF-8 - No BOM

A DESCRIPTION FOR THE MENU=メニューについての説明
A PROPER TITLE FOR THE MENU=メニューのタイトルは適切なものを
ADVANCED PARAMETERS=拡張パラメータ
ALIAS=エリアス
ALIGNMENT OF THE IMAGE=イメージの整列
ALL CATEGORIES=全てのカテゴリ

<...>

NUMBER 30=30
NUMBER 50=50
NUMBER 100=100
SHOW/HIDE THE CATEGORY IMAGE=カテゴリイメージを表示しますか?
SHOW/HIDE THE TABLE HEADINGS=表見出しを表示しますか?

This file seems complete. So, maybe the pb will be solved if we copy it from admin pack to site pack? I didn't have time yet to try it. But it is worth trying!

Pierre

それでは、またね。。。
ピエール

jgates00
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Tue Dec 23, 2008 11:04 pm

Re: Japanese Install Error

Post by jgates00 » Fri Jan 09, 2009 2:38 am

nojiri wrote:Hi,

I'm trying to install Japanese plug-ins for both my site and administration, but when trying to upload, I get this error message:

JInstaller::install: File '/home/mysite/public_html/tmp/install_4941de31e8116/ja-JP_Joomla_1.5.8_site/ja-JP.com_menus.ini' does not exist.

Joomla version is 1.5.8. Language pack is ja-JP_Joomla_1.5.8_site.zip from joomlacode.org

What do I need to do to fix this?

Thanks!
nojiri
I had to design a Japanese site lastnight. All i did is went to Joomla's website on the Japanese server and downloaded 1.5-jp. This was much easier and included Japanese headers.

User avatar
Pierre_NC
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Fri Jan 09, 2009 2:05 am
Location: Nouméa, New Caledonia
Contact:

Re: Japanese Install Error

Post by Pierre_NC » Fri Jan 09, 2009 2:58 am

Well, It seems my trick is not working :-[ ... Another possibility could be to uncompress these zip files on your site, and try 'install form directory'. The best of course would be to contact translaters team... Sorry for not beeing able to test it until next week...

Pierre
ピエール

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 19014
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Japanese Install Error

Post by infograf768 » Fri Jan 09, 2009 8:25 am

Site language packs do NOT include any en-GB.com_menu.ini file. (or for any other language)
That file is only used by admin.

The mistake is in the site install.xml of the package.
url of pack: http://joomlacode.org/gf/project/jtrans ... kage_id=33

unzip locally

take off the line
<filename>ja-JP.com_menus.ini</filename> from the install.xml

save
re-zip and install
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
Pierre_NC
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Fri Jan 09, 2009 2:05 am
Location: Nouméa, New Caledonia
Contact:

Re: Japanese Install Error

Post by Pierre_NC » Fri Jan 09, 2009 9:29 am

Thanks a lot! I'll try it ASAP

Regards
Pierre

 

Locked

Return to “Language - Joomla! 1.5”