Home link always redirect to default language

General questions regarding the use of languages in Joomla! 1.5.

Moderator: General Support Moderators

Locked
tubia87
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun May 15, 2011 1:17 pm

Home link always redirect to default language

Post by tubia87 » Sun May 15, 2011 1:48 pm

Hi all,
I installed joom!fish and sh404sef. I have a 2 language site: IT and EN. All works just fine except that the "Home" link redirect me to the default language home. My default language is IT. If I am in a EN page the "Home" link doesn't redirect me to the EN Home but to the IT Home. I tried to change the URL in the Joom!fish translation of the "Home" menu but it's in grey (I cannot modify it). Any hint to resolve this issue?

Thank you all in advance :)

User avatar
lopoBL
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 235
Joined: Mon Jun 21, 2010 12:28 pm
Location: Banja Luka, Bosnia
Contact:

Re: Home link always redirect to default language

Post by lopoBL » Sun May 15, 2011 2:45 pm

Hi,

maybe you selected External Link for you Home menu item and there entered link to your site? If this is case, change menu type to whatever should be. I guess it should be Front Page Blog Layout.

Also check custom redirects in sh404SEF.

I hope this helps.

Best,
Boris

tubia87
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun May 15, 2011 1:17 pm

Re: Home link always redirect to default language

Post by tubia87 » Sun May 15, 2011 3:12 pm

Hi Boris,
thank you for the fast reply :)
I checked what you suggested but it's all correct (the Home menu item is Frontpage blog layout). I Cheched also sh404sef but no custom redirects setted. I'll add some info:
when I see the redirect of sh404sef for the EN Home I see that the original URL is:

Code: Select all

index.php?option=com_content&Itemid=1&lang=en&view=frontpage 
In joom!fish, however, in the translation page of the Home menu item I see in the end of the page:

Code: Select all

Tag: Link
Original:
index.php?option=com_content&view=frontpage
Translation:
index.php?option=com_content&view=frontpage 
That's the problem! That also the translation redirect to the default Home, not the translated one, wich is:

Code: Select all

index.php?option=com_content&Itemid=1&lang=en&view=frontpage 
The problem is that joom!fish cannot permit to edit that translation parameter..

User avatar
lopoBL
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 235
Joined: Mon Jun 21, 2010 12:28 pm
Location: Banja Luka, Bosnia
Contact:

Re: Home link always redirect to default language

Post by lopoBL » Sun May 15, 2011 3:32 pm

Hi,

I don't think this is JoomFish problem but you can test to be sure. Disable sh404SEF for few second and test home button. If it is working fine then it is sh404SEF issue.

Try next also: Go in sh404SEF URL Manager and search for frontpage, I guess you should get SEF links that are related to Home page. Delete those URL and browse the site and test.

If you didn't create much changes in sh404SEF (like custom URL, meta information and etc) maybe you could purge all sh404SEF cache.

Sorry I don't know how to help you more (:

Best,
Boris

tubia87
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun May 15, 2011 1:17 pm

Re: Home link always redirect to default language

Post by tubia87 » Sun May 15, 2011 7:26 pm

Thank you Boris!
I made what you suggested: deleted the SEF URL for:

Code: Select all

index.php?option=com_content&Itemid=1&lang=en&view=frontpage 
i. e. the "en/" SEF URL (in my case). It has 3 duplicates.
After deleted that all works just fine :)
Probably was a cache problem I think. I'll report in case of other disfunctions.

Greetings and thank you for your kindness Boris :)

User avatar
lopoBL
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 235
Joined: Mon Jun 21, 2010 12:28 pm
Location: Banja Luka, Bosnia
Contact:

Re: Home link always redirect to default language

Post by lopoBL » Sun May 15, 2011 7:32 pm

No problem :D

I am glad that I can help

User avatar
lopoBL
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 235
Joined: Mon Jun 21, 2010 12:28 pm
Location: Banja Luka, Bosnia
Contact:

Re: Home link always redirect to default language

Post by lopoBL » Wed Jun 01, 2011 7:12 pm

Hi,

by this
thomas345 wrote:The default logic of VariationRoot.aspx redirects user on clicking Home link to the page according to language setting in browser.
I can tell that your site is not Joomla, so I can't help you. Sorry :)

Best,
Boris

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18881
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Home link always redirect to default language

Post by infograf768 » Thu Jun 02, 2011 6:29 am

Indeed, and this user thomas345 is a fake poster, nothing concerning J. Just b..t.

His account is now terminated.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

lilian5049
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Sun Apr 03, 2011 6:00 pm

Re: Home link always redirect to default language

Post by lilian5049 » Sat Sep 03, 2011 6:03 pm

lopoBL wrote:Hi,

I don't think this is JoomFish problem but you can test to be sure. Disable sh404SEF for few second and test home button. If it is working fine then it is sh404SEF issue.

Try next also: Go in sh404SEF URL Manager and search for frontpage, I guess you should get SEF links that are related to Home page. Delete those URL and browse the site and test.

If you didn't create much changes in sh404SEF (like custom URL, meta information and etc) maybe you could purge all sh404SEF cache.

Sorry I don't know how to help you more (:

Best,
Boris
Hi there,
i have the same problem and when i turn off the sh404SEF everything works fine. The problem is that there's nothing in the sh URL manager section so there's nothing to delete. Before i had some other component of sh404SEF and there was also an option to purge but the new one which my webmaster installed doesn't have this function. Unfortunatelly now he says he doesn't have time to finish what he started.

The only sections with links in them are just URL manager and Manager 404 requests.

Do you have an idea what could it be?

Thanks a lot in advance

User avatar
lopoBL
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 235
Joined: Mon Jun 21, 2010 12:28 pm
Location: Banja Luka, Bosnia
Contact:

Re: Home link always redirect to default language

Post by lopoBL » Sat Sep 03, 2011 6:14 pm

Hi,

If there is no any records in sh404SEF URL manager probably SEF URL caching is disabled.

Check filed "Activate URL cache" in configuration under Advanced tab.
lilian5049 wrote:
lopoBL wrote:Hi,

I don't think this is JoomFish problem but you can test to be sure. Disable sh404SEF for few second and test home button. If it is working fine then it is sh404SEF issue.

Try next also: Go in sh404SEF URL Manager and search for frontpage, I guess you should get SEF links that are related to Home page. Delete those URL and browse the site and test.

If you didn't create much changes in sh404SEF (like custom URL, meta information and etc) maybe you could purge all sh404SEF cache.

Sorry I don't know how to help you more (:

Best,
Boris
Hi there,
i have the same problem and when i turn off the sh404SEF everything works fine. The problem is that there's nothing in the sh URL manager section so there's nothing to delete. Before i had some other component of sh404SEF and there was also an option to purge but the new one which my webmaster installed doesn't have this function. Unfortunatelly now he says he doesn't have time to finish what he started.

The only sections with links in them are just URL manager and Manager 404 requests.

Do you have an idea what could it be?

Thanks a lot in advance

lilian5049
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Sun Apr 03, 2011 6:00 pm

Re: Home link always redirect to default language

Post by lilian5049 » Sat Sep 03, 2011 7:56 pm

It is activated, clicked on yes. I deleted everything from the 404 requests but i guess there's no connection. Nothing changed...

User avatar
lopoBL
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 235
Joined: Mon Jun 21, 2010 12:28 pm
Location: Banja Luka, Bosnia
Contact:

Re: Home link always redirect to default language

Post by lopoBL » Sat Sep 03, 2011 8:03 pm

I don't know really. It looks like something is not working good in your installation of sh404SEF.

lilian5049
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Sun Apr 03, 2011 6:00 pm

Re: Home link always redirect to default language

Post by lilian5049 » Sat Sep 03, 2011 8:13 pm

Still, thank you for trying...

User avatar
ahmad
Joomla! Guru
Joomla! Guru
Posts: 903
Joined: Fri Apr 07, 2006 4:02 pm
Location: Egypt
Contact:

Re: Home link always redirect to default language

Post by ahmad » Sun Oct 02, 2011 4:59 pm

I had the same issue but I used a different solution

I replaced

Code: Select all

$tmp->url = JURI::base();
with

Code: Select all

$tmp->url = JURI::base()."index.php";
It's working perfectly to me now.

lilian5049
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Sun Apr 03, 2011 6:00 pm

Re: Home link always redirect to default language

Post by lilian5049 » Sun Oct 02, 2011 6:04 pm

Hi Ahmed,
sorry but where did you do that? In which file?

User avatar
ahmad
Joomla! Guru
Joomla! Guru
Posts: 903
Joined: Fri Apr 07, 2006 4:02 pm
Location: Egypt
Contact:

Re: Home link always redirect to default language

Post by ahmad » Mon Oct 03, 2011 7:14 am

I modified the following file :
modules/mod_mainmenu/helper.php

lilian5049
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Sun Apr 03, 2011 6:00 pm

Re: Home link always redirect to default language

Post by lilian5049 » Mon Oct 03, 2011 9:45 am

Doesn't work with me unfortunatelly...

zeusi
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Nov 07, 2011 1:08 pm

Re: Home link always redirect to default language

Post by zeusi » Mon Nov 07, 2011 1:29 pm

I changed

Code: Select all

$tmp->url = JURI::base();
with

Code: Select all

$language = JFactory::getLanguage();
$params = JComponentHelper::getParams("com_languages");
if ( $language->getTag() == $params->get("site", "en-GB") ) {
        $tmp->url = JURI::base();
} else {
	$lang_code_partials = explode("-", $language->getTag());
	$lang_prefix = array_shift($lang_code_partials);
	$tmp->url = JURI::base()."index.php?lang=".$lang_prefix;
}
However I don't like to hack the joomla code, so I am open to other solutions.
Can be this considered a bug ?


Locked

Return to “Language - Joomla! 1.5”