greek characters

Moderators: Aris Ntatsis, geof

Locked
m_barbaras
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Thu Jun 24, 2010 8:53 am

greek characters

Post by m_barbaras » Mon Jun 28, 2010 11:08 am

when i upload my documents written in Greek , they appeared on the web page as ????????????
Can someone help me

thanks

 
User avatar
tsimpo
Joomla! Guru
Joomla! Guru
Posts: 527
Joined: Thu Sep 15, 2005 5:09 am
Location: Greece
Contact:

Re: greek characters

Post by tsimpo » Mon Jun 28, 2010 12:30 pm

Check encoding and collation in mySQL. Should be utf-8 and utf-8_general_ci


What version of joomla you have?


Also check the html encoding.
Joomla sites. http://www.webcase.gr Υπηρεσίες Internet, websites, Joomla! dedicated services.

sguimaraes
Joomla! Intern
Joomla! Intern
Posts: 69
Joined: Thu Feb 04, 2010 5:53 pm
Location: Berlin, Germany

Re: greek characters

Post by sguimaraes » Mon Jul 05, 2010 3:33 pm

hi, I am new using Joomla and I had today exactly the same problem and spent quite some time looking for a tutorial how to fix it. what worked for me, with the help of several different posts aswers to the problem was:

go to my Cpanel > myPHPadmin > selecting the Database or several ones under Joomla Database, and then changing the collation from Latin_Swedish to UTF8_general_ci

Also, I had to go 'inside' every single table from my database and do the change manually to finally solve the problem.

after that, question marks disappeared and the correct characters that I have copy pasted from msword were shown both in the editor frontend and website itself.

good luck!

m_barbaras
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Thu Jun 24, 2010 8:53 am

Re: greek characters

Post by m_barbaras » Wed Jul 07, 2010 6:00 am

thank you all for your help, i have finally found a solution thanks to you all.
REALLY FROM THE BOTTOM OF MY HEART I HAVE TO THANK ALL OF YOU.

 

Locked

Return to “Greek Forum”