Media Manager vs. $live_site

Neu bei Joomla? Allgemeine Fragen über Joomla!

Moderator: Sisko1990

Forum rules
Forumregeln
Locked
Randegger
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Apr 16, 2010 5:11 pm

Media Manager vs. $live_site

Post by Randegger » Fri Apr 16, 2010 5:14 pm

Damit bei meiner Site http://www.ideal-holzbau.ch die Funktion suchmaschinenfreundliche URL funktioniert, sprich bei den versch. Menüs nicht die Darstellung abhanden kommt indem nur Text dargestellt wird, habe ich die Konfiguration von $live_site auf "/" gesetzt. Dies hatte ich einem Forum so entnommen.

Funktioniert auch alles prima damit, nur scheint der Media Manager nun ein Problem zu haben. Mir ist nämlich aufgefallen, dass ich keine Bilder mehr hochladen kann und die folgende Fehlermeldung angezeigt wird:
Firefox weiß nicht, wie diese Adresse geöffnet werden soll, da das Protokoll (undefined) mit keinem Programm verknüpft ist.
(Bei anderen Browsern geht es auch nicht, sondern es kommt einfach eine Fehlerseite.)

Nach Konsultation von Foren, etc. habe ich zuerst den Fehler beim Flash-Upload gesucht und etwas hantiert und siehe da: Es funktionierte wieder mit dem Upload. Es stellte sich aber heraus, dass gleichzeitig in der configuration.php die $live_site Einstellung wieder mit "" überschrieben wurde.

Daher meine Frage:
Ist es möglich, dass dort ein Zusammenhang besteht und falls ja, wie könnte ich das Problem beheben?

Und so ganz nebenbei:
Wie könnte man einstellen, dass nicht bei jeder Anpassung der Konfiguration über das Administrator-Backend einem der $live_site Eintrag wieder überschrieben wird?

Vielen Dank im Voraus!

User avatar
raouf84
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 114
Joined: Mon Jan 26, 2009 1:32 pm
Location: Srinagar
Contact:

Re: Media Manager vs. $live_site

Post by raouf84 » Fri Apr 16, 2010 5:37 pm

Hi,
could you please translate your post into English so that more people can read and help you?
Try to enter this as your live site:
http://www.ideal-holzbau.ch/

Randegger
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Apr 16, 2010 5:11 pm

Re: Media Manager vs. $live_site

Post by Randegger » Sat Apr 17, 2010 1:10 pm

For getting the SEF URL working at my site http://www.ideal-holzbau.ch I had to set the $live_site in the configuration.php on "/". I got this out of a forum.

This works fine, but now the media manager seems to get some problems. I noticed that you can't upload any pictures by the media manager, a error message appears:
Firefox doesn't know how to open this adress, becaus the protocol (undefine) isn't linked with a program.
(With other browsers, I get no error message but a error site 404.)

After consulting forums I tried to fix it by chaning the Flash Upload option and the upload worked again. But now in configuration.php the $live_site was overwritten to "" and the sub sites couldn't be loaded properly. So these two things seem to be linked.

So my question:
Is it possible, that there is a link between these problems and if yes, how can I solve it?

And by the way:
How can I manage that in the configuration.php the $live_site entry doesn't get overwritten everytime I change something in the configuration within the administrator backend?

Thank you very much for your help!

Randegger
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Apr 16, 2010 5:11 pm

Re: Media Manager vs. $live_site

Post by Randegger » Sat Apr 17, 2010 1:17 pm

raouf84 wrote:Hi,
could you please translate your post into English so that more people can read and help you?
Try to enter this as your live site:
http://www.ideal-holzbau.ch/
Thank you for your input!
I tried this and it seems that this can solve the problem.

But I have a second url (http://www.dachanhebung.ch) which is linked to the same webspace. By setting $live_site to "/", your url stays at this one, you once have set. Changing $live_site to www.ideal-holzbau.ch makes this impossible, because once you choose another menu, the url switches to www.ideal-holzbau.ch/news (e.g.).

But I think, if nothing else helps, I will have to take this "second-best" solution.
Thank you very much!

User avatar
mahagma
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Feb 14, 2011 1:09 pm

Re: Media Manager vs. $live_site

Post by mahagma » Sat Jun 11, 2011 9:21 pm

Thx / Danke


Locked

Return to “Allgemeine Fragen”