Modul für Umfragen funktioniert mit Joomla-eigenem SEF nicht

Moderator: Sisko1990

Forum rules
Forumregeln
chilly_bang
Joomla! Apprentice
Joomla! Apprentice
Posts: 32
Joined: Tue May 16, 2006 6:32 pm

Modul für Umfragen funktioniert mit Joomla-eigenem SEF nicht

Postby chilly_bang » Sat Mar 05, 2011 2:13 am

Hallo an alle!

Wie im Thema angesprochen: wenn Joomla-eigenes SEF eingeschaltet ist, so wird jeder Klick auf jede Option (ob Abstimmung oder Ergebnis) im Joomla-eigenen Poll Modul auf die Hauptseite weitergeleitet, ohne Fehlermeldungen. Weitere Klicks auf "Ergebnis" werden auch auf die Hauptseite weitergeleitet, allerdings begleitet von der Meldung, dass es bereits avgestimmt wurde (das heißt, dass die erste Abstimmung doch registriert wurde). Wenn SEF abgeschaltet ist, funktioniert das Modul wie es muss, ohne Probleme.
Noch Mal: es ist kein fremder SEF-Komponent im Einsatz, nur Joomla-eigenes SEF.

Kennt jemand aus der Gemeinde das Problem/die Lösung? Es ist die letzte Joomla im Einsatz (1.5.22.)

Vielen Dank schon mal im Voraus und beste Grüße aus Berlin

User avatar
Slowrider
Joomla! Ace
Joomla! Ace
Posts: 1055
Joined: Wed Apr 21, 2010 7:36 am

Re: Modul für Umfragen funktioniert mit Joomla-eigenem SEF n

Postby Slowrider » Sun Mar 06, 2011 3:20 pm

Funktionieren sonst alle Links? Welche Form hat die URL? Am Besten Link zur Seite posten.

chilly_bang
Joomla! Apprentice
Joomla! Apprentice
Posts: 32
Joined: Tue May 16, 2006 6:32 pm

Re: Modul für Umfragen funktioniert mit Joomla-eigenem SEF n

Postby chilly_bang » Sun Mar 06, 2011 5:33 pm

Hallo Slowrider!
Sonst funktioniert alles.
Link sieht so aus: component/poll/1-this-is-poll-title#content
URL zur Seite ist: http:// explorise . de

acapella
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Jun 23, 2012 10:48 am

Re: Modul für Umfragen funktioniert mit Joomla-eigenem SEF n

Postby acapella » Sat Jun 23, 2012 10:52 am

Selbes Problem... Das Problem trat 2008 schon einmal auf, aber nach einem Patch war es gelöst (http://joomlacode.org/gf/project/joo...r_item_id=9342). Mit Joomla 1.5.26 sollte aber dieser Patch bereits in deiner und meiner Webseite eingebaut sein. Bei mir ist das so (hab die entsprechenden Codezeilen überprüft) und trotzdem läuft es nicht. Immer noch wird nach Umfragebeteiligung oder bei klick auf Ergebnis bei eingeschaltenem Joomla-eigenen SEF nicht auf das Ergebnis weitergeleitet, sondern auf die Startseite. der link in der adresszeile ist aber dabei bizarrerweise die umfrageseite: http://www.xxx.de/component/poll/13-blablabla

Ich bin ratlos... Vermute zwar dass es damit zu tun haben könnte, dass ich sh404sef installiert habe, kurzfristig aktiviert aber wieder deaktiviert habe. Ansonsten hilft nur die com_polls/controller.php zu überprüfen. Es fehlen mir aber hier die nötigen Fähigkeiten.

Kann irgendjemand helfen? Link: www. myfanfest . de

User avatar
Slowrider
Joomla! Ace
Joomla! Ace
Posts: 1055
Joined: Wed Apr 21, 2010 7:36 am

Re: Modul für Umfragen funktioniert mit Joomla-eigenem SEF n

Postby Slowrider » Sat Jun 23, 2012 3:34 pm

Da die Joomla-eigene SEF-Funktion solche Fehler nicht bringt (ich nehme an, der TS hatte anfangs auch sh404 laufen), kann es nur an sh404sef liegen. Deinstalliere es probehalber und lösche auch die verbliebenen DB-Einträge.

acapella
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Jun 23, 2012 10:48 am

Re: Modul für Umfragen funktioniert mit Joomla-eigenem SEF n

Postby acapella » Sun Jun 24, 2012 11:06 pm

sh404sef ist deinstalliert und die Tabellen redirection, sh404sef_aliases und sh404sef_meta gelöscht. Leider gehts immer noch nicht.


Return to “Komponenten, Module, Plugins”

Who is online

Users browsing this forum: No registered users and 5 guests