Page 1 of 1

[Joomla! 1.5] Configuration requise

Posted: Tue Nov 25, 2008 5:42 pm
by mejean
Avant de choisir votre hébergement ou pour préparer votre installation locale, vérifiez ces paramètres avant d'installer Joomla! 1.5 :
  • Un serveur Web opérationnel : Apache à partir de la version 1.3, fonctionne sous Microsoft IIS ;
  • Le langage de script PHP à partir de la version 4.3.10 supportant MySQL, XML et Zlib (mod_mysql, mod_xml et mod_zlib), la version 4.4.7 est recommandée ; la directive Mbstring langage doit être par défaut et Mbstring overload désactivée ;
  • Le système de gestion de bases de données MySQL à partir de la version 3.23.x*
Joomla! supporte les versions les plus récentes d'Apache, PHP et MySQL : 2.2, 5.x et 5.x respectivement.

* Pour l’utilisation du jeu de caractères Unicode, il faut utiliser au moins la version 4.1.x de MySQL

Certains paramètres PHP sont recommandés afin d'assurer une pleine compatibilité avec Joomla!. Toutefois, Joomla! devrait quand même fonctionner correctement si ces paramètres ne correspondent pas.
  • safe_mode : Off
  • display_error : Off
  • file_uploads : On
  • magic_quotes_runtime : Off
  • register_globals : Off
  • output_buffering : Off
  • session.auto_start : Off
Source : http://help.joomla.org/content/view/1938/310/