Purity from SVN has no top menu?

Everything to do with Joomla! 1.5 templates and templating.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
roderiko
Joomla! Apprentice
Joomla! Apprentice
Posts: 38
Joined: Thu Apr 19, 2007 6:38 pm

We want a fix for Ja Purity Green & Blue Menu !!

Post by roderiko » Wed Jul 16, 2008 2:47 pm

i don't understand why ja purity have this modification with errors for green and blue menu...

anyone from joomla art and joomla team have to find a solution... PLEASE

this is the template winner and with this error.... becomes into a problem to all the users of ja purity...

i hope both members (joomla art - joomla org) will find the fix to came back the simple use of this fabulous template.

thanks a lot for your work!!!

------------------------------------------
this is my test site: http://www.madonnasecrets.com/portal/
and this is how the green menu looks...

User avatar
PhilOSparta
Joomla! Guru
Joomla! Guru
Posts: 512
Joined: Sun Feb 25, 2007 10:44 pm
Location: New Jersey, USA
Contact:

Re: ja_purity status

Post by PhilOSparta » Wed Jul 16, 2008 11:52 pm

I hope you got an answer to your question. If not, ja_purity was issued with the Joomla 1.5.4 version.
However, be aware that the template doesn't work exactly as the original. The blue and green header selections don't have a way to change the menu selections in the horizontal navigation top menu. You only get BLACK as the tab selection and roll over colors. Other threads address this issue, but it appears to have been an oversight on the part of the developers, and it will take some coding effort to get that feature to work. There is no easy solution.

User avatar
Jenny
Joomla! Champion
Joomla! Champion
Posts: 6238
Joined: Sun Aug 21, 2005 2:25 pm
Contact:

Re: ja_purity status

Post by Jenny » Thu Jul 17, 2008 7:19 pm

The header has been fixed and it will be in the next release.. the hover and active menus are now registering the correct color.

In the meantime you can see the two attached files that contain the css for the style.css for each header color.
You do not have the required permissions to view the files attached to this post.
Co-author of the Official Joomla! Book http://officialjoomlabook.com
Marpo Multimedia http://marpomultimedia.com

User avatar
PhilOSparta
Joomla! Guru
Joomla! Guru
Posts: 512
Joined: Sun Feb 25, 2007 10:44 pm
Location: New Jersey, USA
Contact:

Re: Menu Type (Header Menu) Gone

Post by PhilOSparta » Thu Jul 17, 2008 7:42 pm

The problem of the BLACK tabs has been fixed!
The problem of the SEPARATOR may still be unresolved.
Check this link for the two files that fix the green and blue styles.css files.
http://forum.joomla.org/viewtopic.php?f ... 9#p1353479
Last edited by PhilOSparta on Fri Jul 18, 2008 12:11 pm, edited 2 times in total.

User avatar
PhilOSparta
Joomla! Guru
Joomla! Guru
Posts: 512
Joined: Sun Feb 25, 2007 10:44 pm
Location: New Jersey, USA
Contact:

Re: We want a fix for Ja Purity Green & Blue Menu !!

Post by PhilOSparta » Thu Jul 17, 2008 7:43 pm

The problem has been fixed!
Check this link.

http://forum.joomla.org/viewtopic.php?f ... 9#p1353479

urednik
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 125
Joined: Mon Aug 13, 2007 7:45 am
Contact:

Re: Menu Type (Header Menu) Gone

Post by urednik » Thu Jul 17, 2008 10:46 pm

Yes Phil, but you still did not test the bug with the SEPERATOR - it still do not work!
Check my website (www.veneti.info) - i had to change MAIN SEPARATOR LINKS - SINCE THEY BROKE CSS as seen on the image above which I provided.

Is there a solution for this? There is still a problem with SECOND LEVEL SEPARATOR menu links - see on my live site:
under ARTICLES and NEWS there are separator links with a name OTHER - they collapse the CSS - in IE they even change the position of the third level menu!

Please if sbd could provide a fix!
Voluntary history research on Veneti.info

User avatar
PhilOSparta
Joomla! Guru
Joomla! Guru
Posts: 512
Joined: Sun Feb 25, 2007 10:44 pm
Location: New Jersey, USA
Contact:

Re: Menu Type (Header Menu) Gone

Post by PhilOSparta » Thu Jul 17, 2008 11:00 pm

Miss post.
Last edited by PhilOSparta on Fri Jul 18, 2008 11:25 am, edited 2 times in total.

roderiko
Joomla! Apprentice
Joomla! Apprentice
Posts: 38
Joined: Thu Apr 19, 2007 6:38 pm

Re: We want a fix for Ja Purity Green & Blue Menu !!

Post by roderiko » Thu Jul 17, 2008 11:35 pm

thanks... :D

urednik
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 125
Joined: Mon Aug 13, 2007 7:45 am
Contact:

Re: Menu Type (Header Menu) Gone

Post by urednik » Thu Jul 17, 2008 11:58 pm

Why do you repeat your post Phil?
You just do not seem to get it - did you check my website? Did you see the image of my menu problem? Or do you always think only of your problem.

This is a community, so please let us not post if we do not check things first.
The issue is not yet fully resolved!

The problem with SEPARATOR links remain!
Voluntary history research on Veneti.info

blotta
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Jul 11, 2008 2:09 am

Re: ja_purity status

Post by blotta » Fri Jul 18, 2008 6:16 am

Thank you very much for this reply Jenny. This is encouraging news!

urednik
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 125
Joined: Mon Aug 13, 2007 7:45 am
Contact:

Re: ja_purity status

Post by urednik » Fri Jul 18, 2008 8:37 am

Hello - there are still problems with SEPARATOR menu items - they do not respect the CSS! See the quoted message:
Yes Phil, but you still did not test the bug with the SEPERATOR - it still do not work!
Check my website (http://www.veneti.info) - i had to change MAIN SEPARATOR LINKS - SINCE THEY BROKE CSS as seen on the image above which I provided.

Is there a solution for this? There is still a problem with SECOND LEVEL SEPARATOR menu links - see on my live site:
under ARTICLES and NEWS there are separator links with a name OTHER - they collapse the CSS - in IE they even change the position of the third level menu!

Please if sbd could provide a fix!
The image posted by me can be seen in this thread: http://forum.joomla.org/viewtopic.php?f ... 1#p1353661

How to fix that?
Voluntary history research on Veneti.info

User avatar
PhilOSparta
Joomla! Guru
Joomla! Guru
Posts: 512
Joined: Sun Feb 25, 2007 10:44 pm
Location: New Jersey, USA
Contact:

Re: Menu Type (Header Menu) Gone

Post by PhilOSparta » Fri Jul 18, 2008 12:38 pm

urednik,
urednik wrote:Why do you repeat your post Phil?
You just do not seem to get it - did you check my website? Did you see the image of my menu problem? Or do you always think only of your problem.

This is a community, so please let us not post if we do not check things first.
The issue is not yet fully resolved!

The problem with SEPARATOR links remain!
I'm sorry for the repost. That was an oversight on my part, and I fully agree with you on "this community", or I wouldn't be here working on these problems.
At this writing, your test site still has the old code with the black rollover etc. so I couldn't verify the separator problem.

I just looked at your production site and it looked great with FireFox so I fired up the Internet Explorer and found that the menu tabs have disconnects that I have never seen before. When the mouse pointer is rolled over the space between the menu tabs that are disconnected, the disconnected menu level disappears. I don't know if you have separators there. The second photo shows an overlap.
The attached three photos ( by camera, because I don't use IE for anything but testing ) show the disconnects.
Were you aware of this anomaly?
You do not have the required permissions to view the files attached to this post.

Macjoomla
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Fri Sep 02, 2005 9:34 am

Re: ja_purity status

Post by Macjoomla » Fri Jul 18, 2008 12:52 pm

Jenny wrote:In the meantime you can see the two attached files that contain the css for the style.css for each header color.
Perfect! Thanks a lot :)

User avatar
Jenny
Joomla! Champion
Joomla! Champion
Posts: 6238
Joined: Sun Aug 21, 2005 2:25 pm
Contact:

Re: Menu Type (Header Menu) Gone

Post by Jenny » Fri Jul 18, 2008 12:55 pm

Okay I see that there is a difference between IE and FF. In FF things work well. In IE it works but there is no overlap on some secondary menu levels. I don't know what to tell you, except that cross browser compatibility is extremely difficult. I could not see when I was surfing your site in IE that it affects the usability of the site.

That being said, as always patches are welcome to fix these issues. Instead of complaining and wanting someone else to fix it, help track down what is going on.
Co-author of the Official Joomla! Book http://officialjoomlabook.com
Marpo Multimedia http://marpomultimedia.com

urednik
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 125
Joined: Mon Aug 13, 2007 7:45 am
Contact:

Re: Menu Type (Header Menu) Gone

Post by urednik » Fri Jul 18, 2008 1:09 pm

Jenny - still you do not see the main problem - see my image posted above (http://forum.joomla.org/download/file.php?id=50074&t=1)

The problem are SEPARATOR MENU LINKS, which I had to remove on my production site (only in first level menu). On the image you can see how it looks if I use them also in the first level. Anyway also the second level ones (like OTHER as posted in one image by Phil) have also different CSS style.

Anyway the overlap was there in the prevous version - so I think it is possible to correct this. But do not forget - I have no knowledge about developing CSS - so the only thing is to point out to a problem, which I did!

Hopefully I was understood this time?!

Phil - thank you - yes I was aware of this - I even posted about this above:
There is still a problem with SECOND LEVEL SEPARATOR menu links - see on my live site:
under ARTICLES and NEWS there are separator links with a name OTHER - they collapse the CSS - in IE they even change the position of the third level menu!
And this means that SEPARATOR LINK and TRIRD LEVEL not connected are the same problem - since with normal links it works ok.
Voluntary history research on Veneti.info

User avatar
Jenny
Joomla! Champion
Joomla! Champion
Posts: 6238
Joined: Sun Aug 21, 2005 2:25 pm
Contact:

Re: Menu Type (Header Menu) Gone

Post by Jenny » Fri Jul 18, 2008 1:50 pm

Urednik,

We're working on it. Hopefully together we can get it all fixed up. Hang in there. :)
Co-author of the Official Joomla! Book http://officialjoomlabook.com
Marpo Multimedia http://marpomultimedia.com

urednik
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 125
Joined: Mon Aug 13, 2007 7:45 am
Contact:

Re: Menu Type (Header Menu) Gone

Post by urednik » Fri Jul 18, 2008 2:37 pm

Great to hear that Jenny!

Seems that nobody used SEPARATOR links except of me ... :eek:

There is another issue connected with this:
the "submenu" heading out of a SEPARATOR menu item has BOLD FONTS for links (normally they aren't bold).

Ehhh - sorry but my last statment is incorrect. It works there as expected ... BOLD fonts are OK.
Voluntary history research on Veneti.info

roderiko
Joomla! Apprentice
Joomla! Apprentice
Posts: 38
Joined: Thu Apr 19, 2007 6:38 pm

Re: ja_purity status

Post by roderiko » Fri Jul 18, 2008 4:52 pm

Jenny wrote:The header has been fixed and it will be in the next release.. the hover and active menus are now registering the correct color.

In the meantime you can see the two attached files that contain the css for the style.css for each header color.
thanks a lot...
but i don't know what to do...
what are the steps to fix it manually?

thanks... roderiko :D

User avatar
Jenny
Joomla! Champion
Joomla! Champion
Posts: 6238
Joined: Sun Aug 21, 2005 2:25 pm
Contact:

Re: ja_purity status

Post by Jenny » Fri Jul 18, 2008 5:01 pm

Download the above files.
Rename the blue one to style.css. Use that file to overwrite the style.css in the folder named blue in the header folder.

Repeat the above step with the green.
Co-author of the Official Joomla! Book http://officialjoomlabook.com
Marpo Multimedia http://marpomultimedia.com

roderiko
Joomla! Apprentice
Joomla! Apprentice
Posts: 38
Joined: Thu Apr 19, 2007 6:38 pm

Re: ja_purity status

Post by roderiko » Fri Jul 18, 2008 5:43 pm

ok. thanks.

nkoomla
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Mon Nov 26, 2007 2:10 pm

Re: Purity from SVN has no top menu?

Post by nkoomla » Fri Jul 18, 2008 5:58 pm

Thanks PhilOSparta, worked like a charm.

User avatar
Jenny
Joomla! Champion
Joomla! Champion
Posts: 6238
Joined: Sun Aug 21, 2005 2:25 pm
Contact:

Re: Purity from SVN has no top menu?

Post by Jenny » Sat Jul 19, 2008 2:42 pm

I have merged all the similar threads regarding the blue and green css/header menu issues. There are still other issues and they are being worked on. :)
Co-author of the Official Joomla! Book http://officialjoomlabook.com
Marpo Multimedia http://marpomultimedia.com

f3red
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Sat May 17, 2008 12:51 pm

Re: Purity from SVN has no top menu?

Post by f3red » Sun Jul 27, 2008 2:15 am

Thanks Phil. I was really sweating that one!

I can add that, depending on website needs, one might also select "Always show sub-menu Items" to "Yes" - I needed to do that to restore previous functionality.

Life is once again good.
f3

urednik
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 125
Joined: Mon Aug 13, 2007 7:45 am
Contact:

Re: Purity from SVN has no top menu?

Post by urednik » Mon Jul 28, 2008 7:42 am

Jenny are all issues solved in the 1.5.5 release?
I am asking also because of the separator issue ...
Voluntary history research on Veneti.info

User avatar
Jenny
Joomla! Champion
Joomla! Champion
Posts: 6238
Joined: Sun Aug 21, 2005 2:25 pm
Contact:

Re: Purity from SVN has no top menu?

Post by Jenny » Mon Jul 28, 2008 1:22 pm

Some items have been fixed, some have not, I do not think the separator issue has been resolved. As always patches and ideas for fixes are always welcome. :)
Co-author of the Official Joomla! Book http://officialjoomlabook.com
Marpo Multimedia http://marpomultimedia.com

zakx
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Jun 27, 2008 11:32 am

Purity separator issue FIX (of sorts)

Post by zakx » Wed Jul 30, 2008 12:34 am

Hi,

I was stumped as to why separators should have the wrong formatting, and was amazed that upgrading to 1.5.5 didn't solve the issue.

No matter - I found a kludge that works. Just change all separators to external links but don't set a value for the link. Voila! Your menus now work as they should.

Maybe this will provide a clue to the solution?

Zak

bmheck
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Sun Jul 20, 2008 3:53 pm

Re: Purity from SVN has no top menu?

Post by bmheck » Thu Aug 14, 2008 8:40 pm

Zak,

You're a genius! Thanks, that fix (use External Link menu items with no link specified) appears to work just fine. Yes, it's a kludge, but better than those funky-looking separators. We can hope that the good people working on this will figure out a more elegant solution for 1.5.7 (or whatever is next).

For anyone else trying this: this will *not* work correctly unless the menu item was a separator immediately before you make it a null external link. For example, if you had the menu item set to a category list, Joomla! will remember that it's a category list even after you change it to a null link! You *must* change the item to a separator first, save it, then change it to a null link. Yes, this obviously is bad behavior, but it's very useful bad behavior.

Memo to Joomla! developers: please don't implement a validity check to ensure that an external link is specified when creating an External Link menu item -- at least not until the ja_purity separator formatting issue is solved......

User avatar
instance
Joomla! Explorer
Joomla! Explorer
Posts: 302
Joined: Mon Nov 13, 2006 11:31 am
Location: Toronto, Canada

Re: Purity from SVN has no top menu?

Post by instance » Sat Aug 16, 2008 4:39 pm

Unfortunately, the menu separators are going to be problematic for a while. The problem is with com_mainmenu. It doesn't put a separator indicator where it's needed.

I have given the CSS for the top menu a complete overhaul. For the moment, separators in the drop downs render as a small gap. The attached file contains four files, all relative to the ja_purity directory. If anyone wants to test these out and provide feedback I'd appreciate it.

These files are experimental and unofficial. Back up your existing files before putting these in; try them on a demo site first; caveat emptor, etc., etc.

P.S. I have tested this in FF3, IE7, and Opera 9.5. Feedback from an IE6 user would be helpful.
You do not have the required permissions to view the files attached to this post.

courcyceline
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sun Sep 14, 2008 1:48 pm

Re: Menu Type (Header Menu) Gone

Post by courcyceline » Mon Sep 15, 2008 5:49 pm

mariusvr wrote:Same problem here. After updating my site to Joomla 1.5.4 my top header menu is gone. I checked in the template HTML and the nice menu code has been removed and now a direct display of the "hornav" modules is called. However Joomla itself does not have a default Mootools menu from what I can see.

Why was this code removed? In my opinion the integrated menu feature was what made ja_purity stand out from the crowd.

I have included an old version of ja_purity to this post, to help other people who might have got this problem after upgrading to Joomla 1.5.4

Thanks, Marius
Thank you, thank you, thank you! Problem now fixed.

netwizard
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Jul 29, 2008 2:09 pm

Still having trouble

Post by netwizard » Wed Sep 24, 2008 5:26 pm

Image

My menu was working fine, till I mistakenly upgraded to 1.5.7. Now I have to fix it again but...

I have followed the instructions above, downloading bluestyles.txt and replacing style.css with it. My menu looks better, hovering and submenus are the right colour... but my main menus up the top are still showing in grey (see photo)

Can anybody advise me what is wrong here?


Locked

Return to “Templates for Joomla! 1.5”