Install Issue on IIS - Stuck at "Select Language" - Solution

This forum is for issues with installing Joomla! on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
paulb2009
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Sat Aug 08, 2009 11:43 pm
Location: USA
Contact:

Install Issue on IIS - Stuck at "Select Language" - Solution

Post by paulb2009 » Wed Sep 02, 2009 5:19 am

Hello all,

I'd like to share a solution I found. If it's been documented, I apologize for duplicating, but I hadn't found it anywhere and spent hours finding this solution.

I usually work with Linux/Apache, but a recent client had a Windows 2003 Server running IIS. There were about 9 different instances of Joomla 1.5.14 running and all but one worked. The one that didn't... What a pain... When I would install, I would get the "Select Language" screen, but could not progress past it. In IE, there was the error in the bottom left and when I clicked on it, I got this code:

Code: Select all

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; GTB6; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0)
Timestamp: Mon, 31 Aug 2009 23:25:28 UTC


Message: Invalid character
Line: 100
Char: 606
Code: 0
URI: http://---/media/system/js/mootools.js


Message: Invalid character
Line: 23
Char: 5
Code: 0
URI: http://---/installation/includes/js/installation.js


Message: Invalid character
Line: 246
Char: 5
Code: 0
URI: http://---/installation/template/js/validation.js


Message: Object doesn't support this property or method
Line: 19
Char: 4
Code: 0
URI: http://---/installation/index.php


Message: Object expected
Line: 88
Char: 3
Code: 0
URI: http://---/installation/index.php




I tried a work-around in which I copied everything from one of the other sites. That let me log in, but same result when I logged into admin.

SOLUTION:

What I finally found was that for that one install, the setup in IIS Manager was set to enable Document Footers. I've attached a screenshot of it. Once I disabled it, the install/site worked perfectly!

I spent hours finding this, even after the clients web host couldn't. Hopefully I can save someone else the headache!
You do not have the required permissions to view the files attached to this post.
Paul Buchanan
http://www.pbweb.us
***********************
When in doubt, use Firebug!!

 
macadelic
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Sun Jan 22, 2006 6:28 pm

Re: Install Issue on IIS - Stuck at "Select Language" - Solution

Post by macadelic » Mon Oct 12, 2009 6:54 am

I was so really for this to be the solution to my issue, but this didn't fix it for me

find_karl
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Fri Sep 11, 2009 3:36 am

Re: Install Issue on IIS - Stuck at "Select Language" - Solution

Post by find_karl » Wed Oct 14, 2009 2:04 am

This post is really old but since I am going through the pain of installing Joomla on IIS and finding these posts, let me add my experience here, in the hope that doing to may help someone else get there a little quicker than I did.

The problem which prevented me getting past the language selection was that Joomla was unable to write the set up changes to .\configuration.pbp

I had to change the security properties on the file to allow the Users group write access, I simply checked Full Control and the issue went away. Unfortunately that was not the end of the problems in short I ended up doing the same for the .\tmp folder, the .\installation folder and the .\templates folder.

naveedbutt
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Aug 03, 2011 5:11 am

Re: Install Issue on IIS - Stuck at "Select Language" - Solu

Post by naveedbutt » Wed Aug 03, 2011 5:18 pm

I am facing the same issue. My screen gets stuck on the page after hitting next on the language selection screen. I am installing it on IIS 7.5 under Windows 7 and the page gets stuck there.

I've tried giving all the privileges to USERS group. Also, tried giving all privileges to IUSR user and giving privileges to "everyone" in the end, but nothing works.

Please help me on this as IIS 7.5 does not have such a document footer section or option available for a website.

I also have tried to set enable document footer to false using appcmd tool provided by microsoft for IIS configuration related issues...

 

Locked

Return to “Joomla! 1.5 on IIS webserver”