NO pages work with SEF turned on

Discuss Search Engine Optimization in relation to Joomla!. This forum will also have discussions on SEF/SEO Joomla! extensions.

Moderator: General Support Moderators

Locked
drummerbran
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Sun Jun 01, 2008 6:32 am

NO pages work with SEF turned on

Post by drummerbran » Thu Aug 28, 2008 6:22 pm

I'm trying to get SEF turned on but none of my pages work. The home page works but any time i try ad click on sometign ing the main menu i get and internet exploer message saying that the webpage cant be found. I have followed the directions from this website http://docs.joomla.org/SEF_URLs_in_Joomla!_1.5. What am I doing wrong? I changed confi.php, turned on "add sufix to urls" and turned on "Use Apache mod_rewrite" and changed the htaccess.txt to htaccess. Can someone help me out.

If you want to have a look yourself got to http://www.cfisfm.com/index.php then to see the problem click on contact us. take notice that the url of the page changed to what it should be.

User avatar
ooffick
Joomla! Master
Joomla! Master
Posts: 11403
Joined: Thu Jul 17, 2008 3:10 pm
Location: Ireland
Contact:

Re: NO pages work with SEF turned on

Post by ooffick » Thu Aug 28, 2008 6:59 pm

hi,

you will need to rename the

Code: Select all

htaccess
file to

Code: Select all

.htaccess
Please note the dot at the beginning of the file name.

Olaf
Olaf Offick - Global Moderator
learnskills.org

drummerbran
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Sun Jun 01, 2008 6:32 am

Re: NO pages work with SEF turned on

Post by drummerbran » Thu Aug 28, 2008 7:06 pm

Thank you it works!


Locked

Return to “Search Engine Optimization (Joomla! SEO) in Joomla! 1.5”