No input file specified. Trying to use SEF URLs

Discuss Search Engine Optimization in relation to Joomla!. This forum will also have discussions on SEF/SEO Joomla! extensions.

Moderator: General Support Moderators

User avatar
vashanka
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Thu Jun 12, 2008 9:19 pm
Location: Reno, Nevada
Contact:

Re: No input file specified. Trying to use SEF URLs

Post by vashanka » Wed May 12, 2010 6:39 pm

Sent you a pm.

BTW your site looks great! Good work.

-Vashanka

 
Guncha
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon May 24, 2010 6:49 am

Re: No input file specified. Trying to use SEF URLs

Post by Guncha » Mon May 24, 2010 6:53 am

vashanka wrote:Hi Bazzazza-

In your .htaccess file, the line you need to make sure is correct is:

RewriteBase /

the / refers to the server path to your Joomla install. Basically it is the directory in which you FTP'd Joomla to on the host. If you can't figure it out please email me.

Also, you should delete the three commented lines beneath it. They begin with # signs and were just instructions from me. No reason to have them in the file. :)

Lastly, I don't use the SF404 module. Try disabling it and see if that fixes the problem.
Hello!

I have that problems :(

what is SF404 module ? ??? where i found that ?

User avatar
vashanka
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Thu Jun 12, 2008 9:19 pm
Location: Reno, Nevada
Contact:

Re: No input file specified. Trying to use SEF URLs

Post by vashanka » Mon May 24, 2010 6:45 pm

Hi there-

I'd like to help you but I think we're having a language problem. Please follow the steps in this thread if you are using GoDaddy Linux hosting with Joomla 1.5.x and you should have success with Joomla's built in URL re-writing.

sh404SEF is a popular commercial plugin for Joomla that does URL re-writing. I've never used it. You can learn more here:

http://extensions.joomla.org/extensions ... /sef/10134

David Blum
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Sat May 29, 2010 1:43 am

Re: No input file specified. Trying to use SEF URLs

Post by David Blum » Tue Jun 08, 2010 12:35 am

I didn't have a plugin called System - SEF, but I followed all the other instructions and it worked great! Thanks a lot!

User avatar
vashanka
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Thu Jun 12, 2008 9:19 pm
Location: Reno, Nevada
Contact:

Re: No input file specified. Trying to use SEF URLs

Post by vashanka » Tue Jun 08, 2010 1:20 am

Happy to help- glad it worked for you!

uccsu
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Jul 28, 2010 1:37 pm

Re: No input file specified. Trying to use SEF URLs

Post by uccsu » Wed Jul 28, 2010 1:50 pm

Hey, thanks for your guild and I followed it to the letter.

It's been three hours and while the URLs have changed I'm still getting page not found errors. Here is the htaccess.txt contents, after my edits as per your post. The file was found in the / file, ie root.

Any advice would be massively appreciated.
Last edited by uccsu on Wed Jul 28, 2010 7:19 pm, edited 1 time in total.

User avatar
vashanka
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Thu Jun 12, 2008 9:19 pm
Location: Reno, Nevada
Contact:

Re: No input file specified. Trying to use SEF URLs

Post by vashanka » Wed Jul 28, 2010 6:38 pm

Here is the htaccess.txt contents, after my edits as per your post.
Just to be clear: have you renamed the htaccess.txt file to .htaccess? If not, the file is being ignored by the server.

Please try that first and give it up to an hour. If you've done so, let me know and I'll give it a further look.

uccsu
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Jul 28, 2010 1:37 pm

Re: No input file specified. Trying to use SEF URLs

Post by uccsu » Wed Jul 28, 2010 7:18 pm

I think I want to marry you and have your children! That fixed my problem in about 30 seconds.

Thanks a million!

User avatar
vashanka
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Thu Jun 12, 2008 9:19 pm
Location: Reno, Nevada
Contact:

Re: No input file specified. Trying to use SEF URLs

Post by vashanka » Wed Jul 28, 2010 8:51 pm

Very glad to help! But you're out of luck: happily married, two kids... ;-)

LEOHYPER
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Wed Aug 11, 2010 4:40 pm

Re: No input file specified. Trying to use SEF URLs

Post by LEOHYPER » Sun Aug 15, 2010 4:26 pm

Where is SF404?

User avatar
Leftfield
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4437
Joined: Fri Dec 08, 2006 3:33 am
Contact:

Re: No input file specified. Trying to use SEF URLs

Post by Leftfield » Mon Aug 16, 2010 8:25 am

There is no SF404 as long as i know. The name of that extensions is SH404SEF.
Personal website (SEO & SEM): https://www.vujosevic.com

LEOHYPER
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Wed Aug 11, 2010 4:40 pm

Re: No input file specified. Trying to use SEF URLs

Post by LEOHYPER » Mon Aug 16, 2010 2:25 pm

Then where is SF404SEF?

User avatar
Leftfield
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4437
Joined: Fri Dec 08, 2006 3:33 am
Contact:

Re: No input file specified. Trying to use SEF URLs

Post by Leftfield » Mon Aug 16, 2010 4:14 pm

LEOHYPER wrote:Then where is SF404SEF?
You can find an answer on next link: http://forum.joomla.org/viewtopic.php?p ... 1#p2230511
Personal website (SEO & SEM): https://www.vujosevic.com

DevByStarlight
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Nov 12, 2010 3:25 am

Re: No input file specified. Trying to use SEF URLs

Post by DevByStarlight » Mon May 02, 2011 6:03 am

Hey all ...

Since this seems to be a popular thread for SEF, sub-directory masking, and so forth on many things goDaddy related ... so I thought I'd append an update for joomla 1.5.22

When I implemented the steps described by vashanka above (the well documented 9/9/2008 post) it achieved the desired affect - SEF URLs appeared, links worked properly, all "good".

Then I upgraded to Joomla 1.5.22 ... In hindsight ... well, just say yuck. I'd hacked the core so much in the previous joomla (1.5.? 4 maybe? one of the early 1.5.x releases) that my site broke down and started crying.

Anyway, once I got the site working, I tried reapplying vashanka's steps to 1.5.22 ... It worked okay. vanshanka's steps above probably do still work ... but didn't work as well for me after the upgrade.

However, I was still having some issues
1) outdated(!) page content was being returned to visitors
2) most of my jForms broke (my forms were using messed up URLs for submit actions like ".../blah/view/submit/12" ???)
3) visitor registration just choked ... even though technically the user was registered in the back-end
4) login module constantly redirected back to login even though user was registered s/he couldn't sign in

Probably none are a direct result of vashanka's posted steps. The steps worked on the earlier joomla but joomla has evolved several versions since the original post three years agao so that's more likely the cause of any discrepancies.

So, I unrolled the .htaccess changes and started again.

~~

So, the solution I have running now for Joomla 1.5.22 came from this thread:
* http://forum.joomla.org/viewtopic.php?f ... 4&start=30 - "Install Joomla in root or in subdirectory?"
* which I believe is based on the following (external link) http://www.drichproductions.com/random- ... ectory.php
* Specifically, DHSTARR's post on 9/9/2010 (coincidence exactly two years after vashanka's earlier post? Hmmm :))
* DHSTARR suggests having two .htaccess files to hide the sub-directory (one in the host root and another in the joomla root). (It works!)
* It also has the benefit of working *seamlessly* with the native Joomla SEF support without any additional extensions (or core hacks)

[aside: vashanka's steps indicate turn OFF caching in the Global Configuration and ENABLE the system - cache module.
* For me, even though "disabled" the cache still cached files and, apparently, returned them to visitor browser requests. No "real" harm except for me where my own changes weren't showing up.
* I have since disabled the system-cache module with no ill effect (Joomla 1.5.22)]

DHSTARR's steps worked from 1.5.22 - both hiding the sub-directory and the built-in SEF operating.
System-Cache DISABLED
SEF ON
mod_rewite ON
And, my forms are using the proper URLs.

A couple final notes:
1) AFTER changing the htaccess files for the "RewriteBase /mySubDir" ... THEN enable the global->configuration SEF ON and mod_rewrite ON (i think it may update the configuration.php live_site variable???)
If the SEF and mod_rewrite are enabled when you change the htaccess file, turn them off and on again. (and clear cache)

2) GoDaddy ... forms ... email ... in a nutshell, my forms weren't sending emails. And it took a week to track down why and it was such a *simple* thing.
Apparently when I'd configured the host machine way back whenever, I'd used another email address for my "Form Mail" settings. After I upgraded to 1.5.22 I changed the email address in the global->configuration to my newer email address. Such a minor thing I didn't think anything of it. And focus was on fixing a zillion other issues that by the time I got 1.5.22 back on it's feet and discovered emails weren't being sent that minor change to the "Mail From" wasn't even close to being on the radar as a cause of the problem (the email address is certainly valid)

Just in case it helps anyone else:
http://help.godaddy.com/article/508 - Specifying an Email Address for the PHP Form-Mailer (doesn't specifically apply but I went back to basics trying to make a test form use GoDaddy's script and when that failed too I knew it wasn't Joomla)
http://help.godaddy.com/article/3434 - Reinstalling the Default Scripts Directory on Linux Shared Hosting
Last edited by DevByStarlight on Tue May 03, 2011 1:56 am, edited 2 times in total.

User avatar
vashanka
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Thu Jun 12, 2008 9:19 pm
Location: Reno, Nevada
Contact:

Re: No input file specified. Trying to use SEF URLs

Post by vashanka » Mon May 02, 2011 11:47 pm

Just wanted to put a big shout out and hearty thank-you to DevByStarlight for the very detailed posting. I still lurk this thread but I haven't used GoDaddy hosting in over a year (I now do everything on Amazon AWS and my Joomla and WordPress sites run great). And no, I am not DHSTARR, the posting dates are just coincidental.

So thank you to DevByStarlight and best of luck to everyone still on GoDaddy and trying to get your SEF working! BTW, if you are interested in migrating to AWS feel free to reply to this thread or better yet PM or Email me.

-Vashanka

agapiouc
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Sep 06, 2011 7:28 am

Re: No input file specified. Trying to use SEF URLs

Post by agapiouc » Tue Sep 06, 2011 7:31 am

Hi, I had exactly the same problem and i followed the instructions found above.
It worked regarding the links and url rewritting but now none of the pics and photos I had don't load.

Can you help me fix this?

You can check the site in www.oiserraioi.com

Thanx

ronaldo85
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Nov 13, 2014 4:52 am

Re: No input file specified. Trying to use SEF URLs

Post by ronaldo85 » Thu Nov 13, 2014 5:09 am

I currently have joomla 3.3 and use godaddy and I was the same but siguiento Vashanka your steps and it turned out thanks! :) ;)

 

Locked

Return to “Search Engine Optimization (Joomla! SEO) in Joomla! 1.5”