Apache mod_rewrite on IIS7

Discuss Search Engine Optimization in relation to Joomla!. This forum will also have discussions on SEF/SEO Joomla! extensions.

Moderator: General Support Moderators

Locked
jtalbot
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Mon Jan 26, 2009 3:44 am

Apache mod_rewrite on IIS7

Post by jtalbot » Sun Feb 22, 2009 6:58 pm

I have Joomla 1.5.9 running on IIS7 on localhost. I'm now experimenting with the SEO Settings from the Joomla global configuration page.

First I toyed with Search Engine Friendly URLs (that gets rid of the queries part of URLs); that works fine.

I also tried to enable the "Use Apache mod_rewrite". I installed "Microsoft URL Rewrite Module for IIS 7.0" and added the web.config as per http://learn.iis.net/page.aspx/527/joomla-on-iis . Then I enabled "Use Apache mod_rewrite". When clicking on menu links, this seems to work in that I no longer see index.php in the URL. The address bar updates to what appears like the right URL, but the content shown is always that of the home page. I tried both in IE and Google Chrome with the same result. Refreshing the page after loaded made no difference.

I tried re-starting IIS7, it didn't make a difference.

Any idea on how to diagnose (or even better, fix :) ) this? I'm a beginner with IIS, Joomla and URL Rewriting so I may very well be missing something obvious.

Thanks,
Jimmy

jtalbot
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Mon Jan 26, 2009 3:44 am

Re: Apache mod_rewrite on IIS7

Post by jtalbot » Tue Feb 24, 2009 3:30 am

Woops, I just found another thread with exactly the same issue: http://forum.joomla.org/viewtopic.php?f ... 7#p1598137 . Please post any response to that thread.


Locked

Return to “Search Engine Optimization (Joomla! SEO) in Joomla! 1.5”