Joomla showing ip-address on some links instead of domain

Discuss Search Engine Optimization in relation to Joomla!. This forum will also have discussions on SEF/SEO Joomla! extensions.

Moderator: General Support Moderators

hauben
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Fri Jul 30, 2010 6:52 pm

Joomla showing ip-address on some links instead of domain

Postby hauben » Fri Sep 16, 2011 11:44 am

Hi!

Since yesterday I'm facing a strange problem that some links
pointing from a menu i.e. or towards an article are not shown like
my-domain/link but ip-address/link which is driving me crazy.

The provider is telling that there are no problems on their side.

After some hours it works again and everything is like normal - again
hours later the same again ip-address gets shown in the link.

I'm using Joomla 1.5.28 with AceSEF 1.5.18 - Joomla Caching is active
but explicity turned off for the main menu. The strange thing is that
the main menu links are sometimes showing the ip-address and some hours
later the domain-name again. If the main menu links would be always
shown correctly I would think that maybe the SEF component is doing some
crazy things and everything gets cached by Joomla. If the cache expires after 30 minutes
everything should be fine again. But this is not the case ....

Does anyone has an idea about this mysterium ?

Best regards
Frank

hauben
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Fri Jul 30, 2010 6:52 pm

Re: Joomla showing ip-address on some links instead of domai

Postby hauben » Mon Sep 19, 2011 7:43 pm

Hello!

I strongly believe that it is not the provider because if I look for instance to the generated html code of my template for i.e. the menu link "about" the url is embedded completly inside:

<div id="footer_left">
<ul class="menu">
<li class="item5">
<a href="http://www.mydomain.com/about">
<span>About</span>
</a>
</li>

The question is now who prepends the domain to the SEFed url "about". The support team from AceSEF says that AceSEF never does something with the domain. And the next question why is sometimes the prepended string my static IP-address???!!! And the second why is the URL not just a relative link without domain name/ip-address?

Regards
Frank

ws101a
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Fri Nov 11, 2011 3:19 pm

Re: Joomla showing ip-address on some links instead of domai

Postby ws101a » Thu Dec 08, 2011 5:03 pm

Hi Frank, did you ever get to the bottom of this?

I have the same problem: My menu links to xx.xx.xx.xx/viewtypeetc instead of www.mysite.com/viewtypeetc

If it helps you, I don't have AceSEF installed.

Are you saying that when you view the source of your page, the link is complete - as it should be in the URL - but despite this, the address bar shows the ip address, i.e. xx.xx.xx.xx/viewtypeetc ?

All the best,
Will

clandestino52
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu May 09, 2013 8:09 am

Re: Joomla showing ip-address on some links instead of domai

Postby clandestino52 » Thu May 09, 2013 8:11 am

Hello, Did you find out whay it's happening. I have the same issue since today and i didn't hace SEF installed.

Thank you

endor
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri May 10, 2013 9:30 am

Re: Joomla showing ip-address on some links instead of domai

Postby endor » Fri May 10, 2013 10:17 am

Hello,

I was facing the same symptoms in Joomla! 3.x. All internal links of my Joomla page where resolved to the IP address and not as expected with the domain name. I also set up a second Joomla website for a different domain on the same Server. The second one worked correctly. I change the settings of the malfunction installation (Var $live_site in configuration.php) without any effect.

What was the difference between both Joomla installations? The domain names where registered a two different provider. So I was having a closer look on the name server records of the domain which could not resolve internal links as I was expecting them.

Here was the reason for the wrong behavior in my case. The A-Record (AAAA-Record for IPv6 if you have an IPv6 Address) was not set. The domain was just forwarded to the IP Address in the settings of the service provider. The result was that I could get to the front- and backend by using my-domain but Joomla was not able to work correctly even when I set Var $live_site = ‘http://www.my-domain.tld’; in configuration.php.

If anyone has IP addresses in internal links of his Joomla website I would advise you to check your DNS settings. Check whether the A-Record (or the AAAA-Record) is set correctly. This was helping me in my case.

aaroncoulter
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Feb 22, 2014 1:13 am

Re: Joomla showing ip-address on some links instead of domai

Postby aaroncoulter » Sat Feb 22, 2014 1:20 am

I host my webserver at home, so it has a private IP address that keeps popping up in my site, rather than the domain name. I tried a few different things to fix the problem. First, I removed any mention of that ip address in my configuration.php file (I had placed it in there to enable FTP during install of Joomla). Second, I went into the network settings in the server and replaced my local DNS server address with that of Google DNS (8.8.8.8). Occasionally, I still see it pop up, but only when I'm viewing the page from the same network as the server. When I clear the server cache the problem goes away. No surprise, almost any glitch or problem that I have with the display of my website is usually directly related to the Joomla caching system.

jpsanudo
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sun Oct 12, 2014 9:53 pm

Re: Joomla showing ip-address on some links instead of domai

Postby jpsanudo » Thu Jul 23, 2015 9:26 am

Any idea about this?? I suppose this should be something quite simple -but I cannot solve it/find it-, since I don't see answers but the questions continue appearing along the years.

Just to refresh... from some menu items, I get: the ip (i.e. xxx.xx.xx.xx/category) instead of the domain name (domainname.com/category). Any one knows the solution! So we can close this post also!!

User avatar
mandville
Joomla! Master
Joomla! Master
Posts: 14260
Joined: Mon Mar 20, 2006 1:56 am
Location: The Girly Side of Joomla in Sussex

Re: Joomla showing ip-address on some links instead of domai

Postby mandville » Thu Jul 23, 2015 3:41 pm

delete the alias and resave?
HU2HY- Poor questions = Poor answer
Un requested Help PM's will be reported, added to the foe list and possibly just deleted
{VEL Team Leader}{TM Auditor }{ Showcase & Security forums Moderator}

bond2u
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Jul 18, 2009 6:26 am

Re: Joomla showing ip-address on some links instead of domai

Postby bond2u » Mon Dec 14, 2015 2:32 pm

I am also having this issue with !Joomla 3.4.5.

I am also using a home server and Domain Name through NameCheap with free DNS which forwards my domain name to my Comcast supplied dynamic IP address.

My website appears to change to the IP address almost daily when I am viewing it from the local network - however, I am typing in the url without the IP. Whether or not this is happening from other networks I can't say, but I would believe that it is coming up as an IP simply because the !Joomla cache is holding it as such.

The temporary solution is to clear Joomla's cache from the back-end (Administrator Control Panel > System > Clear Cache and then refresh the front-end page.

I couldn't find any !Joomla mods or plugins that would automatically clear the cache and I'm not enough of an expert to understand why this is happening.

I am working on this and I'll post updates when I can find an answer.

FYI - I am using the full version of the JoomlaArts' JA_Elastica template with the JAT3 cache.

1. I just disableed the JAT3 cache. Extensions > Templates > click on ja_elastica - Default > T3 Options > Cache Mode = Disabled.

2. Then Administrator Control Panel > System > Clear Cache and then refresh the front-end page.

3. Interesting to me, but now when I Control Panel > System > Clear Cache, two items will not delete, they are: _system and com_plugins.

So for now I will logout and see what happens.

mattyhead
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue May 09, 2017 3:37 pm

Re: Joomla showing ip-address on some links instead of domain

Postby mattyhead » Tue May 09, 2017 3:42 pm

In my case, it appears my server was occasionally returning a HTTP_HOST value containing an IP. I was able to fix this by using SERVER_NAME in my libraries/joomla/environment/uri.php. My nginx vhost explicitly defined a server_name, so this was an easy and quick fix for me.


Return to “Search Engine Optimization (Joomla! SEO) in Joomla! 1.5”

Who is online

Users browsing this forum: No registered users and 6 guests