Page 1 of 1

JCE Left Align by Default

Posted: Tue Jul 10, 2007 12:15 am
by Wardrop
How do I set JCE to left align by default? Everytime I create a new article, it's always center aligned by default instead of being left aligned. Another question, how can I have JCE paste as plain text by default (while maintaining line breaks).

Any help is very much appreciated.

Re: JCE Left Align by Default

Posted: Tue Jul 24, 2007 11:25 pm
by matthewhayashida
I think the left align thing is probably in your template. You probably have to go add a align tag to fix it.

Re: JCE Left Align by Default

Posted: Wed Jul 25, 2007 12:15 am
by Wardrop
I've managed to fix it by creating my own little editor .css and making JCE use that instead of the template.css file which i think is used by default. It's good to know someone's viewing these old topics and still willing to give some assistance.

Thanks!

Re: JCE Left Align by Default

Posted: Wed Jul 25, 2007 3:04 am
by matthewhayashida
Your welcome.

Re: JCE Left Align by Default

Posted: Thu May 15, 2008 12:12 am
by Josh Anderson
I've been trying to solve the same issue. I've utilized my own "editor_content.css" stylesheet for JCE to use instead of the template (template.css) stylesheet. But I'm still wondering if there's a way to prevent users from pasting dynamic text into the editor that usually adds style="" and other attributes. Is there a way other than using the special Paste Plain Text button to force the code to be pasted as clean with only line-breaks?

That would simplify my life quite a bit. Thanks.

Re: JCE Left Align by Default

Posted: Tue Jun 16, 2009 3:37 pm
by hanspan
Hello, I have left align everything in my template.css and the editor_template.css but my icons are still centering. Is there anything specific I should pin point to get them to left align?

Re: JCE Left Align by Default

Posted: Tue Sep 15, 2009 1:02 pm
by Jamesmcguire
Hi there: I've just had a similar problem. To verify which part is causing the problems do the following tests:
1. Tried a different WYSIWIG editor: see if the problem persists.
2. Try a different template (one of the default ones): does the problem goes away?

Using this method I was able to establish that the problem was not the editor (the problem persisted even when this was changed).

I contacted the Template providers and explained the problem. They instructed me to remove a CSS style that was being applied to the body.

In this case.... text-align:center;

I hope this helps you sort out the problem

Re: JCE Left Align by Default

Posted: Sun Jul 10, 2011 11:41 pm
by Jaimeji
Simplest fix:

Hit up JCE Administration in the Components menu.
Go to Global Configuration.
Find setting called Editor Style Reset and change it to Yes.

This "forces left aligned, black text on a white background," in other words, case closed for 99% of users.

Best,
Jaimeji

Re: JCE Left Align by Default

Posted: Thu Nov 10, 2011 9:04 pm
by jorgepelaez
Jaimeji wrote:Simplest fix:

Hit up JCE Administration in the Components menu.
Go to Global Configuration.
Find setting called Editor Style Reset and change it to Yes.

This "forces left aligned, black text on a white background," in other words, case closed for 99% of users.

Best,
Jaimeji
Great! Thanks for the tip.