Images upload with wrong permissions

Need help with a WYSIWYG-editor in Joomla! 1.0.x? This is the place to be.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
User avatar
muddauber
Joomla! Ace
Joomla! Ace
Posts: 1503
Joined: Thu Jun 08, 2006 11:26 pm

Images upload with wrong permissions

Postby muddauber » Wed Apr 23, 2008 3:03 am

I'm using Joomla 1.0.15 with WYSIWG Pro ( have tried with other editors and have same problem)

When I upload an image, the image loads with permission 600, which results in me seeing the
FORBIDDEN message in the listing of image when trying to upload image and insert it in
an article.

I have tried all the options on the admin section on server settings, including :
Dont CHMOD new files (use server defaults)
CHMOD new files to: tooltip

I can FTP files with no problem and the permssions default to 644 for images.
I can upload images with the JoomlXplorer 1.6.0, images upload with 755.
I can also go in and change permissions easily, so it is not an ownership problem.

My host says it is a Joomla configuration problem and that there server setting
to not change anything.

This has been buggin me for months. I waste a lot of time using FTP and JoomlXplorer,
as it is much easier to upload and insert images while I'm editing articles.

Any suggestions from you gurus out there would be GREATLY appreciated.
I have this Joomla install on a FreeBSD server running Apache if that makes
any difference.

nixsys
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Jan 24, 2007 6:23 pm

Re: Images upload with wrong permissions

Postby nixsys » Fri Apr 25, 2008 4:22 pm

I have the same problem. All works well during Joomla installation 1.5. I can even upload images to the media library no problems. However, if install a components (no matter which) then files including images are set to CHMOD 600. The component works fine but if I want to see the component nice little icons then I need to manually change the CHMOD.
For example I installed expose4 and the installation went ok, no warning messages but all the components images were CHMOD 600. I change the permission using FTP and fix the problem as I explained the proble now is that every time I upload a picture using expose4 back-end the files keep changing the files permission, thus I can't see them on the gallery, unless I change the permission manually. Please some one help....

nixsys
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Jan 24, 2007 6:23 pm

Re: Images upload with wrong permissions

Postby nixsys » Fri Apr 25, 2008 5:59 pm

Didn't sleep on this one but found the solution. I am using mod_suphp since I use plesk and mod_php is cousing the problem. In order to fix it you need to change :

etc/suphp.config file
Changed unmask from 0077 to 0022

and works....

Mixelplux
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Nov 21, 2008 6:01 pm

Re: Images upload with wrong permissions

Postby Mixelplux » Fri Nov 21, 2008 6:05 pm

Ok, here is what I found out. The server has default settings, which usually is setup to 600. I wouldn't recommend changing that unless you know what you are doing. However, Joomla can change chmod for files and directories on creation.

Go to: Site -> Global Configuration -> Server tab. On that page you can allow Joomla to set permissions for files and folders created within Joomla. That should fix it.

voglar
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Thu Jan 22, 2009 2:50 pm

Re: Images upload with wrong permissions

Postby voglar » Sat Feb 07, 2009 9:41 pm

I cant't find this "allow Joomla to set permissions" in joomla 1.5

User avatar
tusker
Joomla! Ace
Joomla! Ace
Posts: 1075
Joined: Tue Dec 25, 2007 2:15 pm
Location: Baroda - India
Contact:

Re: Images upload with wrong permissions

Postby tusker » Sat Feb 07, 2009 10:00 pm

Can use some editor like JCE it uploads, edits and directly adds images to your articles from your back end without needing any ftp or component access. Hope this helps.
ONE WORLD OPEN WORLD - WAR TODAY GIVE PEACE A CHANCE
http://indiavoice.info - India News & Information Portal
http://indiadaily.indiavoice.info - India Daily Infotainment

(Powered by Joomla!)

webdesignhelper
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Wed Sep 06, 2006 4:49 pm

Re: Images upload with wrong permissions

Postby webdesignhelper » Mon Aug 24, 2009 9:27 am

"allow Joomla to set permissions" is not in joomla 1.5, so how do we set files to be uploaded with 644 and not 600 as it is clashing with suPHP ?

Macer
Joomla! Apprentice
Joomla! Apprentice
Posts: 32
Joined: Thu Mar 29, 2007 10:15 pm

Re: Images upload with wrong permissions

Postby Macer » Tue Oct 27, 2009 11:30 am

Any solution found on this for joomla 1.5.x?

resp
Joomla! Apprentice
Joomla! Apprentice
Posts: 23
Joined: Tue Sep 21, 2010 1:16 pm

Re: Images upload with wrong permissions

Postby resp » Mon Nov 15, 2010 12:02 pm

I got this problem aswell, when I create folders via Joomla its set to 755 but when uploading images they are 600. I use latest version 1.5. bump this and see if anyone have a solution.
:geek:

hanyelharby
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Dec 22, 2010 3:15 pm

Re: Images upload with wrong permissions

Postby hanyelharby » Wed Dec 22, 2010 3:25 pm

hi all ,

I Have Found One Answer which is After creating the folder change it permission to 0755
as
if (!file_exists('images_project')) {

mkdir('images_project', 0755);

}
chmod("images_project', 0755);

and after uploading the image you must change it's permission to 0644
as
$newimage="images_project/hanyharby.jpg";

chmod($newimage, 0644);

if there is any question don't hesitate to email me @
(hany_dev@yahoo.com)

budiperkasa
Joomla! Intern
Joomla! Intern
Posts: 84
Joined: Sat Apr 21, 2012 7:02 am
Location: Indonesia
Contact:

Re: Images upload with wrong permissions

Postby budiperkasa » Mon May 07, 2012 1:55 pm

hanyelharby wrote:hi all ,

I Have Found One Answer which is After creating the folder change it permission to 0755
as
if (!file_exists('images_project')) {

mkdir('images_project', 0755);

}
chmod("images_project', 0755);

and after uploading the image you must change it's permission to 0644
as
$newimage="images_project/hanyharby.jpg";

chmod($newimage, 0644);

if there is any question don't hesitate to email me @
(hany_dev@yahoo.com)


If I not wrong, the strings that you have writes above is not PHP, Javascript or other language programming, it's just "if else" ordinary condition, my other suggestion is try to use .htaccess file to control access permission to your site directory.

blades
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Dec 27, 2011 4:43 pm

Re: Images upload with wrong permissions

Postby blades » Mon May 06, 2013 8:31 pm

nixsys wrote:Didn't sleep on this one but found the solution. I am using mod_suphp since I use plesk and mod_php is cousing the problem. In order to fix it you need to change :

etc/suphp.config file
Changed unmask from 0077 to 0022

and works....

yes,this solved the problem.thank you
suphp.conf is under
/etc/suphp/suphp.conf


Return to “WYSIWYG Editors - 1.0.x”

Who is online

Users browsing this forum: No registered users and 2 guests