Page 1 of 1

No submit new article icon appears at blog category.

Posted: Sun Jan 09, 2011 7:46 am
by hanjimail
Joomla ver.RC1(Version 1.6.0)

PHP Built On: FreeBSD www1186.sakura.ne.jp 7.1-RELEASE-p15 FreeBSD 7.1-RELEASE-p15 #10
Database Version: 5.1.51-log
Database Collation: utf8_general_ci
PHP Version: 5.2.14
Web Server: Apache/1.3.42 (Unix) mod_ssl/2.8.31 OpenSSL/0.9.8e
WebServer to PHP Interface: cgi
Joomla! Version: Joomla! 1.6.0 RC1 [ Onward ] 14-Dec-2010 23:00 GMT
User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; ja; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 GTB7.1

Bug Description:

A submit-article-icon does not appear when a category is the blog category.
When I change the blog category into the category list, the submit-article-icon does appear in the page.

Steps to replicate:

1) Create a new category A and assign to A-menu in Main Menu.
2) Create a new user-group C under a Group-parent: registered.
3) Create a new user B as a registered user and assign to C user-group.
4) Go to the new category A and set Category permissions on C user-group as follows: New Setting (All action items set inherited to allowed)
5) Done.


I would like user B (registered member status) to create, delete, edit, edit-state, edit own at a particular menu category.

Re: No submit new article icon appears at blog category.

Posted: Tue Jan 11, 2011 3:52 am
by hanjimail
I tried the same thing at Author status and I got the same result in Joomla1.5.22
So, this is parts of Joomla specifications, I assume.

the submit-article-icon does not appear in the blog category page when you log in as the author, but in table category list it does appear.

Re: No submit new article icon appears at blog category.

Posted: Wed Jan 12, 2011 4:16 pm
by mcsmom
Correct. that is the standard, the submit new is on the list layouts. You could add it with an override if desired.

Re: No submit new article icon appears at blog category.

Posted: Wed Aug 01, 2012 7:34 pm
by clancyw
mcsmom, (or anyone)
Can you tell me how to "add it with an override if desired."? I *really* would like to have that link present in blog layout, but cannot find any information on how to do it. Thanks!

Re: No submit new article icon appears at blog category.

Posted: Thu Jun 06, 2013 8:18 am
by Hexagor
I have the opposite problem: My client wants a category list, but they don't want the 'new' button for new article. How do I get rid of it or make it so that only they can add articles? Because right now everybody can add a new article. I've allready tried to change the permission of 'public' but that didn't help.

Please tell me step by step how to fix this.
Thanks.

Re: No submit new article icon appears at blog category.

Posted: Mon Aug 26, 2013 3:20 pm
by wbell
Hexagor wrote:I have the opposite problem: My client wants a category list, but they don't want the 'new' button for new article. How do I get rid of it or make it so that only they can add articles? Because right now everybody can add a new article. I've allready tried to change the permission of 'public' but that didn't help.
Please tell me step by step how to fix this.
Thanks.
There are a couple ways to do what you are asking...

Remove Icon With An Override

Copy The File

Copy the default.php file:

Code: Select all

/components/com_content/views/category/tmpl/default.php
to the the html folder of your template (NOTE: Depending on your template, this file may already exist. If so, you should NOT need to re-copy):

Code: Select all

/templates/<yourTemplate>/html/com_content/category/default.php

Edit The Copied File

Around Line 26, you should see and comment out the following:

Code: Select all

<?php if ($this->access->canEdit || $this->access->canEditOwn) :
        echo JHTML::_('icon.create', $this->category  , $this->params, $this->access);
endif; ?>
Once edited and saved, the icon should no longer show on any Category Lists.




Dynamically Remove Icon With Core "Hack" *

Edit The XML File

Open the following file with your favorite text editor

Code: Select all

components/com_content/views/category/tmpl/default.xml
and add the following code into the parameters section of the XML file:

Code: Select all

<param name="show_new_icon" type="radio" default="1" label="Show New Icon" description="Show/Hide the new article icon">
        <option value="0">Hide</option>
        <option value="1">Show</option>
</param>
(NOTE: If you don't want the default to be show the numbers, change default="1" to default="0" in the param line.)



Edit The PHP File

Open the following file with your favorite text editor **:

Code: Select all

components/com_content/views/category/tmpl/default.php
Around Line 26, you should see and edit the following:

Code: Select all

<?php if ($this->access->canEdit || $this->access->canEditOwn) :
        echo JHTML::_('icon.create', $this->category  , $this->params, $this->access);
endif; ?>
to

Code: Select all

<?php if ($this->params->get('show_new_icon')) : ?>
<?php if ($this->access->canEdit || $this->access->canEditOwn) :
        echo JHTML::_('icon.create', $this->category  , $this->params, $this->access);
endif; ?>
<?php endif; ?>
Once saved, this will give you a new backend option called Show New Icon which will allow you to either show or hide the icon as you please.

* (NOTE: Core "hacks" have the potential to be overwritten upon Joomla upgrades/updates.)
** (NOTE: If your template has a "default.php" file in the "/templates/<yourTemplate>/html/com_content/category/default.php" location, you will need to edit this file, since it overrides the core Joomla file.)

Re: No submit new article icon appears at blog category.

Posted: Tue Aug 27, 2013 2:38 am
by mcsmom
Are you saying the public can submit and article? That is actually specifically blocked by the code and the public should never see a create new icon. Can you please explain more about what you are seeing?

Re: No submit new article icon appears at blog category.

Posted: Sun Nov 30, 2014 12:15 am
by autogadget555
I found a very simple fix for hidding the "NEW" button in J2.5. Just go to Global Configuration>Permissions and here set in Public - Create Field to Denied. Works for me!