Unable to send mail with Joomla

The support for Joomla 2.5 ended on December 31, 2014. Possible bugs in Joomla 2.5 will not be patched anymore. This forum has been closed. Please update your website to Joomla 3.x

Moderator: ooffick

Forum rules
Please use the official Bug Tracker to report a bug: https://issues.joomla.org
Locked
Hotbirdx
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Mar 09, 2013 10:16 am

Unable to send mail with Joomla

Post by Hotbirdx » Sat Mar 09, 2013 10:43 am

I Installed Joomla 2.5.9 on a commercial webhoster and used the default email settings (PHP mail). When I created a new user I got a warning: "Could not instantiate mail function.". To test I also tried to install Joomla 3.0.3 but the result is the same.

If I use a self created PHP script to send e-mail at the same webhoster it works. This simple PHP script only consist of the mail() function to send mail. So my final conclusion was it had something to do with the Joomla scripts and the (security) settings of the email servers of my webhoster. Support of the webhoster dit not bring me any further (until now).

Searching in the Joomla scripts I noticed that the script in: /libraries/phpmailer/phpmailer.php
was supposed to send the emails. In the header of this script I noticed the website of the developer(s) of the script: https://code.google.com/a/apache-extras ... phpmailer/
I downloaded a newer version (5.2.4) of the phpmailer.php script (renamed class.phpmailer.php to phpmailer.php) and overwrite the older version (5.2.1) of the script: /libraries/phpmailer/phpmailer.php

That did the trick; e-mails were send from that moment. In my search for a solution I noticed that its a common problem, so maybe Joomla could integrate the new version of this script into their release?
For now I hope my solution can help others...

Regards,
Hotbirdx.

User avatar
gipester
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Wed Nov 01, 2006 9:01 pm
Location: Colorado Springs, CO, USA

Re: Unable to send mail with Joomla

Post by gipester » Mon Apr 01, 2013 9:57 pm

I tried this fix, replaced the 5.2.1 version with the 5.2.4 version. I'm still having the same problem. Any suggestions?


Locked

Return to “Joomla! 2.5 Bug Reporting”