Possible bug with languagefilter plugin plus voting

The support for Joomla 2.5 ended on December 31, 2014. Possible bugs in Joomla 2.5 will not be patched anymore. This forum has been closed. Please update your website to Joomla 3.x

Moderator: ooffick

Forum rules
Please use the official Bug Tracker to report a bug: https://issues.joomla.org
Locked
Richard67
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 143
Joined: Fri Sep 16, 2011 6:13 pm
Location: Germany

Possible bug with languagefilter plugin plus voting

Post by Richard67 » Sun Jul 07, 2013 2:46 pm

Hello,
I've discovered an issue which is very likely a bug, but I cannot report it on joomlacode.org because registration does not work there.
On a multilanguage site with menu associations, the languagefilter does not create alternate language header links for articles view pages having the show votes option set to on.
The reason is that a parameter "hitcount=0" is added to the request URL if show votes is on, so the test if $current_link == $active_link in languagefilter.php fails, and no alternate language links are added to the header.
I wanted to report this on joomlacode, but when I register and then follow the activation link from the registration email, then I get a "user could not be reached" error on login.
Please can some developer check and inform the languagefilter specialists?
And maybe let the joomlacode guys know about my registration problem, or tell me an email address where I could write to?
Thanks in advance.

Richard67
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 143
Joined: Fri Sep 16, 2011 6:13 pm
Location: Germany

Re: Possible bug with languagefilter plugin plus voting

Post by Richard67 » Sun Jul 07, 2013 2:58 pm

P.S.: It seems that is is a problem in general with url parameters added to the request, e.g. for paging on a page for an extension (e.g. phocaguestbook adds a "?start=5" to the url). The languagefilter does not add alternate language header links if the request url is not equal to the active menu url ($current_link and $active_link in languagefilter.php), so any parameter added to the request url makes it fail. Maybe the language filter should remove all parameters except maybe "id=" and "lang=" before doing the test?

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18650
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Possible bug with languagefilter plugin plus voting

Post by infograf768 » Sun Jul 07, 2013 4:43 pm

1. Voting works here OK. ?hitcount =0 is added to the url and clicking on the flag nicely displays the associated menu item.

2/. I confirm that the rel=alternate links in the <head> do not display for a single article menu item, vote on or off though. Can you confirm this when vote is off?
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

Richard67
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 143
Joined: Fri Sep 16, 2011 6:13 pm
Location: Germany

Re: Possible bug with languagefilter plugin plus voting

Post by Richard67 » Sun Jul 07, 2013 5:32 pm

Hi infograf768,

when voting is off then I have the rel=alternate links in the <head>.

See e.g. http://www.richard-fath.de/music/recordings/fade.html or any other below menu items music/stories, music/photos or music/recordings.

An example for other URL parameters which cause the missing header links is:
http://www.richard-fath.de/guestbook.html?start=5, which is the 2nd page of my guestbook. When toggling the language, it results in the first page of the guestbook being shown in the new language, so the language switcher seems to ignore the start=5 parameter.

But the language filter plugin creates the header links for the other languages only if the first page of the guestbook is shown (no parameter), it does not create links for the second page (parameter).

From my point of view the links should work as well as the language switching does, means if there is some parameter like "?page=x" or "?start=y" or "?hitcount=z", it should be ignored.

Maybe any parameters should be ignored, but I am not sure if this would be working without SEF = on.

So maybe standard Joomla parameters like article IDs or the "lang" parameter should not be ignored?

I don't know, I am really not the Joomla coding guru.

But at least I would be interested in what the language filter developers think how the behavior should be.

Richard67
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 143
Joined: Fri Sep 16, 2011 6:13 pm
Location: Germany

Re: Possible bug with languagefilter plugin plus voting

Post by Richard67 » Sat Jun 21, 2014 2:35 pm

Hello,
meanwhile I have solved my issue.
After I have changed the "Item associations" parameter of the language filter plugin to "No", saved the plugin settings, then changed back to "Yes" and saved again, I have the alternate language header links on all my pages having menu item or content item associations. Disabling and enabling the plugin was not sufficient, I really had to change the setting and save it to the database to get it working.


Locked

Return to “Joomla! 2.5 Bug Reporting”