problem with ignite gallery after update to Joomla 2.5.25

The support for Joomla 2.5 ended on December 31, 2014. Possible bugs in Joomla 2.5 will not be patched anymore. This forum has been closed. Please update your website to Joomla 3.x

Moderator: ooffick

Forum rules
Please use the official Bug Tracker to report a bug: https://issues.joomla.org
Locked
barback
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Sat Feb 10, 2007 11:16 pm

problem with ignite gallery after update to Joomla 2.5.25

Post by barback » Sun Sep 28, 2014 2:37 am

After the update, I get a blank page when attempting to manage images for a gallery.

I don't know if there is a specific way to roll back to 2.5.24 -- a list of files that were changed for 2.5.25?

Thanks.

jgress-
Joomla! Guru
Joomla! Guru
Posts: 957
Joined: Thu Sep 24, 2009 5:40 pm
Location: Santa Cruz, CA, USA

Re: problem with ignite gallery after update to Joomla 2.5.2

Post by jgress- » Sun Sep 28, 2014 3:54 am

did you take a backup before going to 2.5.25? if so, you can roll back. or attempt to have your host roll back.

did you attempt to talk to support at ignite gallery about it? they are usually pretty good about responding and helping when i've needed to talk to them in the past.

:) jenn
Co-author Using Joomla, Second Edition (migration/upgrade included) http://www.usingjoomlabook.com
Find a Joomla User Group (JUG) near you http://community.joomla.org/user-groups.html

iextensions
I've been banned!
Posts: 1498
Joined: Fri Jul 12, 2013 5:37 pm
Contact:

Re: problem with ignite gallery after update to Joomla 2.5.2

Post by iextensions » Sun Sep 28, 2014 3:58 am

I think you can set error_reporting to maximum and see error message.
Then change and edit bug, maybe lost function or class in new version.

jgress-
Joomla! Guru
Joomla! Guru
Posts: 957
Joined: Thu Sep 24, 2009 5:40 pm
Location: Santa Cruz, CA, USA

Re: problem with ignite gallery after update to Joomla 2.5.2

Post by jgress- » Sun Sep 28, 2014 3:59 am

good call, iextensions!
Co-author Using Joomla, Second Edition (migration/upgrade included) http://www.usingjoomlabook.com
Find a Joomla User Group (JUG) near you http://community.joomla.org/user-groups.html

iextensions
I've been banned!
Posts: 1498
Joined: Fri Jul 12, 2013 5:37 pm
Contact:

Re: problem with ignite gallery after update to Joomla 2.5.2

Post by iextensions » Sun Sep 28, 2014 4:14 am

Hi Jgress, I must also fix some bugs as same this case. Maybe that is the path, class or any variable,..... Because fix one extension will be faster when we have updated all joomla site.
That is coding so hope this helps.

jgress-
Joomla! Guru
Joomla! Guru
Posts: 957
Joined: Thu Sep 24, 2009 5:40 pm
Location: Santa Cruz, CA, USA

Re: problem with ignite gallery after update to Joomla 2.5.2

Post by jgress- » Sun Sep 28, 2014 4:18 am

hi iextensions, i'm glad you fix bugs. i'm learning. and i'm grateful for you and others that do. thank you. :)
Co-author Using Joomla, Second Edition (migration/upgrade included) http://www.usingjoomlabook.com
Find a Joomla User Group (JUG) near you http://community.joomla.org/user-groups.html

iextensions
I've been banned!
Posts: 1498
Joined: Fri Jul 12, 2013 5:37 pm
Contact:

Re: problem with ignite gallery after update to Joomla 2.5.2

Post by iextensions » Sun Sep 28, 2014 4:23 am

Thanks Jgress, nice to meet you. Your site "usingjoomlabook" very nice.

jgress-
Joomla! Guru
Joomla! Guru
Posts: 957
Joined: Thu Sep 24, 2009 5:40 pm
Location: Santa Cruz, CA, USA

Re: problem with ignite gallery after update to Joomla 2.5.2

Post by jgress- » Sun Sep 28, 2014 4:25 am

nice to meet you too, iextensions. always a pleasure seeing you help people on the forums. thank you for the nice compliment on the site. it was the site i used in the book as the example for migrating from 1.5 to 3.x. your sites look good too! :) jenn
Co-author Using Joomla, Second Edition (migration/upgrade included) http://www.usingjoomlabook.com
Find a Joomla User Group (JUG) near you http://community.joomla.org/user-groups.html

barback
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Sat Feb 10, 2007 11:16 pm

Re: problem with ignite gallery after update to Joomla 2.5.2

Post by barback » Sun Sep 28, 2014 4:32 am

Thanks for the tip on error-reporting.
Indeed it reported this:
Class 'Jform' not found in /home/monadnoc/public_html/administrator/components/com_igallery/views/images/view.html.php on line 74

Now.... what do I do about it? btw, I have contacted Ignite folks.

jgress-
Joomla! Guru
Joomla! Guru
Posts: 957
Joined: Thu Sep 24, 2009 5:40 pm
Location: Santa Cruz, CA, USA

Re: problem with ignite gallery after update to Joomla 2.5.2

Post by jgress- » Sun Sep 28, 2014 4:37 am

i personally would do what you just did...contact ignite. i so wish i was a coder.

you can check to make sure you have the latest version of ignite loaded. perhaps a newer updated version would resolve it.

of course, you have to backup first, right?! right! backup before you do anything. and after too. (i'm a little excessive and paranoid about having backups. i figure that's a good thing.)

maybe iextensions will have another idea. love coders. ;) jenn
Co-author Using Joomla, Second Edition (migration/upgrade included) http://www.usingjoomlabook.com
Find a Joomla User Group (JUG) near you http://community.joomla.org/user-groups.html

iextensions
I've been banned!
Posts: 1498
Joined: Fri Jul 12, 2013 5:37 pm
Contact:

Re: problem with ignite gallery after update to Joomla 2.5.2

Post by iextensions » Sun Sep 28, 2014 5:45 am

that is new version of joomla and com_igallery still uses old class.
You must check "change log" from igallery and see the change. Or you need to edit in error file if you can know coding.

johncousino
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sat Aug 30, 2014 7:02 am

Re: problem with ignite gallery after update to Joomla 2.5.2

Post by johncousino » Sun Oct 26, 2014 9:59 pm

I have the same problem, Hadn't managed a gallery for a while.
I have emailed Ignite support but have not yet heard from them.
Can you let me know if you have found a fix for this.
Thank you

jgress-
Joomla! Guru
Joomla! Guru
Posts: 957
Joined: Thu Sep 24, 2009 5:40 pm
Location: Santa Cruz, CA, USA

Re: problem with ignite gallery after update to Joomla 2.5.2

Post by jgress- » Sun Oct 26, 2014 10:20 pm

bummer that barback (the OP) didn't post back his fix. maybe he will pipe up. but look for an update to ignite and contact the developer.

barback, what fix did you find?
Co-author Using Joomla, Second Edition (migration/upgrade included) http://www.usingjoomlabook.com
Find a Joomla User Group (JUG) near you http://community.joomla.org/user-groups.html

johncousino
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sat Aug 30, 2014 7:02 am

Re: problem with ignite gallery after update to Joomla 2.5.2

Post by johncousino » Sun Oct 26, 2014 11:04 pm

Thank you,
Ignite Gallery Support just got back to me with a solution.

To resolve this issue, please update the gallery, or edit:

administrator/components/com_igallery/views/images/view.html.php on line 74 change Jform to JForm


Worked!! :)
Thanks again.

jgress-
Joomla! Guru
Joomla! Guru
Posts: 957
Joined: Thu Sep 24, 2009 5:40 pm
Location: Santa Cruz, CA, USA

Re: problem with ignite gallery after update to Joomla 2.5.2

Post by jgress- » Sun Oct 26, 2014 11:10 pm

yay!! well done and thanks for reporting back. :) jenn
Co-author Using Joomla, Second Edition (migration/upgrade included) http://www.usingjoomlabook.com
Find a Joomla User Group (JUG) near you http://community.joomla.org/user-groups.html

barback
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Sat Feb 10, 2007 11:16 pm

Re: problem with ignite gallery after update to Joomla 2.5.2

Post by barback » Mon Oct 27, 2014 10:23 pm

johncousino wrote: To resolve this issue, please update the gallery, or edit:

administrator/components/com_igallery/views/images/view.html.php on line 74 change Jform to JForm
This was the solution I got back from ignite gallery -- it was crucial for me, as I couldn't just update, we had customized ignite in other ways.


Locked

Return to “Joomla! 2.5 Bug Reporting”