¿Aún usas Joomla 1.6 o 1.7? Lee esto URGENTEMENTE

Para cualquier duda sobre Joomla! 2.5 que no tenga cabida en alguno de los foros de más abajo. Si usas Joomla 1.6 o 1.7, también puedes preguntar aquí, pero lee esto antes -> http://forum.joomla.org/viewtopic.php?p=2807388

Moderators: hefesto, carcam

Locked
User avatar
hefesto
Joomla! Hero
Joomla! Hero
Posts: 2569
Joined: Fri Jan 20, 2006 12:37 am
Location: Seville - Spain
Contact:

¿Aún usas Joomla 1.6 o 1.7? Lee esto URGENTEMENTE

Post by hefesto » Sun May 13, 2012 10:55 am

Las versiones 1.6 y 1.7 están obsoletas, y usarlas supone un grave peligro de seguridad, pues contienen agujeros graves que son de dominio público y que podrían utilizarse fácilmente para tomar el control de tu sitio.

Joomla 1.6 alcanzó oficialmente el fin de su vida útil en agosto de 2011. Eso significa que desde entonces no se ha liberado ningún parche de seguridad para esta versión, pues el desarrollo continuó con la 1.7. Esto significa que ninguno de los problemas de seguridad detectados desde esa fecha, tanto en Joomla 1.7 como en la 2.5, ha sido resuelto. Usar la versión 1.6 es muy peligroso para tu sitio.

Joomla 1.7 alcanzó oficialmente el fin de su vida útil en febrero de 2012. Como ocurre con la 1.6, desde esa fecha no se ha liberado ningún parche de seguridad para esta versión.

A lo dicho anteriormente, hay que unir la enorme cantidad de bugs que han ido resolviéndose con las sucesivas versiones de la 1.7 y la 2.5, bugs que afectarán a tu sitio si no tienes la última versión (en el momento de escribir esto, la 2.5.7).

Y por último, hay que recordar que las versiones 2.5.2 y 2.5.3 corregían fallos de seguridad MUY graves que afectaban a todas las versiones de la 1.6.x y la 1.7.x, errores que permiten atacar sitios que usen estas versiones de manera bastante sencilla. Puedes consultar una lista de los problemas de seguridad resueltos en el core de Joomla en el siguiente enlace:

http://developer.joomla.org/security/

Por tanto, si usas las versiones 1.6 o 1.7 lo primero que debes hacer es buscar el tiempo y los recursos necesarios para actualizar a la 2.5 cuanto antes. Dependiendo de la complejidad de tu sitio, esto puede ser tan sencillo como simplemente acceder al gestor de extensiones y seleccionar la versión correcta en la pestaña "actualizar", o bien puede ser un poco más complicado si tu plantilla o alguna de tus extensiones fundamentales incluye algún elemento que requiere ser actualizado para funcionar en la 2.5. En cualquier caso, el proceso no será excesivamente complicado (ni de lejos tan complicado como migrar desde la 1.5), y teniendo la precaución de tomar una copia de seguridad completa del sitio antes, tener tu sitio actualizado y seguro no te llevará demasiado tiempo.
Spanish forum local moderator
Twitter: @isidrobaq
Comunidad Joomla de España: https://joomlaes.org
NO atiendo peticiones privadas de soporte. Por favor, pregunta en los foros.

Locked

Return to “Joomla! 2.5”