2.5.22: not permitted to use link to directly access page

General questions relating to Joomla! 2.5. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5. There are other boards for more specific help on Joomla! features and extensions.
Post Reply
kelly s79+
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Jan 26, 2021 11:25 am

2.5.22: not permitted to use link to directly access page

Post by kelly s79+ » Tue Jan 26, 2021 3:18 pm

I have recently adopted responsibility for our companies website as the creator no longer works in web design.
We have version 2.5.22 and I am experiencing a few problems. when trying to make changes I am getting the message. "you are not permitted to use that link to directly access that page".
I have tried to update the version that I access online only through my web browser but 'i'm unable to, it also states my zoomla is up to date.. can anyone help please?

Many thanks
Last edited by toivo on Tue Jan 26, 2021 3:47 pm, edited 1 time in total.
Reason: mod note: moved from 3.x General Questions, retitled

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 6466
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: 2.5.22: not permitted to use link to directly access page

Post by AMurray » Tue Jan 26, 2021 10:01 pm

Note: Joomla 2.5.x is at End of Life in since 2014.

Please provide the FPA report results. We need to examine the details of your joomla system and hosting
environment. Refer to https://forumpostassistant.github.io/docs/.
I have tried to update the version that I access online only through my web browser but I'm unable to. It also states my Joomla is up to date. Can anyone help please?
What method are you trying to update Joomla? It is certainly not at the latest version; the current release is 3.9.24, and in the 2.5.x series, the last version (seven years ago) was 2.5.28.

Joomla 2.5.x should allow you to install through the Extension manager (not the recommended method, but can still be done that way).

Download 2.5.x versions available here: Download ver 2.5.x. Make sure you backup your site first before doing the updates. Refer to instructions for both methods: Updating Joomla (Update Method) or Updating Joomla (Install Method)

I don't know about the "denied access" messages: (possibly something to do with the browser 'session'). Are you closing your browser without actually logging out of the site first? Are you logging in with (Super) Administrator access (or other access level permitted to make content changes)?

I would advise taking steps towards 3.9.x as it is the current supported version by the Joomla (volunteer) community. This is advisable for security purposes too.

Refer Migrating 2.5 to 3.x for instructions.
Regards,
--------------------------------------------------------------
A Murray
Help you I can, yes!. Post your question, you should. Keep it on topic you must!
Use the Forc....Forum Post Assistant my young Padawan!


Post Reply

Return to “General Questions/New to Joomla! 2.5”