?view=featured and ?layout=blog in my urls

General questions relating to Joomla! 2.5. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5. There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Locked
User avatar
dunxmax
Joomla! Intern
Joomla! Intern
Posts: 56
Joined: Mon Sep 21, 2009 9:33 am
Location: UK
Contact:

?view=featured and ?layout=blog in my urls

Post by dunxmax » Tue Mar 13, 2012 1:02 pm

Hi,

I'm determined to not give up with this problem.

I've been trying to get to the bottom of an url issue for a couple of days now - I posted in the SEO area, AceSEF is being suggested as a solution I haven't tried it yet, but the problem seems like it is fundamental and shouldn't need to be fixed by adding a third party extension.

The issue is this:
1) when I click on a menu link which is a catergory blog item Joomla is adding ?layout=blog to the end of the url.

so instead of looking like this: myurl.html
it looks like this myurl.html?layout=blog

2) when I click back to my home page joomla is adding ?view=featured to the end of the url.

so instead of looking like this: myurl.html
it looks like this myurl.html?view=featured

I have recently upgraded the site from 1.5 - 2.5.2.

When I type the url of each page all the pages are being loaded, eg myurl.html (without the ?xxx=xxx) so its not such a big issue, but it doesn't seem correct that when I click through the site ?xxx=xxx is being added to the urls. I can't figure out if its something that I am missing and/or its to do with using my own template or if its a Joomla bug.

I did find a similar problem which lead me to this bug fix, but it seems to refer to links from within articles creating a similar issue: http://joomlacode.org/gf/project/joomla ... m_id=28150

When I checked my installation of Joomla it seems that the above fix has already been applied but its not fixed the problem I'm getting.

The site I am upgrading is only a small site and I can probably live with the issue, but its becoming a bit of an obsession as I want to understand what is causing the problem.

Although after 3 years of using Joomla my php knowledge is getting better but I still do not have the knowledge to work out if this is a bug or is something I have done wrong.

Help, anyone?
The more we learn the less we know!

http://www.aquamandesign.co.uk
Committed to the Joomla way of life, based in the UK.

User avatar
dunxmax
Joomla! Intern
Joomla! Intern
Posts: 56
Joined: Mon Sep 21, 2009 9:33 am
Location: UK
Contact:

Re: ?view=featured and ?layout=blog in my urls

Post by dunxmax » Mon Mar 19, 2012 4:02 pm

Hi all,

I'm guessing by the lack of reply I stumped you all on this one - well I didn't give up and have spent the day working out what was causing the issue.

At first I thought it was due to the upgrade from 1.5-2.5 using spupgrade - I'd never used it before and figured I'd not read the instructions properly. So I did a completely new install and decided to transfer all content manually - its not a big site!

All was going well until I realised my original problem had returned, in that ?view=featured and ?layout=blog was again getting added to the end of my urls.

Retraced my steps and came to the conclusion that a module I had installed called extended menu was causing the problem. Unpublished it and replaced it with the standard main menu - problem disappeared urls back to normal.

I took a quick look through the parameters of the module couldn't see a setting to stop it adding stuff to the end of my urls.

I tried a different drop down menu and the problem didn't return.

Conclusion: the module was causing the issue.

;)
The more we learn the less we know!

http://www.aquamandesign.co.uk
Committed to the Joomla way of life, based in the UK.

demonich
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat May 25, 2013 5:05 am

Re: ?view=featured and ?layout=blog in my urls

Post by demonich » Sat May 25, 2013 5:11 am

Hi.

Faced a likely problem with Joomla 3.
rel canonical attribute on a home page had an addition - ?view=featured
so search engine robots couldnt index my home page.

Salvation:
in menu - in your main menu change the type from FEATURED ARTICLES to CHOSEN ARTICLE and the problem will go away.

Link to view - http://www.joomlaseo.ru/

tarik916
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Fri May 04, 2007 5:30 pm

Re: ?view=featured and ?layout=blog in my urls

Post by tarik916 » Thu May 30, 2013 3:23 pm

I am also using the extended menu and really like the css class control that it gives me, so I spent a little time browsing the code. A quick fix is to add a php string replacement just after the link output.

I use the "Tree List" menu style option, so the file I edited was list.menuview.class.php

Around line 58, I found:

Code: Select all

$linkOutput = $this->mosGetMenuLink($menuNode, $level, $this->params, $itemHierarchy);
Just after that, I added:

Code: Select all

//custom code to remove parameter
$linkOutput = str_replace('?view=featured','',$linkOutput);
This removed the parameter from the URL output.

I hope this helps!

SEMaster
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 185
Joined: Thu Apr 25, 2013 7:56 pm
Contact:

Re: ?view=featured and ?layout=blog in my urls

Post by SEMaster » Thu May 30, 2013 11:30 pm

Try changing your fratured articles on your menu to choosen artice. That should fix it. Good luck!

619mikenstein
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Jun 01, 2013 7:57 pm

Re: ?view=featured and ?layout=blog in my urls

Post by 619mikenstein » Sat Jun 01, 2013 8:15 pm

/?view=featured

I'm not seeing "view choosen". These are the options I see for articles:

Archived Articles
Single Article
List All Categories
Category Blog
Category List
Featured Articles
Create Article

Should I do category list?


Locked

Return to “General Questions/New to Joomla! 2.5”