Problem with 310 error when enabling ssl on admin section

General questions relating to Joomla! 2.5. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5. There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Locked
Justin21
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Jul 15, 2011 4:33 am

Problem with 310 error when enabling ssl on admin section

Post by Justin21 » Tue Sep 18, 2012 11:16 pm

Good afternoon,
Every time i enable ssl on the admin section of Joomla. I brakes the site and gives me a Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects. I can type in the https and it works fine but when ever i activate it it brakes.
Have anyone seen this before or know what is casing this?
Thanks
Justin

 
User avatar
chetanmadaan
Joomla! Ace
Joomla! Ace
Posts: 1553
Joined: Sun Feb 10, 2008 1:37 pm
Location: Little Office
Contact:

Re: Problem with 310 error when enabling ssl on admin sectio

Post by chetanmadaan » Tue Sep 18, 2012 11:39 pm

do you have any kind of redirection turned on in your Joomla .htaccess to redirect non www users to www. or something like that?
Chetan Madaan - JM-Experts
http://www.Jm-Experts.com

Justin21
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Jul 15, 2011 4:33 am

Re: Problem with 310 error when enabling ssl on admin sectio

Post by Justin21 » Thu Sep 20, 2012 10:50 pm

So the problem is that.
Network Solutions® uses a proxy SSL this does not allow the use of server-side variables to detect HTTPS (secure). All server-side coding will always detect HTTP (non-secure), and for programs that attempt to redirect non-secure connections (http://) to a secure connection (https://) will result in an infinite loop and server error after 30 seconds.
and this give this little code snippet

Code: Select all

<script language="javascript">
if (document.location.protocol != "https:")
{
document.location.href = "https://subdomain.yourdomain.com" + document.location.pathname;
};
</script>
This works fine except for all the connects to like ssl style sheets and js files are still referenced over http not https is there any javascript that will change all references to use ssl or any other Solutions?

 

Locked

Return to “General Questions/New to Joomla! 2.5”