HELP! 2.5.8 Administrator blank screen!

Joomla versions 2.5, 1.7 and 1.6 are all end-of-life since December 31st 2014 and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
whamprod
Joomla! Intern
Joomla! Intern
Posts: 67
Joined: Tue Jun 17, 2008 9:18 pm

HELP! 2.5.8 Administrator blank screen!

Post by whamprod » Fri Nov 09, 2012 8:41 pm

I just updated from 2.5.7 to 2.5.8 today, using the automated updater in the Administrator, and now when I try to login at domain.com/administrator, all I see is a white screen. I am in deep trouble here.

Also, when I go to my home page on the front end, only the header and top menu are displayed. everything below the top menu bar is a blank white page.

If I click on one the menu links, those page will load, but the home page is blank except for the header and menu.

HELP!!!

User avatar
johans
I've been banned!
Posts: 1293
Joined: Tue Oct 26, 2010 3:54 am
Contact:

Re: HELP! 2.5.8 Administrator blank screen!

Post by johans » Fri Nov 09, 2012 11:08 pm

can you show us the link?

whamprod
Joomla! Intern
Joomla! Intern
Posts: 67
Joined: Tue Jun 17, 2008 9:18 pm

Re: HELP! 2.5.8 Administrator blank screen!

Post by whamprod » Sat Nov 10, 2012 2:48 am


whamprod
Joomla! Intern
Joomla! Intern
Posts: 67
Joined: Tue Jun 17, 2008 9:18 pm

Re: HELP! 2.5.8 Administrator blank screen!

Post by whamprod » Sat Nov 10, 2012 2:40 pm

I guess I'm just going to have to do a complete teardown and rebuild.

WARNING to anyone considering an update from 2.5.7 to 2.5.8...... DON'T DO IT until this issue has been addressed.

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: HELP! 2.5.8 Administrator blank screen!

Post by humvee » Fri Nov 16, 2012 7:42 pm

[Mod note: Moved from General Forum to Upgrade Forum; ]
To help you, in the future, find the correct forum for your topic please read the Which forum to post your question that I have put together.
whamprod wrote:I guess I'm just going to have to do a complete teardown and rebuild.

WARNING to anyone considering an update from 2.5.7 to 2.5.8...... DON'T DO IT until this issue has been addressed.
Firstly that is not the case.
Secondly as with all updates, migrations, changes you should have taken a backup of the site and database before you started. Before you start tearing it down permanently and starting again try the following.

It would appear that the Upgrade process was not completed correctly or was in some way corrupted. Therefore you can reinstall the full package to rectify any omissions.
  1. Backup
    • In the unfortunate event that you have not already done so, backup your site and database now.
  2. Manual Re-installation of Joomla
    1. Download Joomla
    2. Extract the archive
      1. Extract this archive locally on your PC using an archive manager.
        • If on Windows do not use M$ own archive manager - download and install 7-Zip.
        • Do not use M$ Explorer's Copy and Paste or Move options to move the extracted files around either.
      2. Delete the installation/ directory !!Important
    3. Upload the files to the host server
      1. Using your FTP client to upload the files to the host joomla_root/ directory (where Joomla files and directories will be located).
        • Again if you are on Windows do not use M$ own software - download and install either WinSCP or FileZilla.
      2. Ensure the Default Transfer File Type is set to Binary in the Options/Parameters of the client.
      3. CLICK Upload
        • The files must overwrite those in the current joomla_root/ whilst maintaining the same file hierarchy. !!Important
    4. Access the Joomla Administrator Backend
      • Try to access to the site once more.
        • If successful proceed to Completing the Update
        • If not successful report back here with precise details.
    5. Completing the Update
      1. Go to Extensions ⇒ Extension Manager ⇒ Discover tab
        1. CLICK Discover
          • This will show any new extensions that are now available
          • It will also show any old, deprecated one's, particularly if the site was updated from 1.6.x, that have not previously been removed properly. So be aware.
        2. SELECT all the new Extensions only
        3. CLICK Install.
      2. Go to Extensions ⇒ Extension Manager ⇒ Database tab.
        • CLICK Fix
      3. Go to Extensions ⇒ Extension Manager ⇒ Discover tab
        • CLICK Purge Cache
  3. Site Review
    Now check your site and backend and all the features both existing and new to make sure they are working.
    • If all the checks are completed successfully
    • Create a fresh Back up of your site and database.
    • If not report back with any issues.
  4. Backup
    • Create a fresh backup of the site and database and keep this safe so that you have a clean position to return to at this point.
    • Remember to always backup your site before doing any updates, Extension installations, or making any changes that could corrupt your site. If you don't know what the outcome of your actions might be then BACKUP.

anthonyg89
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Dec 22, 2012 7:25 pm

Re: HELP! 2.5.8 Administrator blank screen!

Post by anthonyg89 » Sat Dec 22, 2012 7:32 pm

I am having a similar problem with my site. My main site works fine but just last night i tried to log into the back end and keep getting a blank administration screen when i log in.
You do not have the required permissions to view the files attached to this post.

NlaakALD
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sun Jan 31, 2010 12:17 am

Re: HELP! 2.5.8 Administrator blank screen!

Post by NlaakALD » Wed Jan 09, 2013 4:42 am

I am also now having the problem. Left for dinner with main website working and administration working. Was creating articles before I left. Got back and clicked on menu and it was blank.
- Logged out and back in and still blank.
- Cleared cache (Everything) and still blank.
- Tried IE10, Firefox and Safari.. .all blank.

Help, Just got this setup and 2 months.

Update:
- turned on display_error in php.ini, no errors displayed
- turned on error_log in php.ini, no errors
- used filezilla to prepend a . on all folders not included with joomal 2.5.8 in administrator folder. (safe delete)

Still blank administrator page. Main site works fine.

dergoog
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Jan 10, 2013 3:43 am

Re: HELP! 2.5.8 Administrator blank screen!

Post by dergoog » Thu Jan 10, 2013 4:00 am

I am having the same problem - came out of no where - looking at the log files in the administrator folder I see this:

[10-Jan-2013 03:15:36 UTC] PHP Warning: fputs() expects parameter 1 to be resource, boolean given in /home/xxxxxx/public_html/xxxxxx/libraries/joomla/log/loggers/formattedtext.php on line 254
[10-Jan-2013 03:19:14 UTC] PHP Warning: fopen(/logs/error.php) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: No such file or directory in /home/xxxxxx/public_html/xxxxxx/libraries/joomla/log/loggers/formattedtext.php on line 248
[10-Jan-2013 03:19:14 UTC] PHP Warning: fputs() expects parameter 1 to be resource, boolean given in /home/xxxxxx/public_html/xxxxxx/libraries/joomla/log/loggers/formattedtext.php on line 254

I x'd out our server's private directory names.

Any ideas on what would cause this?

farmeunit
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Sat Dec 24, 2005 12:23 am
Location: Missouri
Contact:

Re: HELP! 2.5.8 Administrator blank screen!

Post by farmeunit » Thu Jan 10, 2013 7:36 pm

We run into a similar issue. We're not sure at what point this actually started, though, as we hadn't done too much with the site.

We upgraded to 3.0 to see if it went away, we got an error about the Nooku framework, which is related to DocMan. We in turn uninstalled LogMan since she remembered installing that recently, and it went away.

Probably not your issue, but check your plugins, and make sure those aren't at fault.

soupn
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Tue Aug 23, 2005 1:45 pm
Location: Amadora
Contact:

Re: HELP! 2.5.8 Administrator blank screen!

Post by soupn » Fri Jan 11, 2013 11:15 am

same problem here. anyone resolved this problem?
Admin Portuguese PT Joomla Community - http://www.joomlapt.com

User avatar
katika555
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sat Dec 01, 2007 12:49 pm

Re: HELP! 2.5.8 Administrator blank screen!

Post by katika555 » Fri Jan 18, 2013 8:30 pm

hi all
Blank page from no where, and in Chrome HTTP Error 500 (Internal Server Error)
Joomla version 2.5.8,
i have found
1. if I turned off plugin System - Language Filter Site work, without languages,
2. and if I change current language Default Page option to No site work...
any Ideas?

User avatar
sohrab330
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 108
Joined: Sat Apr 28, 2012 3:20 pm
Location: TX, US
Contact:

Re: HELP! 2.5.8 Administrator blank screen!

Post by sohrab330 » Wed Apr 24, 2013 3:03 pm

there is a code which you can add at the beginning of the index.php to show the errors. I dont remember it now. I'll post it soon

tamarafield
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Apr 12, 2011 9:41 pm

Re: HELP! 2.5.8 Administrator blank screen!

Post by tamarafield » Fri Nov 08, 2013 7:11 pm

We are having the exact same problem! When trying to login to: www.press8.com/administrator/ first I do get the login screen, I type in my un/pw and get a blank screen! Need help fast!

Error I am getting that I found in error codes in my cpanel:

[Fri Nov 08 12:47:55 2013] [error] [client 220.181.108.77] File does not exist: /home/presscom/public_html/404.shtml
[Fri Nov 08 12:47:55 2013] [error] [client 220.181.108.77] File does not exist: /home/presscom/public_html/cache/widgetkit/widgetkit-08853d8b.css
[Fri Nov 08 12:46:28 2013] [error] [client 174.91.121.219] File does not exist: /home/presscom/public_html/404.shtml
[Fri Nov 08 12:46:28 2013] [error] [client 174.91.121.219] File does not exist: /home/presscom/public_html/https:

I just reloaded a new joomla 3.2 (after deleting the installation directory) and that did not fix the problem.

Need help fast!!

User avatar
sea-horse2
Joomla! Intern
Joomla! Intern
Posts: 65
Joined: Sat Feb 16, 2013 11:45 am

Re: HELP! 2.5.8 Administrator blank screen!

Post by sea-horse2 » Thu Dec 26, 2013 7:45 pm

I have the same problem here , my front-end is OK and I even can front-end login, but administration page is totally blank!

Edit

based on another forum I ran into, I remembered that like him the last thing I did was installing "pinteresting plugin https://extensions.joomla.org/extension ... hare/22249" , so how can I uninstall it without accessing to backend?

Edit 2
disabled mentioned plugin and everything OK! :p

pencilspirit
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Fri Feb 24, 2012 4:51 pm
Contact:

Re: HELP! 2.5.8 Administrator blank screen!

Post by pencilspirit » Mon Sep 22, 2014 11:57 am

I have this problem although i did not change anything, i just let my admin page more than 15 without doing anything. It is anything to do with session ?

pgypps
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Jan 10, 2015 10:13 am

Re: HELP! 2.5.8 Administrator blank screen!

Post by pgypps » Sat Jan 10, 2015 10:17 am

its easy to fix...just type this after your domain name /administrator/index.php?option=com_config
because only control panel is not showing...

go to server tab

Error Reporting - change to developement

go back to control panel and see what addons are causing the issue.


Locked

Return to “Migrating and Upgrading to Joomla! 2.5”