Display a module using render() but no titles ?

General questions relating to Joomla! 2.5. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5. There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Post Reply
User avatar
jfer3
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 136
Joined: Tue Sep 01, 2009 12:10 am
Location: melbourne, australia
Contact:

Display a module using render() but no titles ?

Post by jfer3 » Wed Jul 24, 2013 4:43 am

Hi all,
i am using a method to display a module in the Joomla Blog view under a template. However my code does not display the title. Can anyone please have a look at my code and tell me if there is a way to display the title for this :

This is what I am using:
$document = JFactory::getDocument();
$renderer = $document->loadRenderer('modules');
$position = "categorylist_a";
$options = array('style' => 'raw');
echo $renderer->render($position, $options, null);


thanking you
Joe

ncy
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sun Nov 22, 2015 8:15 pm

Re: Display a module using render() but no titles ?

Post by ncy » Fri May 11, 2018 9:33 pm

Well, I guess this reply is super late, but I came across this post because I had the same question. Changing "raw" to "xhtml" fixed it for me:

Code: Select all

$options = array('style' => 'xhtml');
Reference: https://joomla.stackexchange.com/questi ... ule-styles


Post Reply

Return to “General Questions/New to Joomla! 2.5”