Joomla ignore php.ini

General questions relating to Joomla! 2.5. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5. There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Locked
markrolliss
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Wed Sep 25, 2013 12:09 pm

Joomla ignore php.ini

Post by markrolliss » Wed Sep 25, 2013 12:15 pm

I'm trying to set the max file upload size and created an associated php.ini. When I interrogate with phpinfo both in the root and in the specific directory it returns the NEW file upload size and the new location of php.ini. However when I interrogate joomla 2.5.14 (site/system information) the new php.ini is not recognized and the old location and filesize remain at the default. Can any one help.

 
dermi
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Sat Jul 06, 2013 6:25 am

Re: Joomla ignore php.ini

Post by dermi » Wed Sep 25, 2013 12:43 pm

NOT: If so, just ignore it and press OK. (We're going to change the ports now anyway.)
In order to ensure compatability with php.ini, press the "Configure" link for the PHP Debugger to display the screen below.
http://docs.joomla.org/Configuring_Eclipse_and_Xdebug

http://docs.joomla.org/NetBeans_overview
Joomla! is an award-winning open source CMS for building powerful websites.
http://www.ecctv.ir . http://cantral.ir/panasonic-phone

markrolliss
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Wed Sep 25, 2013 12:09 pm

Re: Joomla ignore php.ini

Post by markrolliss » Wed Sep 25, 2013 3:09 pm

Sorry - I don't think I fully understand this response

Is the system information from joolma wrong?

dermi
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Sat Jul 06, 2013 6:25 am

Re: Joomla ignore php.ini

Post by dermi » Wed Sep 25, 2013 3:31 pm

You should be able to increase it by making the necessary changes to the upload_max_filesize in the php.ini file. If you do not have access to this file, contact your host for assistance.
PHP.INI is not part of Joomla. It belongs to the web server set-up. Create one in the web root or talk to your host about it.

If i create it, write in this file: upload_max_filesize=20M
http://www.php.net/manual/en/ini.core.php

please see this posts:
http://forum.joomla.org/viewtopic.php?p=2427582
http://forum.joomla.org/viewtopic.php?p=1296314
http://forum.joomla.org/viewtopic.php?p=1415739
markrolliss wrote:Is the system information from joolma wrong?
Look into the administrator page, "Global configuration", "System" tab, "Maximum Size (in bytes)" field.
In the Global Configuration, in the tab Systems, in the section Media Settings, change the value of the parameter Maximum Size (in bytes).
Joomla! is an award-winning open source CMS for building powerful websites.
http://www.ecctv.ir . http://cantral.ir/panasonic-phone

markrolliss
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Wed Sep 25, 2013 12:09 pm

Re: Joomla ignore php.ini

Post by markrolliss » Sun Sep 29, 2013 8:46 pm

Hi... Yeah I had already created php.ini just the same as you had suggested and placed it in the root. I also tried it in the Directory where the joomla instance is, but the system information from Joomla won't change, wherever I put the php.ini file. Which is why I asked the question in the first instance. Is there something that could be overriding the manual php.ini

markrolliss
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Wed Sep 25, 2013 12:09 pm

Re: Joomla ignore php.ini

Post by markrolliss » Tue Oct 01, 2013 3:17 pm

OK... It was the hosting provider not me. phew... Thanks for all the advice.

markrolliss
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Wed Sep 25, 2013 12:09 pm

Re: Joomla ignore php.ini

Post by markrolliss » Tue Oct 08, 2013 4:28 pm

OK We are now with a new hosting provider that will support php.ini.

Still I have problems. PHPINFO.PHP will return the NEW upload_max_filesize of 40M.
But when logged in as admin Joomla 1.5.26 the system php info returns 2m. ?
I'm trying to migrate the articles out of this site using j2xml and there's rather a lot of articles which is using up the available resources.

I've also tried to make php.ini recursive in htaccess.txt as follows

SuPHP_ConfigPath /home/username/public_html/php.ini

The above assumes that you are going to replace "username" with your actual cpanel username and that your php.ini file lives inside of public_html.

ANYONE???

 

Locked

Return to “General Questions/New to Joomla! 2.5”