Having issues with installing templates?

General questions relating to Joomla! 2.5. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5. There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Post Reply
duongduythao
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sun Apr 19, 2015 1:53 pm
Contact:

Having issues with installing templates?

Post by duongduythao » Tue Apr 24, 2018 1:31 pm

I have an existing server setup that has the following :

-Debian 8.9
-Nginx 1.12.1
-PHP 5.6.30 (fpm)
-Joomla 2.5.28

Its been a while since I tried to install anything. Right now when I try to install a module from http, upload, or path, it gives me error 502. The log file shows : upstream sent invalid status "-1 Cannot find source folder"

Ive been trying out different nginx and php configurations, but nothings worked so far.

Where is a good place to begin debugging this? I'd really like to get it resolved.

Thanks,

User avatar
AMurray
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3954
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Having issues with installing templates?

Post by AMurray » Wed May 16, 2018 9:38 pm

Possibly are you using a template / extension that is not compatible with Joomla 2.5? Solution: update to Joomla 3.x. J! 2.5 has been end of life for 18 months (since Dec 2016), so I would definitely consider upgrading. https://downloads.joomla.org.

Some other possibilities (not saying these are the solution):

You might possibly be trying to install a "quickstart" package within an existing joomla installation; that would be incorrect - quickstart packages contain joomla already, and install the template and joomla in their own separate installation and not for installing in an existing Joomla. You need the "template only" package.

It might also be an issue with your internet connection.

If your PHP settings for file upload and post limits and max execution time is sufficient I don't know what else to suggest.
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.


Post Reply

Return to “General Questions/New to Joomla! 2.5”