Max php version 2.5.28 can tolerate? Topic is solved

General questions relating to Joomla! 2.5. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5. There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Post Reply
poptop
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Dec 07, 2009 1:07 am

Max php version 2.5.28 can tolerate?

Post by poptop » Wed Dec 26, 2018 2:43 pm

What is the highest PHP version Joomla! 2.5.28 can function with?

Currently using PHP 5.6.36.

Thanks.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26020
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Max php version 2.5.28 can tolerate?

Post by Per Yngve Berg » Wed Dec 26, 2018 3:04 pm

You are at the highest version.

User avatar
AMurray
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4937
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Max php version 2.5.28 can tolerate?

Post by AMurray » Sun Dec 30, 2018 11:32 pm

I can see from Pphp.net that 5.6.39 is the latest...... http://php.net/archive/2018.php#id2018-12-06-2 (released 6th December).

5.6.x basically reaches EOL today 31 December 2018. No further updates will be forthcoming (unless some critical security patch needs to be released). Refer to support time-line: http://php.net/supported-versions.php

The best advice is to upgrade your site to Joomla 3.9.x and start using PHP 7.1 or above.
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

poptop
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Dec 07, 2009 1:07 am

Re: Max php version 2.5.28 can tolerate?

Post by poptop » Fri Jan 04, 2019 4:43 pm

Thx for your replies. I'm using a dev site in a folder on the same server as the live site for a ground-up rebuild to 3.9.x. and needed to know how high a php version I could go and keep the 2.5.28 working. Your answers helped. :)

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 7873
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Max php version 2.5.28 can tolerate?

Post by sozzled » Fri Jan 04, 2019 6:42 pm

Simple answer: PHP 5.6 (or PHP 5.6.36 or PHP 5.6.39 if you want to be more specific) is the only version that you can use to operate a mix of J! 2.5 and J! 3.x websites. You cannot operate J! 2.5 websites with PHP 7; when J! 4 is released (later this year) you cannot operate J! 4 websites on PHP 5.6. Hope that helps.

There is no support for PHP 5.6 (from 31-Dec-2018); there is no support for J! 2.5 from 31-Dec-2014.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19675
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Max php version 2.5.28 can tolerate?

Post by leolam » Thu Jan 17, 2019 8:25 am

sozzled wrote:
Fri Jan 04, 2019 6:42 pm
Simple answer: PHP 5.6 (or PHP 5.6.36 or PHP 5.6.39 if you want to be more specific) is the only version that you can use to operate a mix of J! 2.5 and J! 3.x websites.
That depends. If you use latest cPanel with EasyApache 4 you have multiple PHP and you can assign a specific version to a specific site. For instance on our development servers we use that mechanism: a Joomla 1.0-site to be readied for migration runs on PHP5.4 and a Joomla destination 3.9.2 on the same server runs PHP 7.2

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services


Post Reply

Return to “General Questions/New to Joomla! 2.5”