Line issue

General questions relating to Joomla! 2.5. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5. There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Post Reply
Cesarjan
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Mar 09, 2019 11:03 pm

Line issue

Post by Cesarjan » Sat Mar 09, 2019 11:08 pm

Hey folks

Thanks for taking your time and reading this and thanks for helping us noobies out. Means a lot and dont forget the good karma thingy.

I logged on my site to see this error and I have no idea how to fix it.

Fatal error: 'break' not in the 'loop' or 'switch' context in /customers/f/a/6/wilayah.dk/httpd.www/plugins/system/japopup/popupHelper.php on line 232

this is the line from 230

if (isset($paras['event']) && $paras['event'] == 'loadbody')
$paras['event'] = true;
else
$paras['event'] = false;

All help would be appreciated.

Jan

User avatar
AMurray
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4671
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Line issue

Post by AMurray » Sat Mar 09, 2019 11:26 pm

First thing, please make use of the Forum Post Assistant, the link is in the red box at the top of this thread.
viewtopic.php?f=621&t=582860. Download and upload the fpa_en.php script to your joomla folder then run the script. Instructions are included with the ZIP file on how to generate the report, and copy the information into a reply on this thread. The utility is designed to provide all the technical information we need to answer your question.

From the error, it refers to a Joomla Art plugin (japlugin/popuphelper). This may be part of a JA template, so first suggestion is to seek an update to the template or the plugin from JA's website.

Additionally the error might be because the template, or the plugin are not compatible with your current Joomla version (which should always be the latest anyway, currently it is v3.9.3) and/or it may not be compatible with PHP 7.x. (or whatever your current PHP version is).

Will wait on your response to request for the FPA report before continuing since the report will tell us about your installation and what extensions you have.
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

User avatar
AMurray
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4671
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Line issue

Post by AMurray » Sat Mar 09, 2019 11:43 pm

Also noticed you're using Joomla 2.5 (or at least you posted to the 2.5 forum). That version of Joomla is out of date and obsolete, so it may be difficult to find a fix for this.
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.


Post Reply

Return to “General Questions/New to Joomla! 2.5”