Strict standards...

General questions relating to Joomla! 2.5. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5. There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Post Reply
GBRM
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu May 02, 2019 12:45 am

Strict standards...

Post by GBRM » Thu May 02, 2019 6:24 am

Good morning all... I have found some fab advice on the forum regarding the issue I'm having and I feel like I've tried everything... I haven't been able to locate my php.ini file and make any alterations on that but otherwise I'm now stuck... HELP!!

These are the messages I'm getting below - this is my website: http://www.greatwesternrunners.org.uk/i ... op-results
trict Standards: Only variables should be assigned by reference in /homepages/39/d404267813/htdocs/gwr/components/com_grid/GridBuilder.php on line 29

Strict Standards: Only variables should be assigned by reference in /homepages/39/d404267813/htdocs/gwr/plugins/content/jw_sigpro/jw_sigpro.php on line 51

Strict Standards: Only variables should be assigned by reference in /homepages/39/d404267813/htdocs/gwr/plugins/content/jw_sigpro/jw_sigpro.php on line 52

Strict Standards: Only variables should be assigned by reference in /homepages/39/d404267813/htdocs/gwr/plugins/content/raceresults/raceresults.php on line 22

Strict Standards: Only variables should be assigned by reference in /homepages/39/d404267813/htdocs/gwr/plugins/content/raceresults/raceresults.php on line 38

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11334
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: Strict standards...

Post by toivo » Thu May 02, 2019 6:56 am

Change the level of error reporting in Global Configuration to 'None'.

The other option is to get the latest versions of those third party extensions, if they are still supported, or replace them.

At least the Simple Image Gallery can be found from JED: https://extensions.joomla.org/extension ... e-gallery/
Toivo Talikka, Global Moderator

GBRM
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu May 02, 2019 12:45 am

Re: Strict standards...

Post by GBRM » Thu May 02, 2019 8:03 am

toivo wrote:
Thu May 02, 2019 6:56 am
Change the level of error reporting in Global Configuration to 'None'.

The other option is to get the latest versions of those third party extensions, if they are still supported, or replace them.

At least the Simple Image Gallery can be found from JED: https://extensions.joomla.org/extension ... e-gallery/
Thanks Toivo - I have set the error reporting to None and I still get the message.

How do I go about replacing the extensions??

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11334
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: Strict standards...

Post by toivo » Thu May 02, 2019 8:19 am

You can download the latest version of Simple Image Gallery Pro and install it using the normal method, Extensions - Manage - Install.

If the two other extensions have been developed in-house or if they are no longer supported, it may be possible to fix the PHP code and get rid of the error message.

The other option is to fine tune the php.ini file or add a custom php.ini file to the Joomla folder to stop error messages from getting displayed.

Ref. 1 https://www.php.net/manual/en/errorfunc ... lay-errors
Ref. 2 https://www.a2hosting.co.uk/kb/develope ... .ini-files
Toivo Talikka, Global Moderator


Post Reply

Return to “General Questions/New to Joomla! 2.5”