Joomla 2.5 website (to be updated) doesn't read configuration.php Topic is solved

General questions relating to Joomla! 2.5. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5. There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Post Reply
gabriel3
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Tue May 21, 2019 7:39 am

Joomla 2.5 website (to be updated) doesn't read configuration.php

Post by gabriel3 » Fri Jun 07, 2019 2:54 pm

I'm still brawling with the migration of a J2.5 website to update it to 3.9

Site is up and running, but it seems it doesn't read configuration.php file as "Global Configuration" section is showing lot of empty fields, that aren't saved if I manually enter data into them.
I.e. Site Name or Default Editor in "Site" tab, all database settings on "Server" tab, and so on. All this data is properly specified into configuration.php file.
configuration.php permissions are set to 644.
j25conf.jpg
Any help would be appreciated...
You do not have the required permissions to view the files attached to this post.
Last edited by toivo on Fri Jun 07, 2019 3:20 pm, edited 1 time in total.
Reason: mod note: moved from Migrating and Upgrading to Joomla! 3.x

 
User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11936
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: Joomla 2.5 website (to be updated) doesn't read configuration.php

Post by toivo » Fri Jun 07, 2019 3:25 pm

Please post the results of the Forum Post Assistant (FPA) by following the instructions at viewtopic.php?f=806&t=969442.
Toivo Talikka, Global Moderator

gabriel3
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Tue May 21, 2019 7:39 am

Re: Joomla 2.5 website (to be updated) doesn't read configuration.php

Post by gabriel3 » Mon Jun 10, 2019 9:10 am

Forum Post Assistant (v1.4.8 (koine)) : 10th June 2019 wrote:
Basic Environment :: wrote:Joomla! Instance :: Joomla! 2.5.24-Stable (Ember) 25-July-2014
Joomla! Platform :: Joomla Platform 11.4.0-Stable (Brian Kernighan) 03-Jan-2012
Joomla! Configured :: Yes | Writable (644) | Owner: --protected-- . (uid: 1/gid: 1) | Group: --protected-- (gid: 1) | Valid For: 2.5
Configuration Options :: Offline: false | SEF: true | SEF Suffix: true | SEF ReWrite: true | .htaccess/web.config: Yes | GZip: false | Cache: false | CacheTime: 15 | CacheHandler: file | CachePlatformPrefix: N/A | FTP Layer: false | Proxy: N/A | LiveSite: | Session lifetime: 15 | Session handler: database | Shared sessions: N/A | SSL: 0 | Error Reporting: default | Site Debug: false | Language Debug: false | Default Access: 1 | Unicode Slugs: false | dbConnection Type: mysqli | PHP Supports J! 2.5.24: No | Database Supports J! 2.5.24: Yes | Database Credentials Present: Yes |

Host Configuration :: OS: Linux | OS Version: 3.10.0-862.3.2.el7.x86_64 | Technology: x86_64 | Web Server: Apache | Encoding: gzip, deflate, br | Doc Root: --protected-- | System TMP Writable: Yes | Free Disk Space : 249.94 GiB |

PHP Configuration :: Version: 7.1.28 | PHP API: cgi-fcgi | Session Path Writable: Yes | Display Errors: 1 | Error Reporting: 24567 | Log Errors To: | Last Known Error: | Register Globals: | Magic Quotes: | Safe Mode: | Open Base: | Uploads: 1 | Max. Upload Size: 50M | Max. POST Size: 30M | Max. Input Time: 60 | Max. Execution Time: 900 | Memory Limit: 256M

Database Configuration :: Version: 5.5.61-38.13-log (Client:mysqlnd 5.0.12-dev - 20150407 - $Id: 38fea24f2847fa7519001be390c98ae0acafe387 $) | Host: --protected-- (--protected--) | default Collation: latin1_swedish_ci (default Character Set: latin1) | Database Size: 42.61 MiB | #of Tables:  65
Detailed Environment :: wrote:PHP Extensions :: Core (7.1.28) | date (7.1.28) | libxml (7.1.28) | openssl (7.1.28) | pcre (7.1.28) | sqlite3 (7.1.28) | zlib (7.1.28) | bcmath (7.1.28) | bz2 (7.1.28) | calendar (7.1.28) | ctype (7.1.28) | curl (7.1.28) | dom (20031129) | hash (1.0) | fileinfo (1.0.5) | filter (7.1.28) | ftp (7.1.28) | gd (7.1.28) | gettext (7.1.28) | SPL (7.1.28) | iconv (7.1.28) | session (7.1.28) | intl (1.1.0) | json (1.5.0) | mbstring (7.1.28) | mcrypt (7.1.28) | standard (7.1.28) | mysqlnd (mysqlnd 5.0.12-dev - 20150407 - $Id: 38fea24f2847fa7519001be390c98ae0acafe387 $) | mysqli (7.1.28) | PDO (7.1.28) | pdo_mysql (7.1.28) | pdo_sqlite (7.1.28) | Phar (2.0.2) | posix (7.1.28) | Reflection (7.1.28) | imap (7.1.28) | SimpleXML (7.1.28) | soap (7.1.28) | exif (7.1.28) | tidy (7.1.28) | tokenizer (7.1.28) | wddx (7.1.28) | xml (7.1.28) | xmlreader (7.1.28) | xmlrpc (7.1.28) | xmlwriter (7.1.28) | xsl (7.1.28) | zip (1.13.5) | cgi-fcgi () | imagick (3.4.3) | raphf (2.0.0) | propro (2.1.0) | SourceGuardian (11.2) | ionCube Loader () | Zend Engine (3.1.0) |
Potential Missing Extensions ::
Disabled Functions :: system | popen | dl | passthru | proc_open | shell_exec |

Switch User Environment (Experimental) :: PHP CGI: Yes | Server SU: Yes | PHP SU: Yes | Custom SU (LiteSpeed/Cloud/Grid): Yes
Potential Ownership Issues: No
Folder Permissions :: wrote:Core Folders :: images/ (755) | components/ (755) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (755) | logs/ (755) | tmp/ (755) | administrator/components/ (755) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) | administrator/logs/ (---) |

Elevated Permissions (First 10) ::
Database Information :: wrote:Database statistics :: Uptime: 23905219 | Threads: 26 | Questions: 33166084306 | Slow queries: 21838 | Opens: 1441940384 | Flush tables: 19 | Open tables: 129 | Queries per second avg: 1387.399 |
Extensions Discovered :: wrote:Components :: SITE ::
Core :: com_mailto (2.5.0) 1 | com_wrapper (2.5.0) 1 |
3rd Party::

Components :: ADMIN ::
Core :: com_admin (2.5.0) 1 | com_banners (2.5.0) 1 | com_cache (2.5.0) 1 | com_categories (2.5.0) 1 | com_checkin (2.5.0) 1 | com_config (2.5.0) 1 | com_content (2.5.0) 1 | com_cpanel (2.5.0) 1 | com_finder (2.5.0) 1 | com_installer (2.5.0) 1 | com_joomlaupdate (2.5.0) 1 | com_languages (2.5.0) 1 | com_login (2.5.0) 1 | com_media (2.5.0) 1 | com_menus (2.5.0) 1 | com_messages (2.5.0) 1 | com_modules (2.5.0) 1 | com_newsfeeds (2.5.0) 1 | com_plugins (2.5.0) 1 | com_redirect (2.5.0) 1 | com_search (2.5.0) 1 | com_templates (2.5.0) 1 | com_users (2.5.0) 1 | com_weblinks (2.5.0) 1 |
3rd Party:: Akeeba (4.7.5) ? |

Modules :: SITE ::
Core :: mod_articles_archive (2.5.0) 1 | mod_articles_categories (2.5.0) 1 | mod_articles_category (2.5.0) 1 | mod_articles_latest (2.5.0) 1 | mod_articles_news (2.5.0) 1 | mod_articles_popular (2.5.0) 1 | mod_banners (2.5.0) 1 | mod_breadcrumbs (2.5.0) 1 | mod_custom (2.5.0) 1 | mod_feed (2.5.0) 1 | mod_finder (2.5.0) 1 | mod_footer (2.5.0) 1 | mod_languages (2.5.0) 1 | mod_login (2.5.0) 1 | mod_menu (2.5.0) 1 | mod_random_image (2.5.0) 1 | mod_related_items (2.5.0) 1 | mod_search (2.5.0) 1 | mod_stats (2.5.0) 1 | mod_syndicate (2.5.0) 1 | mod_users_latest (2.5.0) 1 | mod_weblinks (2.5.0) 1 | mod_whosonline (2.5.0) 1 | mod_wrapper (2.5.0) 1 |
3rd Party:: mod_news_pro_gk4 (3.4.1) 1 | [spam] (6.3) 1 |

Modules :: ADMIN ::
Core :: mod_custom (2.5.0) 1 | mod_feed (2.5.0) 1 | mod_latest (2.5.0) 1 | mod_logged (2.5.0) 1 | mod_login (2.5.0) 1 | mod_menu (2.5.0) 1 | mod_multilangstatus (2.5.0) 1 | mod_popular (2.5.0) 1 | mod_quickicon (2.5.0) 1 | mod_status (2.5.0) 1 | mod_submenu (2.5.0) 1 | mod_title (2.5.0) 1 | mod_toolbar (2.5.0) 1 | mod_version (2.5.0) 1 |
3rd Party::

Libraries :: SITE ::
Core ::
3rd Party::

Plugins :: SITE ::
Core :: plg_authentication_gmail (2.5.0) 0 | plg_authentication_joomla (2.5.0) 1 | plg_authentication_ldap (2.5.0) 0 | plg_captcha_recaptcha (2.5.0) 1 | plg_content_emailcloak (2.5.0) 1 | plg_content_finder (2.5.0) 0 | plg_content_geshi (2.5.0) 0 | plg_content_joomla (2.5.0) 1 | plg_content_loadmodule (2.5.0) 1 | plg_content_pagebreak (2.5.0) 1 | plg_content_pagenavigation (2.5.0) 1 | plg_content_vote (2.5.0) 1 | plg_editors-xtd_article (2.5.0) 1 | plg_editors-xtd_image (2.5.0) 1 | plg_editors-xtd_pagebreak (2.5.0) 1 | plg_editors-xtd_readmore (2.5.0) 1 | plg_extension_joomla (2.5.0) 1 | plg_finder_categories (2.5.0) 1 | plg_finder_contacts (2.5.0) 1 | plg_finder_content (2.5.0) 1 | plg_finder_newsfeeds (2.5.0) 1 | plg_finder_weblinks (2.5.0) 1 | plg_quickicon_extensionupdate (2.5.0) 1 | plg_quickicon_joomlaupdate (2.5.0) 1 | plg_search_categories (2.5.0) 1 | plg_search_contacts (2.5.0) 1 | plg_search_content (2.5.0) 1 | plg_search_newsfeeds (2.5.0) 1 | plg_search_weblinks (2.5.0) 1 | plg_system_cache (2.5.0) 0 | plg_system_debug (2.5.0) 1 | plg_system_highlight (2.5.0) 1 | plg_system_languagecode (2.5.0) 0 | plg_system_languagefilter (2.5.0) 0 | plg_system_log (2.5.0) 1 | plg_system_logout (2.5.0) 1 | plg_system_p3p (2.5.0) 1 | plg_system_redirect (2.5.0) 1 | plg_system_remember (2.5.0) 1 | plg_system_sef (2.5.0) 1 | plg_user_contactcreator (2.5.0) 0 | plg_user_joomla (2.5.0) 1 | plg_user_profile (2.5.0) 0 |
3rd Party:: plg_editors_codemirror (1.0) 1 | plg_editors_tinymce (3.5.4.1) 1 | plg_quickicon_akeebabackup (1.0) 1 | PLG_SYSTEM_BACKUPONUPDATE_TITLE (3.7) 1 | System - HD-OG (3.2) 1 | PLG_JMONITORING_AKEEBABACKUP_TITLE (1.0) 1 |
Templates Discovered :: wrote:Templates :: SITE :: atomic (2.5.0) 1 | beez5 (2.5.0) 1 | beez_20 (2.5.0) 1 | magazine3000 (2.5.0) 1 |
Templates :: ADMIN :: bluestork (2.5.0) 1 | hathor (2.5.0) 1 |
Here it is. Thank you!

gabriel3
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Tue May 21, 2019 7:39 am

Re: Joomla 2.5 website (to be updated) doesn't read configuration.php

Post by gabriel3 » Mon Jun 10, 2019 10:01 am

Probably it is a problem tied with php version?
On the same space/domain I have a J3 website running, so PHP is 7.x

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11936
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: Joomla 2.5 website (to be updated) doesn't read configuration.php

Post by toivo » Mon Jun 10, 2019 10:16 am

Yes, Joomla 2.5 is not supported on PHP 7.
Ref. https://downloads.joomla.org/technical-requirements
Toivo Talikka, Global Moderator

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26437
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Joomla 2.5 website (to be updated) doesn't read configuration.php

Post by Per Yngve Berg » Mon Jun 10, 2019 1:50 pm

You are also behind in updating. The last version is 2.5.28.

https://downloads.joomla.org/cms/joomla ... format=zip

gabriel3
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Tue May 21, 2019 7:39 am

Re: Joomla 2.5 website (to be updated) doesn't read configuration.php

Post by gabriel3 » Tue Jun 11, 2019 2:31 pm

Thanks, I solved changing PHP version on the server.
I was also unable to update to 2.5.28 due to this.

Thanks!

 

Post Reply

Return to “General Questions/New to Joomla! 2.5”