Joomla V2.5.11 Upgrade Php from 5.6 to 7.2 Error 500

General questions relating to Joomla! 2.5. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5. There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Post Reply
andrevorster
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Dec 10, 2007 10:44 am

Joomla V2.5.11 Upgrade Php from 5.6 to 7.2 Error 500

Post by andrevorster » Wed Sep 04, 2019 10:14 am

Hey Guys and Gals
Please excuse me if this has been posted in the wrong section. I did look for about an hour and I did research where to post and couldn't find anywhere else. :( Now onto my issue.

Website: http://schizophrenia.co.za/
Version: 2.5.11
Current PHP Version: 5.6

I am currently trying to update all my clients old Joomla 2.5 websites php to 7.2. They seem to all be breaking. Most of them end up with :

Warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /usr/www/users/schizoy/libraries/joomla/filter/input.php on line 652 Warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /usr/www/users/schizoy/libraries/joomla/filter/input.php on line 654 Warning: session_cache_limiter(): Cannot change cache limiter when headers already sent in /usr/www/users/schizoy/libraries/joomla/session/session.php on line 531 Warning: session_start(): Cannot start session when headers already sent in /usr/www/users/schizoy/libraries/joomla/session/session.php on line 532 Duplicate entry '' for key 'PRIMARY' SQL=INSERT INTO `m2dkv_session` (`session_id`, `client_id`, `time`) VALUES ('', 0, '1567586979')

I understand this means it is depreciated and wont work with my database. Is there any other fix to this other than updating to Joomla V 3 and up? Is there a replacement for those files. Is there a simple fix to this issue so that we can move the sites over to 7.2 without breaking the site and with out upgrading.

I have updated the configuration.php to have sqli instead of sql and removed the .htaccess information these changes sadly haven't worked.

Can any one shed some light on this?

Thanks in advanced :)
Last edited by toivo on Wed Sep 04, 2019 10:36 am, edited 1 time in total.
Reason: mod note: moved from Joomla 3.x

 
User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26400
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Joomla V2.5.11 Upgrade Php from 5.6 to 7.2 Error 500

Post by Per Yngve Berg » Wed Sep 04, 2019 11:39 am

2.5 does not run on php 7.x
2.5.28 was released December 2014 when the 2.5 series went EOL.
The current version 3.9.11 does.

andrevorster
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Dec 10, 2007 10:44 am

Re: Joomla V2.5.11 Upgrade Php from 5.6 to 7.2 Error 500

Post by andrevorster » Wed Sep 04, 2019 12:12 pm

Per Yngve Berg wrote:
Wed Sep 04, 2019 11:39 am
2.5 does not run on php 7.x
2.5.28 was released December 2014 when the 2.5 series went EOL.
The current version 3.9.11 does.
Hey Yngve

Appreciate your reply. So just to make 100% sure there is no way other than to update to V3 of joomla if I am to upgrade my version of php to 7.2 and have the website work.

Regards

 

Post Reply

Return to “General Questions/New to Joomla! 2.5”