Page 1 of 1

New here and advice needed

Posted: Sat May 09, 2020 6:35 am
by N32
Good morning and congrats on your forum. I am the owner of a joomla site version 2.5.28, which i haven't changed for ages.
Yesteday i wanted to add a couple of articles, wrote them, published them (at least that's what i thought), but they do not come to the site itself.
Is there an upgrade needed? If yes, what is the procedure?
regards
Nicolas

Re: New here and advice needed

Posted: Sat May 09, 2020 6:40 am
by gws
Welcome to the forum. A good place to start would be viewtopic.php?f=710&t=793171.
You are many versions of joomla out of date,currently we are 3.9.18.

Re: New here and advice needed

Posted: Sat May 09, 2020 7:28 am
by Webdongle
Often files from 3rd party extensions (even when they are compatible) can interfere with the migration from 2.5 to 3.x. If that occurs then you can use viewtopic.php?f=714&t=946026 to migrate.

Re: New here and advice needed

Posted: Sat May 09, 2020 7:53 am
by N32
Thank you for your fast replies and for welcoming. Is this a procedure an amateur can make? I mean, yes i can add some articles in general, but i am not an IT.
The links only suggest to backup, but not in detail. Any how to guide for this?

Re: New here and advice needed

Posted: Sat May 09, 2020 8:12 am
by Webdongle
https://docs.joomla.org/Backup_Basics_f ... !_Web_Site

So long as your database is safe then your site is safe.

Re: New here and advice needed

Posted: Sat May 09, 2020 11:02 am
by N32
thank you, will try and get back.

Re: New here and advice needed

Posted: Mon May 11, 2020 7:11 am
by N32
Hello gents. I did the procedure, it looks updated, but when you click on the site name, it doesn't come to view.. Any thoughts?

Re: New here and advice needed

Posted: Mon May 11, 2020 8:59 am
by Webdongle
N32 wrote:
Mon May 11, 2020 7:11 am
... when you click on the site name, it doesn't come to view....
What does it do (N.B. 'nothing is not an option).

Re: New here and advice needed

Posted: Mon May 11, 2020 9:17 am
by N32
"nothing" :)
blank page..
On the taskbar, just where i put the address i can see a lock.

plus..i receive the following message on the control panel

"Error
We have detected that your server is using PHP 5.4.45 which is obsolete and no longer receives official security updates by its developers. The Joomla! Project recommends upgrading your site to PHP 7.2 or later which will receive security updates at least until 2020-11-30. Please ask your host to make PHP 7.2 or a later version the default version for your site. If your host is already PHP 7.2 ready please enable PHP 7.2 on your site's root and 'administrator' directories – typically you can do this yourself through a tool in your hosting control panel, but it's best to ask your host if you are unsure."

Re: New here and advice needed

Posted: Mon May 11, 2020 9:33 am
by Webdongle
When you have updated viewtopic.php?f=710&t=793171 then post back with the results of https://forumpostassistant.github.io/docs/ please

Re: New here and advice needed

Posted: Mon May 11, 2020 9:34 am
by N32
contacted my hosting provider, and get back!

Re: New here and advice needed

Posted: Mon May 11, 2020 12:30 pm
by Webdongle
Doubtful that your Host will update Joomla or 3rd party extensions ... that is your responsibility. If they update the php version to 7.x before you have updated Joomla then your site won't work.

Re: New here and advice needed

Posted: Mon May 11, 2020 1:01 pm
by N32
I updated the site to 3x, then i updated the php from the hosting. Still i cannot see my site..

I got a message from the hosting compny who told me that one of the plugins must not be compatible to the php vesrion. But on the plugin list there are approx 50 plugins. How can someone detece the faulty one?

Re: New here and advice needed

Posted: Mon May 11, 2020 2:59 pm
by gws

Re: New here and advice needed

Posted: Tue May 12, 2020 12:28 pm
by Webdongle
N32 wrote:
Mon May 11, 2020 1:01 pm
...
I got a message from the hosting compny who told me that one of the plugins must not be compatible to the php vesrion. But on the plugin list there are approx 50 plugins. How can someone detece the faulty one?
In the database order by id descending and the 3rd part extensions should be at the top. Disable all the 3rd party extensions then check see if the site works ... if it does then log in and enable one by one. (or disable one at a time).

Re: New here and advice needed

Posted: Tue May 12, 2020 11:18 pm
by AMurray
Webdongle wrote:
Sat May 09, 2020 7:28 am
Often files from 3rd party extensions (even when they are compatible) can interfere with the migration from 2.5 to 3.x. If that occurs then you can use viewtopic.php?f=714&t=946026 to migrate.
That's the "recover from a hack" link not the Step by Step migration guide...???

Re: New here and advice needed

Posted: Tue May 12, 2020 11:54 pm
by Webdongle
AMurray wrote:
Tue May 12, 2020 11:18 pm
...

That's the "recover from a hack" link not the...
Yes it is and it is a method that works for migration and for rebuilding a broken site. When 3rd party extension files prevent migrating then:
1. Using fresh Joomla files (of the same version) can be used to update the database without corrupt 3rd party files interfering.
And
2. A fresh Joomla install can be used to create fresh Joomla/3rdparty files.
3.Connecting the fresh Joomla/3rdparty files to the updated database recreates the site.