Please, HELP! The Images don't appear on the website.

Discussion regarding Joomla! 2.5 Performance issues.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
Dalens
Joomla! Intern
Joomla! Intern
Posts: 71
Joined: Fri Oct 08, 2010 7:28 am

Please, HELP! The Images don't appear on the website.

Post by Dalens » Thu Jun 23, 2011 4:15 pm

Hello,

I hope somebody would help me.
The pictures on my website do only appear on the frontpage. On all other pages they are marked with a red kors and images' names.

I could find out, that the root of the problem is that images are not being called from the proper location in either the theme, or in the modules calling them. I need to have the proper path adjusted, forcing images to use the absolute path rather than the relative path.
My question is: which file should be corrected and what exactly should I change?

Thank you in advance!

 
User avatar
imanickam
Joomla! Master
Joomla! Master
Posts: 27431
Joined: Wed Aug 13, 2008 2:57 am
Location: Chennai, India

Re: Please, HELP! The Images don't appear on the website.

Post by imanickam » Thu Jun 23, 2011 4:34 pm

To answer your question, others have to review the code generated for your site. What is your site's URL?
Ilagnayeru (MIG) Manickam | இளஞாயிறு மாணிக்கம்
Joomla! - Global Moderators Team | Translations Coordination Team | Tamil (தமிழ்) Translation Team

Eegan - Support the poor and underprivileged

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 38235
Joined: Sat Apr 05, 2008 9:58 pm

Re: Please, HELP! The Images don't appear on the website.

Post by Webdongle » Thu Jun 23, 2011 4:36 pm

Also, have you altered the path anywhere before the problem occurred ?

What changes did you make before the problem occurred ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

Dalens
Joomla! Intern
Joomla! Intern
Posts: 71
Joined: Fri Oct 08, 2010 7:28 am

Re: Please, HELP! The Images don't appear on the website.

Post by Dalens » Thu Jun 23, 2011 4:59 pm

I have activated cache plugin, and then the problem occurred. And even though I deactiveted cache, the problem still is here...
The website is www.petitbrabancon.net

Thank you!

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 38235
Joined: Sat Apr 05, 2008 9:58 pm

Re: Please, HELP! The Images don't appear on the website.

Post by Webdongle » Thu Jun 23, 2011 5:13 pm

Images display on my Browser

Clear your Browser cache also use another Browser to view the site.
Screenshot-501.png
You do not have the required permissions to view the files attached to this post.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

Dalens
Joomla! Intern
Joomla! Intern
Posts: 71
Joined: Fri Oct 08, 2010 7:28 am

Re: Please, HELP! The Images don't appear on the website.

Post by Dalens » Thu Jun 23, 2011 6:05 pm

I did so.
And I can see the pictures on the frontpage too. But not on the other pages!

User avatar
brian
Joomla! Master
Joomla! Master
Posts: 11886
Joined: Fri Aug 12, 2005 7:19 am
Location: Leeds, UK
Contact:

Re: Please, HELP! The Images don't appear on the website.

Post by brian » Thu Jun 23, 2011 6:22 pm

The images in the top modules are indeed missing on the internal pages. This is because the template is setting the incorrect base href
"Exploited yesterday... Hacked tomorrow"
Blog http://brian.teeman.net/
Joomla Hidden Secrets http://hiddenjoomlasecrets.com/

Dalens
Joomla! Intern
Joomla! Intern
Posts: 71
Joined: Fri Oct 08, 2010 7:28 am

Re: Please, HELP! The Images don't appear on the website.

Post by Dalens » Thu Jun 23, 2011 6:27 pm

Please, could you suggest how to correct it? I am sorry, I am not so expierenced with Joomla...

Thank you!

User avatar
OOmNezar
Joomla! Ace
Joomla! Ace
Posts: 1870
Joined: Mon Sep 07, 2009 3:18 am

Re: Please, HELP! The Images don't appear on the website.

Post by OOmNezar » Thu Jun 23, 2011 6:35 pm

What page ? image show up in other page
coffee & smoke just fine
OOm Nezar

Dalens
Joomla! Intern
Joomla! Intern
Posts: 71
Joined: Fri Oct 08, 2010 7:28 am

Re: Please, HELP! The Images don't appear on the website.

Post by Dalens » Thu Jun 23, 2011 6:39 pm

I have tried with different browsers, images are missing on the internal pages.

User avatar
OOmNezar
Joomla! Ace
Joomla! Ace
Posts: 1870
Joined: Mon Sep 07, 2009 3:18 am

Re: Please, HELP! The Images don't appear on the website.

Post by OOmNezar » Thu Jun 23, 2011 6:46 pm

Already renamed htaccess.txt to .htaccess ?
Or try what happen if SEF OFF
coffee & smoke just fine
OOm Nezar

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 38235
Joined: Sat Apr 05, 2008 9:58 pm

Re: Please, HELP! The Images don't appear on the website.

Post by Webdongle » Thu Jun 23, 2011 6:57 pm

OK I've seen this problem before the path images/ is not followed but /images/ is. Check your
'System - SEF plugin' is Enabled.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

Dalens
Joomla! Intern
Joomla! Intern
Posts: 71
Joined: Fri Oct 08, 2010 7:28 am

Re: Please, HELP! The Images don't appear on the website.

Post by Dalens » Thu Jun 23, 2011 7:03 pm

Guys, you are great! It worked! All the pictures show up again.
Thank you very much!

Greetings,
Diana

 

Locked

Return to “Performance - Joomla! 2.5”